Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema Optirun con Nvidia (SOLVED-SOLUTION HERE)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Pipeng
n00b
n00b


Joined: 23 Jul 2013
Posts: 8

PostPosted: Mon Nov 04, 2013 1:59 am    Post subject: Problema Optirun con Nvidia (SOLVED-SOLUTION HERE) Reply with quote

Hola, hace poco instale gentoo, y no logro echar andar el comando optirun glxgears, el error que me aparece es:

Code:
[ 3365.529733] [INFO]Configured driver: nvidia
[ 3370.173697] [INFO]Response: No - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please

[ 3370.173719] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please

[ 3370.173732] [ERROR]Aborting because fallback start is disabled.


Este es mi make.conf

Code:
CFLAGS="-O2 -pipe -march=native"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
USE="cpudetection icu minizip acpi gbm X python xa libkms bindist mmx sse sse2 udev gtk dbus gnome qt4 dvd alsa dri sna cdr networkmanager"
MAKEOPTS="-j8"
GENTOO_MIRRORS="http://gentoo.localhost.net.ar"
VIDEO_CARDS="i965 i915 intel nvidia"
INPUT_DEVICES="evdev synaptics mouse"
LINGUAS="es"
PORTDIR="/usr/portage"
ACCEPT_LICENSE="*"


Este es el log del Xorg

Code:
[  3365.531]
X.Org X Server 1.14.3
Release Date: 2013-09-12
[  3365.531] X Protocol Version 11, Revision 0
[  3365.531] Build Operating System: Linux 3.2.46 x86_64 Gentoo
[  3365.531] Current Operating System: Linux Pipe-Pc 3.10.17-gentoo #1 SMP Sun Nov 3 18:35:22 CLST 2013 x86_64
[  3365.531] Kernel command line: BOOT_IMAGE=/boot/kernel-genkernel-x86_64-3.10.17-gentoo root=/dev/sda8
[  3365.531] Build Date: 02 November 2013  08:57:37PM
[  3365.531] 
[  3365.531] Current version of pixman: 0.30.2
[  3365.531]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  3365.531] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  3365.531] (==) Log file: "/var/log/Xorg.8.log", Time: Sun Nov  3 22:42:15 2013
[  3365.531] (++) Using config file: "/etc/bumblebee/xorg.conf.nvidia"
[  3365.531] (++) Using config directory: "/etc/bumblebee/xorg.conf.d"
[  3365.531] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  3365.531] (==) ServerLayout "Layout0"
[  3365.531] (==) No screen section available. Using defaults.
[  3365.531] (**) |-->Screen "Default Screen Section" (0)
[  3365.531] (**) |   |-->Monitor "<default monitor>"
[  3365.531] (==) No device specified for screen "Default Screen Section".
   Using the first device section listed.
[  3365.531] (**) |   |-->Device "DiscreteNvidia"
[  3365.531] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[  3365.531] (**) Option "AutoAddDevices" "false"
[  3365.532] (**) Option "AutoAddGPU" "false"
[  3365.532] (**) Not automatically adding devices
[  3365.532] (==) Automatically enabling devices
[  3365.532] (**) Not automatically adding GPU devices
[  3365.532] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[  3365.532]    Entry deleted from font path.
[  3365.532] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  3365.532]    Entry deleted from font path.
[  3365.532] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  3365.532]    Entry deleted from font path.
[  3365.532] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  3365.532]    Entry deleted from font path.
[  3365.532] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[  3365.532]    Entry deleted from font path.
[  3365.532] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[  3365.532]    Entry deleted from font path.
[  3365.532] (==) FontPath set to:
   
[  3365.532] (++) ModulePath set to "/usr/lib64/opengl/nvidia/lib,/usr/lib64/opengl/nvidia/extensions,/usr/lib64/xorg/modules/drivers,/usr/lib64/xorg/modules"
[  3365.532] (==) |-->Input Device "<default pointer>"
[  3365.532] (==) |-->Input Device "<default keyboard>"
[  3365.532] (==) The core pointer device wasn't specified explicitly in the layout.
   Using the default mouse configuration.
[  3365.532] (==) The core keyboard device wasn't specified explicitly in the layout.
   Using the default keyboard configuration.
[  3365.532] (II) Loader magic: 0x808c00
[  3365.532] (II) Module ABI versions:
[  3365.532]    X.Org ANSI C Emulation: 0.4
[  3365.532]    X.Org Video Driver: 14.1
[  3365.532]    X.Org XInput driver : 19.1
[  3365.532]    X.Org Server Extension : 7.0
[  3365.532] (II) xfree86: Adding drm device (/dev/dri/card1)
[  3365.532] (II) xfree86: Adding drm device (/dev/dri/card0)
[  3365.532] setversion 1.4 failed
[  3365.533] (--) PCI:*(0:1:0:0) 10de:0fdf:1043:1477 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[  3365.533] Initializing built-in extension Generic Event Extension
[  3365.533] Initializing built-in extension SHAPE
[  3365.533] Initializing built-in extension MIT-SHM
[  3365.533] Initializing built-in extension XInputExtension
[  3365.533] Initializing built-in extension XTEST
[  3365.533] Initializing built-in extension BIG-REQUESTS
[  3365.533] Initializing built-in extension SYNC
[  3365.533] Initializing built-in extension XKEYBOARD
[  3365.533] Initializing built-in extension XC-MISC
[  3365.533] Initializing built-in extension XINERAMA
[  3365.533] Initializing built-in extension XFIXES
[  3365.533] Initializing built-in extension RENDER
[  3365.533] Initializing built-in extension RANDR
[  3365.533] Initializing built-in extension COMPOSITE
[  3365.533] Initializing built-in extension DAMAGE
[  3365.533] Initializing built-in extension MIT-SCREEN-SAVER
[  3365.533] Initializing built-in extension DOUBLE-BUFFER
[  3365.533] Initializing built-in extension RECORD
[  3365.533] Initializing built-in extension DPMS
[  3365.533] Initializing built-in extension X-Resource
[  3365.533] Initializing built-in extension XVideo
[  3365.533] Initializing built-in extension XVideo-MotionCompensation
[  3365.533] Initializing built-in extension XFree86-VidModeExtension
[  3365.533] Initializing built-in extension XFree86-DGA
[  3365.533] Initializing built-in extension XFree86-DRI
[  3365.533] Initializing built-in extension DRI2
[  3365.533] (II) LoadModule: "glx"
[  3365.533] (II) Loading /usr/lib64/opengl/nvidia/extensions/libglx.so
[  3365.540] (II) Module glx: vendor="NVIDIA Corporation"
[  3365.540]    compiled for 4.0.2, module version = 1.0.0
[  3365.540]    Module class: X.Org Server Extension
[  3365.540] (II) NVIDIA GLX Module  325.15  Wed Jul 31 18:12:00 PDT 2013
[  3365.540] Loading extension GLX
[  3365.540] (II) LoadModule: "nvidia"
[  3365.540] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[  3365.540] (II) Module nvidia: vendor="NVIDIA Corporation"
[  3365.540]    compiled for 4.0.2, module version = 1.0.0
[  3365.540]    Module class: X.Org Video Driver
[  3365.540] (II) LoadModule: "mouse"
[  3365.540] (II) Loading /usr/lib64/xorg/modules/input/mouse_drv.so
[  3365.540] (II) Module mouse: vendor="X.Org Foundation"
[  3365.540]    compiled for 1.14.3, module version = 1.9.0
[  3365.540]    Module class: X.Org XInput Driver
[  3365.540]    ABI class: X.Org XInput driver, version 19.1
[  3365.540] (II) LoadModule: "kbd"
[  3365.540] (WW) Warning, couldn't open module kbd
[  3365.540] (II) UnloadModule: "kbd"
[  3365.541] (II) Unloading kbd
[  3365.541] (EE) Failed to load module "kbd" (module does not exist, 0)
[  3365.541] (II) NVIDIA dlloader X Driver  325.15  Wed Jul 31 17:50:57 PDT 2013
[  3365.541] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  3365.541] (--) using VT number 7

[  3365.541] (II) Loading sub module "fb"
[  3365.541] (II) LoadModule: "fb"
[  3365.541] (II) Loading /usr/lib64/xorg/modules/libfb.so
[  3365.541] (II) Module fb: vendor="X.Org Foundation"
[  3365.541]    compiled for 1.14.3, module version = 1.0.0
[  3365.541]    ABI class: X.Org ANSI C Emulation, version 0.4
[  3365.541] (WW) Unresolved symbol: fbGetGCPrivateKey
[  3365.541] (II) Loading sub module "wfb"
[  3365.541] (II) LoadModule: "wfb"
[  3365.541] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[  3365.541] (II) Module wfb: vendor="X.Org Foundation"
[  3365.541]    compiled for 1.14.3, module version = 1.0.0
[  3365.541]    ABI class: X.Org ANSI C Emulation, version 0.4
[  3365.541] (II) Loading sub module "shadow"
[  3365.541] (II) LoadModule: "shadow"
[  3365.541] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[  3365.541] (II) Module shadow: vendor="X.Org Foundation"
[  3365.541]    compiled for 1.14.3, module version = 1.1.0
[  3365.541]    ABI class: X.Org ANSI C Emulation, version 0.4
[  3365.541] (II) Loading sub module "ramdac"
[  3365.541] (II) LoadModule: "ramdac"
[  3365.541] (II) Module "ramdac" already built-in
[  3365.541] (II) NVIDIA(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[  3365.541] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[  3365.541] (==) NVIDIA(0): RGB weight 888
[  3365.541] (==) NVIDIA(0): Default visual is TrueColor
[  3365.541] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  3365.541] (**) NVIDIA(0): Option "NoLogo" "true"
[  3365.541] (**) NVIDIA(0): Option "ProbeAllGpus" "false"
[  3365.541] (**) NVIDIA(0): Option "UseEDID" "false"
[  3365.541] (**) NVIDIA(0): Option "UseDisplayDevice" "none"
[  3365.541] (**) NVIDIA(0): Enabling 2D acceleration
[  3365.541] (**) NVIDIA(0): Ignoring EDIDs
[  3365.541] (**) NVIDIA(0): Option "UseDisplayDevice" set to "none"; enabling NoScanout
[  3365.541] (**) NVIDIA(0):     mode
[  3370.172] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please
[  3370.172] (EE) NVIDIA(0):     check your system's kernel log for additional error
[  3370.172] (EE) NVIDIA(0):     messages and refer to Chapter 8: Common Problems in the
[  3370.172] (EE) NVIDIA(0):     README for additional information.
[  3370.172] (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
[  3370.172] (EE) NVIDIA(0): Failing initialization of X screen 0
[  3370.172] (II) UnloadModule: "nvidia"
[  3370.172] (II) UnloadSubModule: "shadow"
[  3370.172] (II) UnloadSubModule: "wfb"
[  3370.172] (II) UnloadSubModule: "fb"
[  3370.172] (EE) Screen(s) found, but none have a usable configuration.
[  3370.172] (EE)
Fatal server error:
[  3370.172] (EE) no screens found(EE)
[  3370.172] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  3370.172] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
[  3370.172] (EE)
[  3370.172] (EE) Server terminated with error (1). Closing log file.


Este es el fragmento que se ejecuto tras la operacion del archivo messages

Code:
Nov  3 22:42:15 Pipe-Pc kernel: vgaarb: this pci device is not a vga device
Nov  3 22:42:15 Pipe-Pc kernel: nvidia 0000:01:00.0: irq 46 for MSI/MSI-X
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: [XORG] (WW) Unresolved symbol: fbGetGCPrivateKey
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: [XORG] (EE) NVIDIA(0):     check your system's kernel log for additional error
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: [XORG] (EE) NVIDIA(0):     messages and refer to Chapter 8: Common Problems in the
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: [XORG] (EE) NVIDIA(0):     README for additional information.
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: [XORG] (EE) NVIDIA(0): Failing initialization of X screen 0
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: [XORG] (EE) Screen(s) found, but none have a usable configuration.
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: [XORG] (EE)
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: [XORG] (EE) no screens found(EE)
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: [XORG] (EE)
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: [XORG] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: [XORG] (EE)
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: [XORG] (EE) Server terminated with error (1). Closing log file.
Nov  3 22:42:20 Pipe-Pc bumblebeed[16315]: X did not start properly
Nov  3 22:42:20 Pipe-Pc kernel: NVRM: RmInitAdapter failed! (0x24:0x38:1131)
Nov  3 22:42:20 Pipe-Pc kernel: NVRM: rm_init_adapter(0) failed


Este es mi lspci

Code:

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation Device 0fdf (rev a1)
03:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
04:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 0a)


Este es mi bumblebee.conf

Code:
# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=true
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/primus:/usr/lib32/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
PMMethod=bbswitch
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib64/opengl/nvidia/lib:/usr/lib32/opengl/nvidia/lib:/usr/lib/opengl/nvidia/lib
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib64/opengl/nvidia/lib,/usr/lib64/opengl/nvidia/extensions,/usr/lib64/xorg/modules/drivers,/usr/lib64/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau


Y esta es mi configuracion del Xorg para Nvidia

Code:
Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
    Option      "AutoAddGPU" "false"
EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"

#   If the X server does not automatically detect your VGA device,
#   you can manually set it here.
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
#   as you see in the commented example.
#   This Setting may be needed in some platforms with more than one
#   nvidia card, which may confuse the proprietary driver (e.g.,
#   trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
#   BusID "PCI:01:00:0"

#   Setting ProbeAllGpus to false prevents the new proprietary driver
#   instance spawned to try to control the integrated graphics card,
#   which is already being managed outside bumblebee.
#   This option doesn't hurt and it is required on platforms running
#   more than one nvidia graphics card with the proprietary driver.
#   (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
#   If this option is not set, the new Xorg may blacken the screen and
#   render it unusable (unless you have some way to run killall Xorg).
    Option "ProbeAllGpus" "false"

    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "UseDisplayDevice" "none"
EndSection


Mi laptop usa un sistema hybrido de targeta grafica, una intel vga para la grafica normal, y una Nvidia Geforce 740m como dedicada, el driver actual de gentoo de nvidia drivers soporta la targeta, e probado no especificando el puerto pci de a targeta, pero sigue marcando error, en el kernel tengo habilitado la opcion de grafica hibrida, el bbswitch funciona bien segun los datos que me da la pc, asi que no se por que no quiere funcionar la targeta, y tampoco se de donde proviene el problema, a pesar de la vasta cantidad de logs con encuentro el problema, por si acaso, el driver que ocupo es nvidia y el nouveau esta desabilitado desde el kernel, por lo que no deberia obstaculizar el funcionamisnto de esto, y el driver nvidia si existe ya que funciona el "modprobe nvidia".

Muchas Gracias


Last edited by Pipeng on Sun Mar 09, 2014 10:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
edgar_uriel84
Guru
Guru


Joined: 21 Dec 2008
Posts: 453
Location: Tultitlan, México

PostPosted: Mon Nov 04, 2013 3:46 am    Post subject: Reply with quote

Yo nunca logre hacer funcionar el driver de Nvidia, uso nouveau, pero este post dice las instrucciones, si lo consigues lanza una guía :P

http://forums.gentoo.org/viewtopic-t-959568-highlight-nvidia+optimus.html

Hasta donde se, necesitaras el driver modesetting para la intel, debes desinstalar bumblebee y bueno, otros detalles listados en el hilo de arriba.
_________________
Algún día habrá una persona mejor que yo, pero esa persona no eres tú ni ese momento es ahora.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Mon Nov 04, 2013 7:30 pm    Post subject: Reply with quote

@Pipeng:
Podrías reinstalar xorg-server ahora que has actualizado tu kernel.
Back to top
View user's profile Send private message
Pipeng
n00b
n00b


Joined: 23 Jul 2013
Posts: 8

PostPosted: Sun Mar 09, 2014 10:05 pm    Post subject: Solucionado Reply with quote

Hola, revivo este antiguo post por si alguien lo encuentra, Optimus me funciono finalmente con los drivers oficiales con los packetes actuales y una actualizacion del kernel:

Genkernel: Kernel 3.12.13
Direct Rendering Manager como modulo
Nouveau como module (bloqueado desde blacklist) (nouveau)
Nvidia Framebuffer como modulo (bloqueado desde blacklist) (nvidiafb)
Todos los framebuffer desactivados

Nvidia-Drivers 331.49
Bumblebee 3.2.1
Bbswitch 0.8

En make.conf

USE="nouveau nvidia bbswitch"
VIDEO_CARDS="nouveau nvidia"

Recordar que despues de actulizar el kernel y los packetes con las uses ejecutar un "emerge @module-rebuild"

Y por si acaso gracias a que corre ahora se puede habilitar el opencl dentro de la use (USE="opencl")
Claramente para los que parten si utilizan el soporte de opencl recuerden prender la targeta grafica con "echo ON >> /proc/acpi/bbswitch" o ejecutando el comando con optimus.

Bueno eso, nos vemos
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum