Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerging dev-java/icedtea
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
PeGa!
n00b
n00b


Joined: 13 May 2005
Posts: 64
Location: Capital Federal, Buenos Aires, Argentina

PostPosted: Sun Nov 03, 2013 6:28 pm    Post subject: Emerging dev-java/icedtea Reply with quote

Hi, I'm trying to install icedtea from sources, and this is what I get:

Code:
# emerge -vat icedtea

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] dev-java/icedtea-7.2.4.3:7  USE="X alsa cjk cups nsplugin nss source webstart -debug -doc -examples -javascript -jbootstrap -kerberos -pax_kernel -pulseaudio -systemtap {-test}"
[ebuild  N    ~]  dev-java/icedtea-web-1.4.1  USE="nsplugin -doc -javascript {-test}" 1,344 kB
[ebuild  N    ~]   dev-java/icedtea-7.2.4.3:7  USE="X alsa cjk cups nsplugin nss source webstart -debug -doc -examples -javascript -jbootstrap -kerberos -pax_kernel -pulseaudio -systemtap {-test}" 71,708 kB
[nomerge       ] virtual/jre-1.6.0-r1:1.6
[ebuild  N     ]  virtual/jdk-1.6.0-r2:1.6  0 kB
[ebuild  N     ]   dev-java/icedtea-bin-6.1.12.6:6  USE="X alsa cjk cups nsplugin -doc -examples -source" 0 kB
[ebuild  N     ]    dev-java/java-config-2.1.12-r1:2  PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_3)" 0 kB
[nomerge       ] kde-base/kdegraphics-meta-4.10.5:4  USE="scanner (-aqua)"
[nomerge       ]  kde-base/libkdcraw-4.10.5-r1:4  USE="(-aqua) -debug -jasper"
[nomerge       ]   media-libs/libraw-0.15.4:0/9  USE="jpeg jpeg2k lcms openmp -demosaic -examples -static-libs"
[ebuild     U ~]    media-libs/lcms-2.5-r1:2 [2.3:2] USE="jpeg tiff zlib -doc -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 6,837 kB
[ebuild     U ~]     media-libs/tiff-4.0.3-r5 [4.0.3-r4] USE="cxx jpeg zlib -jbig -lzma -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[nomerge       ] dev-java/icedtea-7.2.4.3:7  USE="X alsa cjk cups nsplugin nss source webstart -debug -doc -examples -javascript -jbootstrap -kerberos -pax_kernel -pulseaudio -systemtap {-test}"
[ebuild  N    ~]  app-admin/eselect-java-0.1.0  71 kB
[ebuild  N     ]  sys-apps/lsb-release-1.4  11 kB
[nomerge       ] dev-java/icedtea-web-1.4.1  USE="nsplugin -doc -javascript {-test}"
[ebuild  N     ]  net-misc/npapi-sdk-0.27.2  65 kB
[nomerge       ] dev-java/icedtea-7.2.4.3:7  USE="X alsa cjk cups nsplugin nss source webstart -debug -doc -examples -javascript -jbootstrap -kerberos -pax_kernel -pulseaudio -systemtap {-test}"
[nomerge       ]  dev-java/java-config-2.1.12-r1:2  PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_3)"
[ebuild  N     ]   dev-java/java-config-wrapper-0.16  8 kB
[blocks B      ] app-admin/eselect-java ("app-admin/eselect-java" is blocking dev-java/java-config-2.1.12-r1)
[blocks B      ] <dev-java/java-config-2.2 ("<dev-java/java-config-2.2" is blocking app-admin/eselect-java-0.1.0)

Total: 11 packages (2 upgrades, 9 new), Size of downloads: 80,041 kB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-java/java-config-2.1.12-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-java/java-config-2.1.9-r1 required by (dev-java/swt-3.7.2::gentoo, installed)
    >=dev-java/java-config-2.1.9-r1 required by (dev-java/icedtea-7.2.4.3::gentoo, ebuild scheduled for merge)
    >=dev-java/java-config-2.1.9-r1 required by (dev-java/icedtea-web-1.4.1::gentoo, ebuild scheduled for merge)
    <dev-java/java-config-2.2 required by (dev-java/icedtea-bin-6.1.12.6::gentoo, ebuild scheduled for merge)
    =dev-java/java-config-2* required by (dev-java/icedtea-7.2.4.3::gentoo, ebuild scheduled for merge)
    =dev-java/java-config-2* required by (dev-java/icedtea-web-1.4.1::gentoo, ebuild scheduled for merge)
    =dev-java/java-config-2* required by (dev-java/icedtea-bin-6.1.12.6::gentoo, ebuild scheduled for merge)
    >=dev-java/java-config-2.1.9-r1 required by (dev-java/ant-core-1.9.2::gentoo, installed)

  (app-admin/eselect-java-0.1.0::gentoo, ebuild scheduled for merge) pulled in by
    app-admin/eselect-java required by (dev-java/icedtea-7.2.4.3::gentoo, ebuild scheduled for merge)
    app-admin/eselect-java required by (dev-java/icedtea-web-1.4.1::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked



Now, what really I fail to understand is that the same package is calling two dependencies that are mutually blocking. To study the situation, I went to see the icedtea ebuild, and I was unable to find a single reference to the eselect-java dependency. I know, I don't want to disable a Gentoo feature, I just want to understand why this is happening.

What am I missing in order to solve this blockage?

Thanks in advance.
_________________
If it moves, it has an ebuild.

Adopt an unanswered post.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1678
Location: Berlin, Germany

PostPosted: Sun Nov 03, 2013 10:27 pm    Post subject: Reply with quote

Code:
[ebuild  N     ]    dev-java/java-config-2.1.12-r1:2  PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_3)" 0 kB
[blocks B      ] <dev-java/java-config-2.2 ("<dev-java/java-config-2.2" is blocking app-admin/eselect-java-0.1.0)
You are trying to install the stable java-config which does not work with eselect-java. You need at least java-config-2.2 to proceed.
Back to top
View user's profile Send private message
urcindalo
Guru
Guru


Joined: 08 Feb 2005
Posts: 555
Location: Almeria, Spain

PostPosted: Thu Nov 21, 2013 11:03 am    Post subject: Reply with quote

I'm facing a similar situation when trying to update my ~amd64 dev-java/icedtea-bin-7.2.4.1 to v7.2.4.3.

This is what I get:
Code:
# emerge -vat =dev-java/icedtea-bin-7.2.4.3

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] dev-java/icedtea-bin-7.2.4.3:7 [7.2.4.1:7] USE="X alsa cups nsplugin source -cjk -doc -examples"
[ebuild  N    ~]  dev-java/icedtea-web-1.4.1  USE="icedtea7 javascript nsplugin -doc {-test}" 1,344 kB
[ebuild     U ~]   dev-java/icedtea-bin-7.2.4.3:7 [7.2.4.1:7] USE="X alsa cups nsplugin source -cjk -doc -examples" 94,522 kB
[ebuild  N     ]   dev-java/rhino-1.7.2-r2:1.6  USE="source -doc -examples" 2,946 kB
[ebuild  N     ]    dev-java/xml-xmlbeans-1.0.4_pre20041217:1  USE="source -doc" 2,380 kB
[ebuild  N    ~]   app-admin/eselect-java-0.1.0  71 kB
[blocks B      ] app-admin/eselect-java ("app-admin/eselect-java" is blocking dev-java/java-config-2.1.12-r1)
[blocks B      ] <dev-java/java-config-2.2 ("<dev-java/java-config-2.2" is blocking app-admin/eselect-java-0.1.0)

Total: 5 packages (1 upgrade, 4 new), Size of downloads: 101,262 kB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-admin/eselect-java-0.1.0::gentoo, ebuild scheduled for merge) pulled in by
    app-admin/eselect-java required by (dev-java/icedtea-bin-6.1.12.6::gentoo, installed)
    app-admin/eselect-java required by (dev-java/icedtea-web-1.4.1::gentoo, ebuild scheduled for merge)

  (dev-java/java-config-2.1.12-r1::gentoo, installed) pulled in by
    >=dev-java/java-config-2.1.9-r1 required by (media-libs/libpano13-2.9.18::gentoo, installed)
    >=dev-java/java-config-2.1.9-r1 required by (dev-java/swt-3.7.2::gentoo, installed)
    >=dev-java/java-config-2.1.9-r1 required by (dev-java/xerces-2.11.0::gentoo, installed)
    =dev-java/java-config-2* required by (dev-java/icedtea-web-1.4.1::gentoo, ebuild scheduled for merge)
    >=dev-java/java-config-2.1.6 required by (java-virtuals/jaf-1.1-r1::gentoo, installed)
...
...
    <dev-java/java-config-2.2 required by (dev-java/icedtea-web-1.4.1::gentoo, ebuild scheduled for merge)
    <dev-java/java-config-2.2 required by (dev-java/icedtea-bin-7.2.4.3::gentoo, ebuild scheduled for merge)
...
...


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-java/icedtea-bin-7.2.4.3[nsplugin]
# required by =dev-java/icedtea-bin-7.2.4.3 (argument)
=dev-java/icedtea-web-1.4.1 ~amd64
# required by dev-java/icedtea-web-1.4.1
# required by dev-java/icedtea-bin-7.2.4.3[nsplugin]
# required by =dev-java/icedtea-bin-7.2.4.3 (argument)
=app-admin/eselect-java-0.1.0 ~amd64


So, I just included these lines in /etc/portage/package.accept_keywords
Code:
=sys-apps/baselayout-java-0.1.0
=dev-java/java-config-2.2.0
=dev-java/icedtea-web-1.4.1
=app-admin/eselect-java-0.1.0


only to get the same blocking:
Code:
[blocks B      ] app-admin/eselect-java ("app-admin/eselect-java" is blocking dev-java/java-config-2.1.12-r1)
[blocks B      ] <dev-java/java-config-2.2 ("<dev-java/java-config-2.2" is blocking app-admin/eselect-java-0.1.0)


If I remove the =dev-java/java-config-2.2.0 and =sys-apps/baselayout-java-0.1.0 lines from /etc/portage/package.accept_keywords I still get the same denial when updating to =dev-java/icedtea-bin-7.2.4.3:
Code:
[blocks B      ] app-admin/eselect-java ("app-admin/eselect-java" is blocking dev-java/java-config-2.1.12-r1)
[blocks B      ] <dev-java/java-config-2.2 ("<dev-java/java-config-2.2" is blocking app-admin/eselect-java-0.1.0)


Am I doing something wrong?
I have been forced to mask =dev-java/icedtea-bin-7.2.4.3 for world updates.
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 398

PostPosted: Fri Nov 22, 2013 2:53 am    Post subject: Reply with quote

I had problems like this on a couple computers. What seemed to work for me was unmerging and keywording app-admin/eselect-java, dev-java/java-config, and sys-apps/baselayout-java. I hope that this helps.
Back to top
View user's profile Send private message
urcindalo
Guru
Guru


Joined: 08 Feb 2005
Posts: 555
Location: Almeria, Spain

PostPosted: Fri Nov 22, 2013 12:12 pm    Post subject: Reply with quote

keet wrote:
I had problems like this on a couple computers. What seemed to work for me was unmerging and keywording app-admin/eselect-java, dev-java/java-config, and sys-apps/baselayout-java. I hope that this helps.


Do you mean unmerging the previous dev-java/icedtea-bin-7.2.4.1 version or any other package?

Thanks for your help.
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 398

PostPosted: Fri Nov 22, 2013 1:11 pm    Post subject: Reply with quote

I am sorry for the ambiguity. What I meant was this:

Code:
emerge -C app-admin/eselect-java dev-java/java-config sys-apps/baselayout-java


and then add these lines to /etc/portage/package.keywords:

Code:
# IcedTea
app-admin/eselect-java
dev-java/java-config
sys-apps/baselayout-java
Back to top
View user's profile Send private message
rsevero
n00b
n00b


Joined: 01 Sep 2004
Posts: 33

PostPosted: Wed Dec 11, 2013 1:33 pm    Post subject: Reply with quote

I've just managed to upgrade to icedtea-bin-7.2.4.3. I had to include the following in my /etc/portage/package.keywords/package.keywords.original file:

Code:
=dev-java/icedtea-bin-7.2.4.3 ~amd64
=dev-java/icedtea-web-1.4.1 ~amd64
=virtual/jre-1.7.0 ~amd64
=virtual/jdk-1.7.0 ~amd64
=dev-java/java-config-2.2.0 ~amd64
=sys-apps/baselayout-java-0.1.0 ~amd64
=app-admin/eselect-java-0.1.0 ~amd64


That's because both eselect-java AND java-config are necessary but only java-config >= 2.2 is compatible with eselect-java.

Hope this saves someone the 2 hours I spent getting to this solution :wink:
Back to top
View user's profile Send private message
urcindalo
Guru
Guru


Joined: 08 Feb 2005
Posts: 555
Location: Almeria, Spain

PostPosted: Thu Dec 12, 2013 10:33 am    Post subject: Reply with quote

Thanks rsevero :D
I was finally able to upgrade thanks to your hard work.
Before I was getting circular impediments 8O
Back to top
View user's profile Send private message
RAPHEAD
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2003
Posts: 102
Location: Germany

PostPosted: Fri Mar 07, 2014 10:08 am    Post subject: Reply with quote

Saved my day! I alsmost had it like your solution but I was missing

=sys-apps/baselayout-java-0.1.0 ~amd64

I think. Once I had this, it worked.
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2730
Location: The Peanut Gallery

PostPosted: Fri Mar 07, 2014 5:43 pm    Post subject: Reply with quote

If you're on amd64, then you don't need to put the ~amd64 in package.keywords. IOW you could just use eg:
Code:
=sys-apps/baselayout-java-0.1.0

By default, portage assumes ~arch for whatever arch you are on.
This makes it easier to share keyword files (as well as being less cruft.)

add: oops keet did just that; for you others then ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum