Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ebuild install is much slower than before
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2699
Location: Hamburg/Germany

PostPosted: Sat Nov 02, 2013 8:44 am    Post subject: ebuild install is much slower than before Reply with quote

I realized that the install part calls /usr/lib/portage/bin/install.py if in a makefile "install" is specified instead of "/usr/bin/install".

This however seems to vastly slow down the installation part at a system, where I do boot from (and therefore install to an external USB 2.0 drive, especially for packages with a lot of installation files like pingus and phpmyadmin.

Now I'm wondering if something was change in the way portage handles the installation -or- if my external hard disk is dying -or- if the call of the python does now cost much more than in former times ?
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2486
Location: The Peanut Gallery

PostPosted: Sat Nov 02, 2013 2:16 pm    Post subject: Reply with quote

If you're using nvidia-drivers this bug may be apposite (latter is dupe of first, but is the same issue of portage slowing down.) Solution: downgrade.

People in #-portage have also mentioned FEATURES=xattr as an issue. (Turn it off;) I think this is more likely as it will affect the install phase most of all.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum