Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
spectacular emerge crash -- goomwwm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pking
n00b
n00b


Joined: 11 Sep 2009
Posts: 49

PostPosted: Sun Oct 27, 2013 1:38 am    Post subject: spectacular emerge crash -- goomwwm Reply with quote

Doing a clean install of gentoo on a new SSD for my laptop, I hit the following snag:
when I tried to emerge goomwwm [ = Get Out Of My Way Window Manager! ], there
was a remarkable failure. Here's the build log:

Code:

 * Package:    x11-wm/goomwwm-1.0.0
 * Repository: gentoo
 * Maintainer: jer@gentoo.org
 * USE:        amd64 elibc_glibc kernel_linux userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking goomwwm-1.0.0.tar.gz to /var/tmp/portage/x11-wm/goomwwm-1.0.0/work
>>> Source unpacked in /var/tmp/portage/x11-wm/goomwwm-1.0.0/work
>>> Preparing source in /var/tmp/portage/x11-wm/goomwwm-1.0.0/work/goomwwm-1.0.0 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-wm/goomwwm-1.0.0/work/goomwwm-1.0.0 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-wm/goomwwm-1.0.0/work/goomwwm-1.0.0 ...
make -j8 CC=x86_64-pc-linux-gnu-gcc proto normal
cat *.c | egrep '^(void|int|char|unsigned|client|Window|winlist|XWindow)' | sed -r 's/\)/);/' > proto.h
x86_64-pc-linux-gnu-gcc -o goomwwm goomwwm.c -march=native -O2 -pipe -fomit-frame-pointer -include proto.h -I/usr/include/freetype2 -lXinerama -lX11 -lXft  -Wl,-O1 -Wl,--as-needed
In file included from <command-line>:0:0:
./proto.h:1:18: error: unknown type name âAtomâ
./proto.h:3:25: error: unknown type name âclientâ
./proto.h:4:22: error: unknown type name âclientâ
./proto.h:4:33: error: unknown type name âAtomâ
./proto.h:5:23: error: unknown type name âclientâ
./proto.h:5:34: error: unknown type name âAtomâ
./proto.h:6:26: error: unknown type name âclientâ
./proto.h:6:37: error: unknown type name âAtomâ
./proto.h:7:31: error: unknown type name âclientâ
./proto.h:8:23: error: unknown type name âclientâ
./proto.h:8:34: error: unknown type name âAtomâ
./proto.h:9:30: error: unknown type name âclientâ
./proto.h:10:27: error: unknown type name âclientâ
./proto.h:11:23: error: unknown type name âclientâ
./proto.h:11:34: error: unknown type name âwinruleâ
./proto.h:12:1: error: unknown type name âclientâ
./proto.h:12:23: error: unknown type name âWindowâ
./proto.h:13:18: error: unknown type name âclientâ
./proto.h:14:23: error: unknown type name âclientâ
./proto.h:14:34: error: unknown type name âclientâ
./proto.h:15:27: error: unknown type name âclientâ
./proto.h:15:38: error: unknown type name âAtomâ
./proto.h:16:19: error: unknown type name âclientâ
./proto.h:17:23: error: unknown type name âclientâ
./proto.h:18:26: error: unknown type name âclientâ
./proto.h:19:32: error: unknown type name âclientâ
./proto.h:20:24: error: unknown type name âclientâ
./proto.h:21:20: error: unknown type name âclientâ
./proto.h:22:22: error: unknown type name âclientâ
./proto.h:23:27: error: unknown type name âclientâ
./proto.h:24:32: error: unknown type name âclientâ
./proto.h:25:32: error: unknown type name âclientâ
./proto.h:26:30: error: unknown type name âclientâ
./proto.h:27:35: error: unknown type name âclientâ
./proto.h:28:35: error: unknown type name âclientâ
./proto.h:29:1: error: unknown type name âwinlistâ
./proto.h:29:32: error: unknown type name âworkareaâ

...and so on, for some fifty more lines, before concluding with
the pithy remark: "emake failed". But this isn't a subtle failure;
it crashes and burns right out of the gate. Odd, because on the
very same computer, before switching the hard disk out, goomwwm
was running just fine, as it does on several other computers of mine.

What's gone wrong here? Any ideas?
Back to top
View user's profile Send private message
pking
n00b
n00b


Joined: 11 Sep 2009
Posts: 49

PostPosted: Thu Oct 31, 2013 1:39 am    Post subject: Reply with quote

Okay, a follow-up. I copied the old binary of goomwwm from the removed hard drive
and it runs on the new system perfectly -- so it isn't the environment or some missing
library. The problem is at the emerge stage. Though I'm no expert, it looks to me as
though the first thing the ebuild does is it tries to strip information from the *.c files and
put it into proto.h -- but then something has gone wrong, because proto.h is filled with
stuff that gcc can't compile (hence all the "unknown type" errors for Atom and client).
If so, that suggests a problem in the ebuild. Perhaps even a bug. Is that what the
egrep/sed line is doing, or am I way off base here?
Back to top
View user's profile Send private message
pking
n00b
n00b


Joined: 11 Sep 2009
Posts: 49

PostPosted: Fri Nov 01, 2013 12:37 am    Post subject: Reply with quote

Thanks to Peter Hartman, the culprit is:
Code:

append-cflags -include proto.h

Comment out that line in the ebuild of goomwwm, and it all
compiles cleanly and without problem. Looks like someone
missed something in testing out the ebuild.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum