Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
System halt (power off) during emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
erge
n00b
n00b


Joined: 28 Oct 2010
Posts: 23
Location: ZH (CH)

PostPosted: Sun Oct 27, 2013 3:59 pm    Post subject: System halt (power off) during emerge Reply with quote

- - - - - -
Problem Description:
As soon as i am starting the emerge (emerge --update --newuse --deep --with-bdeps=y @world
) then after an while the machine stops complete (power off).
For me it looks like it could be a "Kernel Panic" but how can i analyse an debug this ?
- - - - - -
Hardware environment:
Power Mac G5 Quad 2.5 Ghz (M9592LL/A)
powerppc ~ # uname -a
Linux powerppc 3.10.7-gentoo #1 SMP Sun Oct 27 14:07:18 CET 2013 ppc64 PPC970MP, altivec supported PowerMac11,2 GNU/Linux
powerppc ~ # lspci
0000:00:0b.0 PCI bridge: Apple Inc. CPC945 PCIe Bridge
0000:0a:00.0 VGA compatible controller: NVIDIA Corporation NV43 [GeForce 6600] (rev a2)
0001:00:00.0 Host bridge: Apple Inc. U4 HT Bridge
0001:00:01.0 PCI bridge: Broadcom BCM5780 [HT2000] PCI-X bridge (rev a3)
0001:00:02.0 PCI bridge: Broadcom BCM5780 [HT2000] PCI-X bridge (rev a3)
0001:00:03.0 PCI bridge: Broadcom BCM5780 [HT2000] PCI-Express Bridge (rev a3)
0001:00:04.0 PCI bridge: Broadcom BCM5780 [HT2000] PCI-Express Bridge (rev a3)
0001:00:05.0 PCI bridge: Broadcom BCM5780 [HT2000] PCI-Express Bridge (rev a3)
0001:00:06.0 PCI bridge: Broadcom BCM5780 [HT2000] PCI-Express Bridge (rev a3)
0001:00:07.0 PCI bridge: Apple Inc. Shasta PCI Bridge
0001:00:08.0 PCI bridge: Apple Inc. Shasta PCI Bridge
0001:00:09.0 PCI bridge: Apple Inc. Shasta PCI Bridge
0001:01:01.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
0001:01:07.0 Unassigned class [ff00]: Apple Inc. Shasta Mac I/O
0001:01:0b.0 USB controller: NEC Corporation OHCI USB Controller (rev 43)
0001:01:0b.1 USB controller: NEC Corporation OHCI USB Controller (rev 43)
0001:01:0b.2 USB controller: NEC Corporation uPD72010x USB 2.0 Controller (rev 04)
0001:03:0c.0 IDE interface: Broadcom K2 SATA
0001:03:0d.0 Unassigned class [ff00]: Apple Inc. Shasta IDE
0001:03:0e.0 FireWire (IEEE 1394): Apple Inc. Shasta Firewire
0001:05:04.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5780 Gigabit Ethernet (rev 03)
0001:05:04.1 Ethernet controller: Broadcom Corporation NetXtreme BCM5780 Gigabit Ethernet (rev 03)
powerppc ~ #

- - - - - - -
Gentoo environment:

powerppc ~ # emerge --info
Portage 2.2.1 (default/linux/powerpc/ppc64/13.0/32bit-userland/desktop, gcc-4.6.3, glibc-2.15-r3, 3.10.7-gentoo ppc64)
=================================================================
System uname: Linux-3.10.7-gentoo-ppc64-PPC970MP,_altivec_supported-with-gentoo-2.2
KiB Mem: 4006124 total, 3834040 free
KiB Swap: 8388604 total, 8388604 free
Timestamp of tree: Sat, 26 Oct 2013 15:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [disabled]
app-shells/bash: 4.2_p45
dev-java/java-config: 2.1.12-r1
dev-lang/python: 2.6.8-r3, 2.7.5-r3, 3.2.5-r3
dev-util/ccache: 3.1.9
dev-util/cmake: 2.8.10.2-r2
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.11.8
sys-apps/sandbox: 2.6-r1
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.9.6-r3, 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils: 2.23.1
sys-devel/gcc: 4.6.3, 4.7.3-r1
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4.2
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc: 2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="ppc"
ACCEPT_LICENSE="*"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O3 -pipe -mcpu=970 -mtune=970 -maltivec -mabi=altivec -fno-strict-aliasing"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CPPFLAGS="-DRUNTIME_CPUDETECT"
CXXFLAGS="-O3 -pipe -mcpu=970 -mtune=970 -maltivec -mabi=altivec -fno-strict-aliasing"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=5 --load-average=4.8"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5 -l4.6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
USE="X a52 aac acl aiglx alsa aoss asf berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gcc64 gdbm gif glitz gnome gpm gstreamer gtk hal iconv java jpeg lcms ldap libnotify mad mng modules mp3 mp4 mpeg mudflap ncurses new-login nls nptl nsplugin ogg opengl openmp pam pango pcre pdf png policykit ppc ppds qt3support readline real samba sdl session spell sqlite ssl startup-notification svg symlink tcpd threads tiff truetype udev udisks unicode upower usb vorbis win32codecs wxwidgets xcb xcomposite xinerama xml xorg xscreensaver xv xvid zlib" ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON

powerppc ~ #
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3892
Location: USA

PostPosted: Sun Oct 27, 2013 5:28 pm    Post subject: Reply with quote

Usually such is a hardware problem...
Have you checked cooling?
Will it shut off if you use only 1 thread and keep load average low?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
erge
n00b
n00b


Joined: 28 Oct 2010
Posts: 23
Location: ZH (CH)

PostPosted: Sun Oct 27, 2013 7:26 pm    Post subject: Reply with quote

>Usually such is a hardware problem...
I have booted to the OSX from the Mac after that generating heavy load no problem there.

>Have you checked cooling?
In the dmesg i see the the winfarm process is started i also can hear the cooling fans.

>Will it shut off if you use only 1 thread and keep load average low?
I will try this with the /etc/portage/make.conf and setting "MAKEOPTS="-j1".
Back to top
View user's profile Send private message
erge
n00b
n00b


Joined: 28 Oct 2010
Posts: 23
Location: ZH (CH)

PostPosted: Sun Oct 27, 2013 9:12 pm    Post subject: no more power off happens Reply with quote

Yes great it works if I am using only one thread then it is able to process 22 packages without doing automaticly power off, it is slow I only can see -> us 25%, sys 0%, id 75%, wa 0% but .......it is stable.

It is an Quad Core Machine and i am using now only one thread, but portage (emerge) sems to be happy with this situation.
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3892
Location: USA

PostPosted: Mon Oct 28, 2013 3:27 am    Post subject: Reply with quote

There's likely a problem with overheating then. Unfortunately I don't know anything about ppc/mac hardware... You could see if it will do with 2 threads or try to limit the load average lower...

Check the heatsink for dust or a bad fan. I don't know what apple did with their os to throttle, I would hope Linux would be able to do the same, but I'm an x86/pc hardware person...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
erge
n00b
n00b


Joined: 28 Oct 2010
Posts: 23
Location: ZH (CH)

PostPosted: Tue Oct 29, 2013 8:21 pm    Post subject: Reply with quote

>There's likely a problem with overheating then.
>Unfortunately I don't know anything about ppc/mac hardware...
>You could see if it will do with 2 threads or try to limit the load average lower...
The PowerMac G5 Quad Core has an Liquid Cooling System (LCS), i did install the stress application
to geto 100% CPU load constantly for 2 Minutes on all 4 CPU Cores during that stress activity i did monitor the
temperature of all the CPU Cores. CPU Core0+1 did have an average about 80 Grad Celsius, CPU Core2+3 gets to 70 Grad Celsius. I did not have any reboot during that testphase I did run the stress test several time no problem occured.
For me it looks like the portage command did have an problem with the "-j5" parameter but unfourtantly i can not reproduce the problem bcause ther are not so much packages to install wtih the emerge because the system is already updated.


>Check the heatsink for dust or a bad fan.
>I don't know what apple did with their os to throttle,
>I would hope Linux would be able to do the same, but I'm an x86/pc hardware person...
I did check in the CPU aerea and the LCS System for leakage and did remove the dust it did look clean, i did also reconnect all the connectors for the System Board and the LCS.
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3892
Location: USA

PostPosted: Tue Oct 29, 2013 8:27 pm    Post subject: Reply with quote

For a liquid cooled system, 80 degrees Celsius is quite warm or hot, at least for a Core-based Intel PC.. Is the pump working? My quad core machines don't get that high when stressed.

Also there's the possibility that 2 minutes may not be long enough to trigger the issue...

You can always re-emerge a package again by not specifying --update (-u). Or you could try building a new package you never ran before :D
Back to top
View user's profile Send private message
erge
n00b
n00b


Joined: 28 Oct 2010
Posts: 23
Location: ZH (CH)

PostPosted: Thu Oct 31, 2013 7:45 pm    Post subject: Reply with quote

>For a liquid cooled system, 80 degrees Celsius is quite warm or hot, at least for a Core-based Intel PC.. Is the pump >working? My quad core machines don't get that high when stressed.
Yes the pump is working i can see different temperatures as soon as i vary the CPU workload. Yes 80 degrees Celsius are quite hot but it seems to be normal and it looks like the PowerMac G5 can handle this quite good. http://domino.watson.ibm.com/library/cyberdig.nsf/papers/E6EBD3C859FB49F785256ED8006A3F4A/$File/rc23276.pdf

>Also there's the possibility that 2 minutes may not be long enough to trigger the issue...
I did increase it to 4 minutes it is still working perfect. I did repeat the test several times.....

>You can always re-emerge a package again by not specifying --update (-u). Or you could try building a new package >you never ran before :D
I did an re-emerge an long time CPU job (emerge sys-devel/gcc) after chanceing the /etc/portage/make.conf to (MAKEOPTS="-j5 -l4.6"), running about estimatet 40 minutes with very high CPU load and more the 80 degrees Celsius without any incident. For me it looks like the problem gets fixed with the reconnecting of the connectors on the System Board and on the pump (Liquid Cooling System (LCS)).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum