Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PCIe Board & alte Mach64 VT (PCI) & xorg [~solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 973

PostPosted: Thu Oct 10, 2013 4:12 pm    Post subject: Reply with quote

nicht unbedingt. Probier erstmal aus, ob du ein kernel modul irgendwie bauen kannst. wenn nicht kannst du den mach64 xorg treiber gar nicht verwenden, sondern musst auf vesa oder fbdev ausweichen. dann kannst du auch atyfb behalten in dem fall.
aber uvesa einzurichten ist gar nicht so schwer. und nachdem ich es einmal eingerichtet hatte, musste ich seitdem nix mehr dran machen.
Back to top
View user's profile Send private message
bell
Guru
Guru


Joined: 27 Nov 2007
Posts: 418

PostPosted: Thu Oct 10, 2013 8:27 pm    Post subject: Reply with quote

Da hebe ich bei den Archis nützliches gefunden: https://wiki.archlinux.org/index.php/mach64. Spiele mal mit den dort genannten Einstellungen rum. Einige davon sollen Segfaults verhindern können.
Back to top
View user's profile Send private message
schmidicom
l33t
l33t


Joined: 09 Mar 2006
Posts: 971
Location: Schweiz

PostPosted: Fri Oct 11, 2013 7:34 am    Post subject: Reply with quote

bell wrote:
Da hebe ich bei den Archis nützliches gefunden: https://wiki.archlinux.org/index.php/mach64. Spiele mal mit den dort genannten Einstellungen rum. Einige davon sollen Segfaults verhindern können.

Wenn jegliche Acceleration (Option "NoAccel" "true") abgeschaltet wird kommt der Xorg zwar hoch aber dafür genau so lahm wie mit vesa oder fbdev. Im Endeffekt dürfte wohl klar sein das der mach64 Treiber des Xorg ohne passendes Kernelmodul für DRI/DRM schlicht unbrauchbar ist.

Danke für die Hilfe aber ohne passendes ebuild breche ich hier ab denn das DRI/DRM Modul aus irgendwelchen alten Mesa oder Kernel Ausgaben herauszulösen ist den Aufwand nicht wert.
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 973

PostPosted: Fri Oct 11, 2013 9:26 am    Post subject: Reply with quote

ja, das auf jeden fall. ohne kernel modul kommst du nicht weiter.
Back to top
View user's profile Send private message
schmidicom
l33t
l33t


Joined: 09 Mar 2006
Posts: 971
Location: Schweiz

PostPosted: Mon Oct 21, 2013 10:54 am    Post subject: Reply with quote

Mal so am Rand gefragt, wäre es falsch ein bugreport wegen dem fehlenden Modul für "x11-drivers/xf86-video-mach64" zu eröffnen?
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 973

PostPosted: Mon Oct 21, 2013 3:03 pm    Post subject: Reply with quote

falsch nicht, aberdie frage ist ob es was bringt:
So wie ich das verstanden habe, ist der treiber upstream einfach nicht gewartet. Irgendwo hab ich was gelesen, das es Probleme mit "neuren" Kerneln geben würde/könnte deswegen. Die Arch Leute scheinen es aber mit einem 3.7er kernel laufen zu haben.
Die frage ist dann also, ob sich jemand findet, der sich um einen treiber für hardware kümmert, die wohl relativ selten im einsatz und auch schon etwas älter ist. Der müsste sich dann um anpassungen für aktuelle kernel kümmern. und eigentlich wäre das eine upstream sache.

also, einen bugreport kannst du sicher aufmachen, aber ich glaube die chancen, dass sich jemand damit befasst sind eher gering.
Die beste möglichkeit wäre glaub ich, sich mal bei den archleuten umzuhören, was die machen und das ganze irgendwie in ebuild form zu gießen.
Back to top
View user's profile Send private message
schmidicom
l33t
l33t


Joined: 09 Mar 2006
Posts: 971
Location: Schweiz

PostPosted: Tue Oct 22, 2013 6:46 am    Post subject: Reply with quote

Bei den Archis gibt es einen "trya <tryagainprod@gmail.com>" der das Modul weiter pflegt aber seine TODO-Liste macht mir sorgen:
Quote:
mach64 DRM module TODO
----------------------

- switch between VTs without crashing X
- properly kill X when logging out
- clean up video memory each time we kill X
- suspend without crashing X (implies switching to vt1)
- support for 24bpp color depth
- fix EXA acceleration

So kann ich das meinem Chef unmöglich vorsetzen.

EDIT:
Und wenn ich mich nicht sehr irre wäre ein KMS Modul langfristig sowieso die bessere Lösung weil es vom X11 unabhängig einsetzbar ist oder?
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 973

PostPosted: Tue Oct 22, 2013 10:57 am    Post subject: Reply with quote

sag mal, bevor du da soviel aufwand reinsteckst, was ja deinen chef auch geld kostet, eine karte für ein paar 20-30€ zu kaufen, die funktionierende treiber hat? für einen X-Server reichen die allemal.
Back to top
View user's profile Send private message
bell
Guru
Guru


Joined: 27 Nov 2007
Posts: 418

PostPosted: Tue Oct 22, 2013 12:26 pm    Post subject: Reply with quote

Sehe ich genauso. Suche Dir eine gebrauchte ATI/AMD oder NVIDIA mit passivem Kühler. Damit kann man wenig falsch machen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum