Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gst-plugins-ffmpeg y media-video/libav
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
opotonil
l33t
l33t


Joined: 17 Jun 2005
Posts: 781
Location: 127.0.0.1

PostPosted: Wed Oct 16, 2013 6:56 pm    Post subject: gst-plugins-ffmpeg y media-video/libav Reply with quote

Estoy intentando instalar "gst-plugins-ffmpeg" con la USE "ffmpeg" habilitada y obtengo el siguiente error:
Code:

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-video/libav-0.8.7::gentoo, installed) pulled in by
    >=media-video/libav-0.8.4[X?,encode?,gsm?,jpeg2k?,mp3?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?] (>=media-video/libav-0.8.4[X,encode,threads,truetype]) required by (virtual/ffmpeg-0.10.3::gentoo, installed)
    media-video/libav required by @selected

  (media-video/ffmpeg-1.0.7::gentoo, ebuild scheduled for merge) pulled in by
    media-video/ffmpeg:0 required by (media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r1::gentoo, ebuild scheduled for merge)


Con el que entiendo que "media-plugins/gst-plugins-ffmpeg" requiere "media-video/ffmpeg", pero mirando el ebuild de "media-plugins/gst-plugins-ffmpeg" veo:
Code:

RDEPEND=">=media-libs/gstreamer-0.10.31:0.10
        >=media-libs/gst-plugins-base-0.10.31:0.10
        >=virtual/ffmpeg-0.10
        || ( media-video/ffmpeg:0 media-libs/libpostproc )
        orc? ( >=dev-lang/orc-0.4.6 )"


Con lo que entiendo que "media-plugins/gst-plugins-ffmpeg" requiere "virtual/ffmpeg" (version mayor o igual a la 0.10) o sino "media-video/ffmpeg". Si en el propio mensaje de error, del principio, me esta diciendo que "media-video/libav" esta instalada como requerimiento de "virtual/ffmpeg-0.10.3" como es que "media-plugins/gst-plugins-ffmpeg" pretende instalar como dependencia "media-video/ffmpeg".

A parte si se mira un poco mas "gst-plugins-ffmpeg-0.10.13_p201211-r1.ebuild" se puede ver:
Code:

        # libav-9 support backported from gst-plugins-libav-1.1.0
        epatch ../${MY_P}-libav-9-patches/*.patch

        # compat bits for older ffmpeg/libav releases
        epatch "${FILESDIR}/${PV}-channel_layout.patch" \
                "${FILESDIR}/${PV}-iscodec.patch" \
                "${FILESDIR}/${PV}-coma.patch" \
                "${FILESDIR}/${PV}-gstffmpegpipe_redef.patch"


¿Que esta pasando? Porque "gst-plugins-ffmpeg" dice que requiere "media-video/ffmpeg" y me da el bloqueo...

Salu2.
_________________
Localnet
Films Localnet
Back to top
View user's profile Send private message
opotonil
l33t
l33t


Joined: 17 Jun 2005
Posts: 781
Location: 127.0.0.1

PostPosted: Wed Oct 16, 2013 7:32 pm    Post subject: Reply with quote

Bueno, sigo sin entenderlo. Pero se puede resolver enmascarando "media-video/ffmpeg".
Code:

emerge -p virtual/ffmpeg media-video/libav gst-plugins-ffmpeg

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-video/libav-0.8.7
[ebuild   R    ] virtual/ffmpeg-0.10.3
[ebuild   R    ] media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r1


Salu2.
_________________
Localnet
Films Localnet
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 760

PostPosted: Wed Oct 16, 2013 9:49 pm    Post subject: Re: gst-plugins-ffmpeg y media-video/libav Reply with quote

opotonil wrote:
...
Code:

RDEPEND=">=media-libs/gstreamer-0.10.31:0.10
        >=media-libs/gst-plugins-base-0.10.31:0.10
        >=virtual/ffmpeg-0.10
        || ( media-video/ffmpeg:0 media-libs/libpostproc )
        orc? ( >=dev-lang/orc-0.4.6 )"


Con lo que entiendo que "media-plugins/gst-plugins-ffmpeg" requiere "virtual/ffmpeg" (version mayor o igual a la 0.10) o sino "media-video/ffmpeg
...

No.
Code:
>=virtual/ffmeg-0.10
es una dependencia directa.

Code:
|| ( media-video/ffmpeg:0 media-libs/libpostproc )
es una dependencia con alternativas.

Se requiere media-video/ffmpeg:0 o media-libs/libpostproc

Puesto que has enmascarado media-video/ffmpeg te debe haber instalado media-libs/libpostproc

Mira en
Code:
man 5 ebuild
el apartado Dynamic Dependencies.
Back to top
View user's profile Send private message
opotonil
l33t
l33t


Joined: 17 Jun 2005
Posts: 781
Location: 127.0.0.1

PostPosted: Thu Oct 17, 2013 7:19 am    Post subject: Reply with quote

Si, si que me instalo media-libs/libpostproc al enmascarar media-video/ffmpeg. Muy buena la aclaración, cuando tenga un momento mirare las Dynamic Dependencies. Gracias.

Salu2.
_________________
Localnet
Films Localnet
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum