Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201310-07 ] OpenJPEG: User-assisted execution of arbitrary code
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1613

PostPosted: Thu Oct 10, 2013 12:26 pm    Post subject: [ GLSA 201310-07 ] OpenJPEG: User-assisted execution of arbi Reply with quote

Gentoo Linux Security Advisory

Title: OpenJPEG: User-assisted execution of arbitrary code (GLSA 201310-07)
Severity: normal
Exploitable: remote
Date: October 10, 2013
Bug(s): #412895, #425772, #433766
ID: 201310-07

Synopsis

Multiple vulnerabilities in OpenJPEG could result in execution of
arbitrary code.


Background

OpenJPEG is an open-source JPEG 2000 library.

Affected Packages

Package: media-libs/openjpeg
Vulnerable: < 1.5.1
Unaffected: >= 1.5.1
Architectures: All supported architectures


Description

OpenJPEG contains an invalid free error and multiple buffer overflow
flaws. Please review the CVE identifiers referenced below for details.


Impact

A remote attacker could entice a user to open a specially crafted JPEG
file, possibly resulting in execution of arbitrary code or a Denial of
Service condition.


Workaround

There is no known workaround at this time.

Resolution

All OpenJPEG users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=media-libs/openjpeg-1.5.1"
   


References

CVE-2009-5030
CVE-2012-3358
CVE-2012-3535
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum