Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[udev] boot freeze suite à mise à jour kernel (résolu)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5701
Location: ~Brussels - Belgique

PostPosted: Thu Oct 03, 2013 6:26 pm    Post subject: Reply with quote

As-tu des périphériques externes (USB) ? Essaie de les débrancher pour tester.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
ludo82
n00b
n00b


Joined: 19 Aug 2005
Posts: 73

PostPosted: Fri Oct 04, 2013 5:18 am    Post subject: Reply with quote

J'ai débranché tous mes périphériques externes USB (clavier, souris, imprimante) mais ça donne le même problème au boot.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5701
Location: ~Brussels - Belgique

PostPosted: Fri Oct 04, 2013 6:36 am    Post subject: Reply with quote

As-tu déjà jeté un oeil à la sortie de dmesg ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
ludo82
n00b
n00b


Joined: 19 Aug 2005
Posts: 73

PostPosted: Fri Oct 04, 2013 6:22 pm    Post subject: Reply with quote

Vu que je n'arrive pas à démarrer, je ne peux pas accéder à dmesg.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5701
Location: ~Brussels - Belgique

PostPosted: Fri Oct 04, 2013 6:44 pm    Post subject: Reply with quote

Merci pour l'information.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
k-root
Guru
Guru


Joined: 08 Jan 2005
Posts: 362
Location: Paris

PostPosted: Fri Oct 04, 2013 7:06 pm    Post subject: Reply with quote

edit : et hop .. c'est vendredi :)
_________________
boozo wrote:
Gentoo, ça mange des ours et baffe des buffles par 37°C avec un bob et des tongs
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5701
Location: ~Brussels - Belgique

PostPosted: Fri Oct 04, 2013 7:33 pm    Post subject: Reply with quote

Le dmesg du livecd ne va pas nous aider ici ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 260
Location: S.O. France

PostPosted: Fri Oct 04, 2013 9:43 pm    Post subject: Reply with quote

Peux-tu poster ton grub.conf et ls -l /boot
EDIT: Peux tu tester le kernel 3.9
Back to top
View user's profile Send private message
ludo82
n00b
n00b


Joined: 19 Aug 2005
Posts: 73

PostPosted: Sat Oct 05, 2013 11:11 am    Post subject: Reply with quote

Le kernel 3.9 fonctionne chez moi. Ce sont les kernels 3.10 et 3.11 qui plantent.

Code:
# vi /boot/grub/grub.conf

# This is a sample grub.conf for use with Genkernel, per the Gentoo handbook
# http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=10#doc_chap2
# If you are not using Genkernel and you need help creating this file, you
# should consult the handbook. Alternatively, consult the grub.conf.sample that
# is included with the Grub documentation.

default 1
timeout 5
splashimage=(hd0,1)/boot/grub/gentoo.xpm.gz

title=Gentoo Linux (3.11.3-gentoo)
root (hd0,1)
kernel /boot/kernel-genkernel-x86_64-3.11.3-gentoo splash=verbose,theme:natural_gentoo video=uvesafb:1680x1050-32,mtrr:3,ywrap initrd=/dev/ram0 real_root=/dev/sda2
initrd /boot/initramfs-genkernel-x86_64-3.11.3-gentoo

title=Gentoo Linux (3.9.11-gentoo-r1)
root (hd0,1)
kernel /boot/kernel-genkernel-x86_64-3.9.11-gentoo-r1 splash=verbose,theme:natural_gentoo video=uvesafb:1680x1050-32,mtrr:3,ywrap initrd=/dev/ram0 real_root=/dev/sda2
initrd /boot/initramfs-genkernel-x86_64-3.9.11-gentoo-r1

title Windows XP
root (hd0,3)
makeactive
chainloader +1

title=Memtest86Plus
root (hd0,1)
kernel /boot/memtest86plus/memtest
# vim:ft=conf:


Code:
# ls -l /boot

total 18904
-rw-r--r-- 1 root root 2083303  3 oct.  20:06 System.map-genkernel-x86_64-3.11.3-gentoo
-rw-r--r-- 1 root root 2014339  2 oct.  20:43 System.map-genkernel-x86_64-3.9.11-gentoo-r1
lrwxrwxrwx 1 root root       1  1 juil.  2011 boot -> .
drwxr-xr-x 2 root root    4096  5 oct.  13:04 grub
-rw-r--r-- 1 root root 4025772  3 oct.  20:13 initramfs-genkernel-x86_64-3.11.3-gentoo
-rw-r--r-- 1 root root 4008468  2 oct.  20:50 initramfs-genkernel-x86_64-3.9.11-gentoo-r1
-rw-r--r-- 1 root root 3631760  3 oct.  20:06 kernel-genkernel-x86_64-3.11.3-gentoo
-rw-r--r-- 1 root root 3554896  2 oct.  20:43 kernel-genkernel-x86_64-3.9.11-gentoo-r1
drwxr-xr-x 2 root root    4096  8 juil.  2012 memtest86plus
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5701
Location: ~Brussels - Belgique

PostPosted: Sun Oct 06, 2013 5:16 pm    Post subject: Reply with quote

As-tu essayé de prendre le .config du kernel qui fonctionne et de l'utiliser comme base pour les autres kernels ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
ludo82
n00b
n00b


Joined: 19 Aug 2005
Posts: 73

PostPosted: Tue Oct 08, 2013 6:02 pm    Post subject: Reply with quote

Bon, j'ai réussi à démarrer le noyau 3.10 mais comme j'ai fait beaucoup de tests et de bidouillages dans le noyau, du coup je ne sais pas ce qui a permis de résoudre le problème.

Pour y arriver, j'ai essayé le pilote radeon à la place de fglrx pour tester, mais aucun noyau ne voulait démarrer, ni le 3.9 ni le 3.10 ni le 3.11.

Alors je suis revenu à fglrx, j'ai désactivé l'option CONFIG_DRM dans le noyau, j'ai désinstallé le paquet linux-firmware, et ça a marché.

Merci à tous pour votre aide.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum