Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]cave/paludis: problem installing gentoo-sources
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
andi456
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2005
Posts: 123
Location: Germany

PostPosted: Sat Sep 28, 2013 5:25 pm    Post subject: [solved]cave/paludis: problem installing gentoo-sources Reply with quote

Hi everybody,

again a problem concerning an update. This time cave refuses to install the latest gentoo-sources and complains as follows:
Code:

s   sys-kernel/gentoo-sources:3.11.2::gentoo 3.11.2 to ::installed
    "Full sources including the Gentoo patchset for the 3.11 kernel tree"
    -build -deblob -experimental -symlink build_options: -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: target
    64.81 kBytes to download

s   dev-python/python-exec:2::gentoo 2.0 to ::installed
    "Python script wrapper"
    PYTHON_TARGETS: (jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: dev-libs/boost-1.52.0-r6:0::installed, dev-libs/libxml2-2.9.1-r1:2::installed, dev-libs/libxslt-1.1.28-r1:0::installed, 9 more
    78.88 kBytes to download

Total: 2 new slot installs, 143.69 kBytes to download

Build Options:
    dwarf_compress:                Compress DWARF2+ debug information
    optional_tests:                Run tests considered by the package to be optional
    symbols:                       How to handle debug symbols in installed files
    trace:                         Trace actions executed by the package (very noisy, for debugging broken builds only)
    work:                          Whether to preserve or remove working directories

USE:
    build:                         !!internal use only!! DO NOT SET THIS FLAG YOURSELF!, used for creating build images and the first half of bootstrapping [make stage1]
    deblob:                        Remove binary blobs from kernel sources to provide libre license compliance.
    experimental:                  Apply experimental patches; for more information, see "https://wiki.gentoo.org/wiki/Project:Kernel/Experimental".
    symlink:                       Force kernel ebuilds to automatically update the /usr/src/linux symlink

python_targets:
    jython2_5:                     Build with Jython 2.5
    jython2_7:                     Build with Jython 2.7
    pypy2_0:                       Build with PyPy 2.0
    python2_6:                     Build with Python 2.6
    python2_7:                     Build with Python 2.7
    python3_2:                     Build with Python 3.2
    python3_3:                     Build with Python 3.3

I encountered the following errors:

!   dev-python/sip
    Reasons: dev-python/PyQt4-4.10.3:0::installed, kde-base/pykde4-4.11.1:4::installed
    Unsuitable candidates:
      * dev-python/sip-4.14.3:0::gentoo
        Did not meet >=dev-python/sip-4.15.0:0/10=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)], use existing if possible, installing to / from dev-python/PyQt4-4.10.3:0::installed
      * dev-python/sip-4.14.6:0::gentoo
        Did not meet >=dev-python/sip-4.15.0:0/10=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)], use existing if possible, installing to / from dev-python/PyQt4-4.10.3:0::installed
      * dev-python/sip-4.14.7:0::gentoo
        Did not meet >=dev-python/sip-4.14:0/9=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)], use existing if possible, installing to / from kde-base/pykde4-4.11.1:4::installed
        Did not meet >=dev-python/sip-4.15.0:0/10=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)], use existing if possible, installing to / from dev-python/PyQt4-4.10.3:0::installed
      * dev-python/sip-4.15.2:0::gentoo
        Did not meet >=dev-python/sip-4.14:0/9=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)], use existing if possible, installing to / from kde-base/pykde4-4.11.1:4::installed


So I tried to install dev-python/python-exec alone with the same result. Then I tried to reinstall dev-python/sip and saw the same errors...

What am I supposed to do?

Regards and thanks in advance,

Andreas


Last edited by andi456 on Tue Oct 08, 2013 7:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2280
Location: UK

PostPosted: Sat Sep 28, 2013 10:34 pm    Post subject: Reply with quote

Try doing:
Code:
cave resolve -1x dev-python/PyQt4 kde-base/pykde4
Back to top
View user's profile Send private message
andi456
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2005
Posts: 123
Location: Germany

PostPosted: Sun Sep 29, 2013 8:41 am    Post subject: Reply with quote

Tried that and got:
Code:
r   dev-python/sip:0::gentoo 4.15.2 to ::installed replacing 4.15.2
    -debug -doc PYTHON_TARGETS: python2_6* python2_7 python3_2 python3_3* build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: dev-python/PyQt4-4.10.3:0::gentoo, kde-base/pykde4-4.11.1:4::gentoo

r   dev-python/PyQt4:0::gentoo 4.10.3 to ::installed replacing 4.10.3
    X dbus -debug declarative -doc -examples -help kde -multimedia opengl phonon script -scripttools sql svg webkit -xmlpatterns PYTHON_TARGETS: python2_6* python2_7 python3_2 python3_3* build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: target, kde-base/plasma-workspace-4.11.1:4::installed, kde-base/pykde4-4.11.1:4::gentoo

r   kde-base/pykde4:4::gentoo 4.11.1 to ::installed replacing 4.11.1
    (-aqua) -debug -doc -examples (-test) PYTHON_TARGETS: python2_6* python2_7 python3_2 python3_3* build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: target, kde-base/plasma-workspace-4.11.1:4::installed

Total: 3 reinstalls

python_targets:
    python2_6:                     Build with Python 2.6
    python3_3:                     Build with Python 3.3

I encountered the following errors:

!   dev-python/dbus-python
    Reasons: dev-python/PyQt4-4.10.3:0::gentoo
    Unsuitable candidates:
      * dev-python/dbus-python-1.2.0:0::gentoo
        Did not meet >=dev-python/dbus-python-0.80[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)], use existing if possible, installing to / from dev-python/PyQt4-4.10.3:0::gentoo
            Flag 'python_targets_python3_3' enabled if it is enabled for 'dev-python/PyQt4-4.10.3:0::gentoo', assuming disabled if missing


Had to go back to the stable versions of dev-python/sip and dev-python/PyQt4
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum