Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Problem z kernelem i sterownikami nvidia-drivers
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Wed Aug 21, 2013 8:52 am    Post subject: [SOLVED]Problem z kernelem i sterownikami nvidia-drivers Reply with quote

Witam wszystkich.

Mam następujący problem, otóż dawno nie robiłem aktualizacji systemu trochę się tego nazbierało, ale wszystko poszło bardzo gładko i nie było większych zgrzytów, poza jednym. Mam problem z nvidia-drivers. Nie chcą się zbudować...

Zainstalowałem jajko 3.10.9 i chciałem do tego zainstalować sterowniki w wersji 325.08 niestety operacja zakończyła się niepowodzeniem. Co ciekawe nawet na moim starym kernelu(3.9.7) razem z którym te sterowniki były(i są na chwilę obecną zainstalowane) nie da się ich w tej chwili nawet przebudować zwracają dokładnie ten sam error co przy 3.10.9, sprawdzałem też jajko 3.10.7 jak i sterowniki w wersji 325.15 i również występuję ten sam problem. Jakiejkolwiek bym kombinacji nie użył zawsze jest to samo.

Code:
* NVIDIA-Linux-x86_64-325.08.run SHA256 SHA512 WHIRLPOOL size ;-) ...             [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.9.7/build
 * Found sources for kernel version:
 *     3.9.7
>>> Unpacking source...
>>> Unpacking NVIDIA-Linux-x86_64-325.08.run to /var/tmp/portage/x11-drivers/nvidia-drivers-325.08/work
>>> Source unpacked in /var/tmp/portage/x11-drivers/nvidia-drivers-325.08/work
>>> Preparing source in /var/tmp/portage/x11-drivers/nvidia-drivers-325.08/work ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-drivers/nvidia-drivers-325.08/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-drivers/nvidia-drivers-325.08/work ...
 * Preparing nvidia module
make -j3 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' ARCH=x86_64 IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/3.9.7/build CC=x86_64-pc-linux-gnu-gcc clean module
NVIDIA: calling KBUILD...
/bin/sh: line 0: cd: /lib/modules/3.9.7/build: Nie jest katalogiem
make[1]: Wejście do katalogu `/usr/src/linux-3.9.7'
make -C /lib/modules/3.9.7/build \
KBUILD_SRC=/usr/src/linux-3.9.7 \
KBUILD_EXTMOD="/var/tmp/portage/x11-drivers/nvidia-drivers-325.08/work/kernel" -f /usr/src/linux-3.9.7/Makefile \
modules
make: Wejście do nieznanego katalogu
make: *** /lib/modules/3.9.7/build: Brak dostępu. Stop.
make: Opuszczenie nieznanego katalogu
make[1]: *** [sub-make] Błąd 2
make[1]: Opuszczenie katalogu `/usr/src/linux-3.9.7'
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make: *** [module] Błąd 1
 * ERROR: x11-drivers/nvidia-drivers-325.08::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-325.08::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-325.08::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-325.08/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-325.08/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-325.08/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-325.08/work/'


Jakieś pomysły?


Last edited by Pryka on Thu Aug 22, 2013 7:01 am; edited 1 time in total
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 493

PostPosted: Wed Aug 21, 2013 12:17 pm    Post subject: Reply with quote

Do jajka >= 3.10 potrzebujesz steru
Code:
x11-drivers/nvidia-drivers-325.15
lub nowszego.

Ten na jaju 3.10.5 zbudował się prawidłowo bez żadnych specjalnych czarów czy łatek.

Przy Grsecurity nie nakłada się już łatki pax-const, a tylko pax-usercopy.
U mnie na jajkach 3.10.7 i 3.10.9 z grsec/pax Nvidia 325.15 z łatką pax-usercopy chodzi bez problemu.

Quote:
Code:
make: *** /lib/modules/3.9.7/build: Brak dostępu. Stop.

Co to ma być, to już sam sobie odpowiedz. ;)

U mnie:
Code:
ls -l /lib/modules/`uname -r`/build
lrwxrwxrwx 1 root root 43 08-21 04:33 /lib/modules/3.10.9-gr1/build -> /home/fabryka/kernel/src64/linux-3.10.9-gr1


Pozdro
8)
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Wed Aug 21, 2013 12:57 pm    Post subject: Reply with quote

Jacekalex wrote:
Do jajka >= 3.10 potrzebujesz steru
Code:
x11-drivers/nvidia-drivers-325.15
lub nowszego.

Ten na jaju 3.10.5 zbudował się prawidłowo bez żadnych specjalnych czarów czy łatek.

Tak wiem o tym, ale na razie żadnych się nie da zainstalować.

Jacekalex wrote:
Przy Grsecurity nie nakłada się już łatki pax-const, a tylko pax-usercopy.
U mnie na jajkach 3.10.7 i 3.10.9 z grsec/pax Nvidia 325.15 z łatką pax-usercopy chodzi bez problemu.

Nie używam grsec od jakiegoś roku.

Jacekalex wrote:
Quote:
Code:
make: *** /lib/modules/3.9.7/build: Brak dostępu. Stop.

Co to ma być, to już sam sobie odpowiedz. ;)

U mnie:
Code:
ls -l /lib/modules/`uname -r`/build
lrwxrwxrwx 1 root root 43 08-21 04:33 /lib/modules/3.10.9-gr1/build -> /home/fabryka/kernel/src64/linux-3.10.9-gr1


Pozdro
8)

U mnie,
Code:
lrwxrwxrwx 1 root root 20 08-21 10:37 /lib/modules/3.9.7/build -> /usr/src/linux-3.9.7

więc jak widzisz, sam sobie niestety nie odpowiedziałem :)
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 493

PostPosted: Wed Aug 21, 2013 1:03 pm    Post subject: Reply with quote

Spróbuj, czy sterownik buduje się z palca, może emerge jakieś zmienne ustawia inaczej.

Uprawnienia chyba tu nie są problemem, u mnie:
Code:
ls -ld /home/fabryka/kernel/src64/linux-3.10.9-gr1
drwx------ 25 root root 4096 08-21 04:33 /home/fabryka/kernel/src64/linux-3.10.9-gr1
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Wed Aug 21, 2013 1:54 pm    Post subject: Reply with quote

Z palca jest to samo :(


Uprawnienia, też na pewno nie jak już sam stwierdziłeś.
Code:
sudo ls -ld /usr/src/linux-3.9.7
drwxr-xr-x 25 root root 4096 08-21 10:37 /usr/src/linux-3.9.7



Wygoglować kurde też nic konkretnego nie mogę, na bugzilli też nic pomocnego nie ma.


PS. Odkryłem pewną ciekawostkę, po wywaleniu w cholere całej zawartości z /lib/modules/3.9.7/ nvidia daje radę się zainstalować, mogę w sumie po zainstalowaniu sterowników wszystko przywrócić z powrotem do tego katalogu, ale to głupiego robota.
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2831

PostPosted: Wed Aug 21, 2013 4:45 pm    Post subject: Reply with quote

Portage pewnie zrzuca roota i na portage userze pracuje, sprawdz uprawnienia do /usr/src/ albo wylacz userpriv feature.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 493

PostPosted: Wed Aug 21, 2013 10:53 pm    Post subject: Reply with quote

SlashBeast wrote:
Portage pewnie zrzuca roota i na portage userze pracuje, sprawdz uprawnienia do /usr/src/ albo wylacz userpriv feature.

Prawda, z userpriv w FEATURES mam ten sam błąd.

Ciekawe tylko czemu przy instalacji sterownika z palca (ręcznie) się wywalił z tym błędem.
(A może nie wywalił?) ;)

Pozdro
8)
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Thu Aug 22, 2013 6:59 am    Post subject: Reply with quote

SlashBeast wrote:
Portage pewnie zrzuca roota i na portage userze pracuje, sprawdz uprawnienia do /usr/src/ albo wylacz userpriv feature.

Code:
drwxr-xr-x 5 root root 4096 08-22 06:34 /usr/src

Portage(grupa, użytkownik) tam nie ma dostępu jak widać, czyli wszystko jasne. Ciekawi mnie tylko jedno, do czego służy ten userpriv, bo opis tej opcji nie mówi nic poza tym, że ściąga roota przy niektórych operacjach. Znasz może jakiś bardziej namacalny przykład? Byłbym wdzięczny.



Jacekalex wrote:
Prawda, z userpriv w FEATURES mam ten sam błąd.

Ciekawe tylko czemu przy instalacji sterownika z palca (ręcznie) się wywalił z tym błędem.
(A może nie wywalił?) ;)

Pozdro
8)


Wywaliło, wywaliło. Ale z mojej winy akurat xD Sporo z tym kombinowałem wcześniej przestawiając trochę uprawnienia przed instalacją z palucha i sam zrobiłem sobie podobny efekt :D Głupek ze mnie, dopiero teraz na to wpadłem jak mi zwróciłeś uwagę czy aby na pewno instalowałem z ręki :(


Co by nie było dziękuje wam obydwu za pomoc. Pozdrawiam
Back to top
View user's profile Send private message
canis_lupus
l33t
l33t


Joined: 22 Dec 2005
Posts: 746
Location: Kraków

PostPosted: Sat Sep 21, 2013 7:03 pm    Post subject: Reply with quote

U mnie się to nie chce kompilować, nawet jak dam a+rwx na całym /usr/src.
_________________
"I love you cię" Różyczko...
Fotografia ślubna
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Mon Sep 23, 2013 9:04 am    Post subject: Reply with quote

Sterowniki 325.15(przynajmniej u mnie) nie instalują się na jajku >=3.11.x bez patcha. Jacekalex dał do niego link w tym temacie http://forums.gentoo.org/viewtopic-t-968194.html

Ewentualnie może masz włączone to całe userpriv w portage?
Back to top
View user's profile Send private message
canis_lupus
l33t
l33t


Joined: 22 Dec 2005
Posts: 746
Location: Kraków

PostPosted: Mon Sep 23, 2013 5:01 pm    Post subject: Reply with quote

Nie włączałem. :D
Ja mam jajo 3.10.7, więc wg tego co mówisz - powinno się kompilować.
_________________
"I love you cię" Różyczko...
Fotografia ślubna
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Wed Sep 25, 2013 11:51 am    Post subject: Reply with quote

canis_lupus wrote:
Nie włączałem. :D
Ja mam jajo 3.10.7, więc wg tego co mówisz - powinno się kompilować.



I ja nie włączałem :D samo się włączyło razem z aktualizacją portage do 2.2(chyba?) :) więc lepiej sprawdź.


A jaki błąd Ci wyskakuje? Taki sam jak u mnie wcześniej?
Back to top
View user's profile Send private message
tswiercz
Tux's lil' helper
Tux's lil' helper


Joined: 05 Dec 2004
Posts: 106

PostPosted: Sat Jan 04, 2014 8:36 pm    Post subject: Reply with quote

Nie chcę jeszcze otwierać nowego wątku, może sobie sam poradzę. Ale ogólnie po ostatnich updateach zauażyłem, że freeze systemu powróciły.
Zazwyczaj nvidia jest temu winna, więc teraz też zaczynam od tej strony.
I teraz w tym wątku patrze, że:
Quote:
Do jajka >= 3.10 potrzebujesz steru

No ok, może tu jest błąd. Ale równocześnie, jedyny nie zamaskowany gentoo source to 3.10
a z drugiej strony najpóźniejsza niezamaskowana nvidia to 319.76.
Czy jest coś o czym nie wiem? Wszystko mi się kompiluje, tylko te freezy na chromium...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum