Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
no sound after steam installation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
genLin
n00b
n00b


Joined: 14 Sep 2013
Posts: 8
Location: Bochum

PostPosted: Sun Sep 15, 2013 9:19 am    Post subject: no sound after steam installation Reply with quote

Hi,

after I installed steam with about 17 dependencies where one was something with "pulseaudio alsa" it is not possible to simultaneously play sound files. I had to close steam and then could play a flashstreamed video... is there any suggestion to solve this?

I looked through the forums but I found nothing related to my topic.

thx in advance
_________________
Lieber ein Pinguin der rennt, als ein Fenster das hängt.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5282

PostPosted: Sun Sep 15, 2013 3:39 pm    Post subject: Reply with quote

I've come across stuff like this before. All I remember offhand is doing something to your alsa config to make sure it can handle simultaneous streams. Try searching for "linux alsa simultaneous audio" and variants. If you find something, please share, because I'm interested in documenting it on gentoostudio.org.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
genLin
n00b
n00b


Joined: 14 Sep 2013
Posts: 8
Location: Bochum

PostPosted: Mon Sep 16, 2013 6:25 am    Post subject: Reply with quote

Thats what I`ve found. Couldn#t test it yet. I am at work while writing this. Will check this at home later. Maybe thats helping you out? Feedback would be a pleasure.

http://ptspts.blogspot.de/2009/03/how-to-select-alsa-sound-card-and-have.html
_________________
Lieber ein Pinguin der rennt, als ein Fenster das hängt.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Mon Sep 16, 2013 8:25 am    Post subject: Reply with quote

audiodef wrote:
doing something to your alsa config

Ahem. Seen the config in my sig? It's a method that works, without pulseaudio.
_________________
Improve your font rendering and ALSA sound
Back to top
View user's profile Send private message
genLin
n00b
n00b


Joined: 14 Sep 2013
Posts: 8
Location: Bochum

PostPosted: Mon Sep 16, 2013 10:40 am    Post subject: Reply with quote

Pulseaudio was emerged as dependency by steam-meta package using layman -a steamlayer(guess it was called like this)

so it was not my "own"-choice to use or install pulseaudio... my suggestion is,if I delete pulseaudio, steam won't run.
correct me If I am totally wrong..
_________________
Lieber ein Pinguin der rennt, als ein Fenster das hängt.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Mon Sep 16, 2013 11:09 am    Post subject: Reply with quote

Steam does not need pulseaudio.
Back to top
View user's profile Send private message
genLin
n00b
n00b


Joined: 14 Sep 2013
Posts: 8
Location: Bochum

PostPosted: Mon Sep 16, 2013 3:52 pm    Post subject: Reply with quote

if you're correct then why is it within the "needed" dependencies? the realpackage name was pulseaudio[alsa] 1.2.6~

btw:

I used ur sound config file u pasted to dropbox. Is it possible to use this with /etc/asound.conf as well?

Thx
_________________
Lieber ein Pinguin der rennt, als ein Fenster das hängt.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Mon Sep 16, 2013 4:54 pm    Post subject: Reply with quote

Ask them, not me. Maybe they simply hadn't tested it without pulseaudio.

/etc/asound.conf should work also, I haven't bothered to test it.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1242
Location: 42.68n 85.41w

PostPosted: Tue Sep 17, 2013 3:50 am    Post subject: Reply with quote

$HOME/.asoundrc = user
/etc/asound.conf = system wide, ie all users

http://www.alsa-project.org/main/index.php/Asoundrc


if it works for 1, it works for the other.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2523
Location: UK

PostPosted: Tue Sep 17, 2013 2:57 pm    Post subject: Reply with quote

Pulseaudio in its default configuration (USE=alsa, which is a requirement for it to work at all) attempts to take over your system's sound by dropping config files into /usr/share/alsa/alsa.conf.d/ that replace your real sound card with PA ALSA emulation. To fix that, add those files to INSTALL_MASK in make.conf and re-emerge media-plugins/alsa-plugins.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5282

PostPosted: Tue Sep 17, 2013 8:07 pm    Post subject: Reply with quote

Now I remember - it's Paul's ALSA config that helps.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum