Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Evitare di installare 1 pacchetto che viene sempre proposto?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Sat Sep 14, 2013 8:57 pm    Post subject: Evitare di installare 1 pacchetto che viene sempre proposto? Reply with quote

Scusate ho un problema che necessita di una soluzione che non riesco a porre in essere vista la mia inesperienza con Gentoo. In pratica ho un portatile con doppia scheda grafica, intel + nvidia. Ho installato con successo bumblebee che avviato come demone mi tiene spenta la maledetta scheda grafica discreta ndivia che non uso mai, e che mi faceva consumare solo batteria e produrre estremo calore al portatile. Fin qui tutto bene, il problema però è che ogni volta che tento di aggiornare il sistema, tenta sempre di installarmi il maledettissimo "nvidia-drivers" che è richiesto dal sistema. Se lo installo la grafica non mi parte piu e il sistema mi resta bloccato in fase di boot. Come posso fare per annullare in maniera definitiva la richiesta di installazione di questo pacchetto nvidia-drivers?? ci sta un comando o qualcosa da modificare nel config di qualche file per non installare mai piu questo pacchetto?? questo è quello che mi da il sistema:

Code:
Calculating dependencies... done!
 * Dependencies could not be completely resolved due to
 * the following required packages not being installed:
 *
 *   x11-drivers/nvidia-drivers pulled in by:
 *     x11-base/xorg-drivers-1.13
 *
 * Have you forgotten to do a complete update prior to depclean? The
 * most comprehensive command for this purpose is as follows:
 *
 *   emerge --update --newuse --deep --with-bdeps=y @world
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Sun Sep 15, 2013 7:46 am    Post subject: Reply with quote

Se ti dice pulled in by x11-base/xorg-drivers-1.13, vuold dire che in make.conf hai qualcosa relativo a nvidia, se ho capito bene e non la usi, rimuovilo.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
sabayonino
Apprentice
Apprentice


Joined: 03 Jan 2012
Posts: 255

PostPosted: Sun Sep 15, 2013 8:18 am    Post subject: Reply with quote

ago wrote:
Se ti dice pulled in by x11-base/xorg-drivers-1.13, vuold dire che in make.conf hai qualcosa relativo a nvidia, se ho capito bene e non la usi, rimuovilo.


si nell'altro thread gli era stato suggerito di mettre "nvidia" nella VIDEO_CARD , ma non aveva indicato se ben ricordo che non voleva utilizzare nvidia.

forse ce l'avrà anche all'interno delle USE
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Sun Sep 15, 2013 9:04 am    Post subject: Reply with quote

No ragazzi "nvidia" lo avevo prima all'interno delle USE poi l'ho tolto da un pezzo, ma non so se dopo questo dovevo comunque aggiornare qualcosa nel sistema per dire che non lo deve piu usare. Il fatto e' che se mi installa nvidia il computer non mi parte piu in quanto resta bloccato, quindi devo togliere questo maledetto pacchetto nvidia che continua a propormi ad ogni emerge -uD world che io digito nel terminale. Vi ricordo che comunque ho dovuto installare bumblebee per spegnere la scheda discreta e maledetta (nvidia) forse l'avere settato all'interno del mio make.conf "bbswitch" genera questo problema? ogni volta che si ritoccano le USE comunque si deve dire al sistema di rigenerare il tutto? se si con quale comando specifico questo?
emerge --update --deep --with-bdeps=y world

Edit

Questo il mio attuale make.conf

Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="bindist mmx sse sse2"
MAKEOPTS="-j5"
GENTOO_MIRRORS="http://gentoo.inode.at/ ftp://gd.tuwien.ac.at/opsys/linux/gentoo/"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="-gnome -kde -minimal qt xcb policykit dbus vaapi dri dri2 alsa nsplugin flash pdf git subversion jpeg lock session gtk networkmanager pulseaudio startup-notification thunar systemd-consolekit pam udev udisks upower X dvd ffmpeg mpeg mad
 wxwindows aac dts a52 ogg flac theora oggvorbis matroska x264 freetype bidi xv xvid svga gnutls stream vlm httpd cdda
 vcd cdio live lua aalib fbcon svg unicode v4l xosd"
VIDEO_CARDS="intel vesa fbdev"
INPUT_DEVICES="evdev synaptics"
#ACCEPT_KEYWORDS="~amd64"

# Set PORTDIR for backward compatibility with various tools:
#   gentoo-bashcomp - bug #478444
#   euse - bug #474574
#   euses and ufed - bug #478318
PORTDIR="/usr/portage"
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Sun Sep 15, 2013 9:10 am    Post subject: Reply with quote

nvidia non si installa da solo, devi trovare dove lo hai settato.

Code:
grep -Ri "nvidia" /etc/portage/

_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Sun Sep 15, 2013 9:15 am    Post subject: Reply with quote

ago wrote:
nvidia non si installa da solo, devi trovare dove lo hai settato.

Code:
grep -Ri "nvidia" /etc/portage/


il comando che mi hai suggerito non mi restituisce nulla, semplicemente il terminale va a capo senza generarmi alcun risultato
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Sun Sep 15, 2013 9:17 am    Post subject: Reply with quote

aggiorna i pacchetti singolarmente, poi quando resta solo nvidia-drivers lancia:

Code:
emerge -DuNpvt world

_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Sun Sep 15, 2013 9:35 am    Post subject: Reply with quote

ago wrote:
aggiorna i pacchetti singolarmente, poi quando resta solo nvidia-drivers lancia:

Code:
emerge -DuNpvt world

come si aggiornano i pacchetti singolarmente? in genere io do un
emerge --sync
poi emerge --update --ask world
e questo mi aggiorna eventuali pacchetti
ma se lancio ad esempio il comando: emerge -uD world mi fa sempre installare quel maledetto driver nvidia che mi rovina sempre il sistema, e ogni volta mi tocca subito dare il comando emerge --unmerge nivida-drivers altrimenti se riavvio ho il solito blocco. Ecco perche' la mia richiesta di dire al mio sistema che non mi deve installare questo maledetto pacchetto.
Se do direttamente il comando che mi hai suggerito sopra, vale a dire: emerge -DuNpvt world
risolvo definitivamente il mio problema?? oppure non posso mettere qualcosa dentro il package.mask per dire che quel pacchetto nvidia non me lo deve MAI installare?
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Sun Sep 15, 2013 9:40 am    Post subject: Reply with quote

Prima di fare le cose, dovresti capire un po' di più la logica che ci sta dietro. Se non configuri Xorg per farlo funzionare con nvidia, come è possibile che ti blocca il sistema?

Aggiorna i pacchetti che -Du ti suggerisce, uno per uno emerge $pacchetto -1q e lascia solo nvidia, poi -t ci fa capire meglio chi tira dentro nvidia.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Sun Sep 15, 2013 9:55 am    Post subject: Reply with quote

ago wrote:
Prima di fare le cose, dovresti capire un po' di più la logica che ci sta dietro. Se non configuri Xorg per farlo funzionare con nvidia, come è possibile che ti blocca il sistema?

Aggiorna i pacchetti che -Du ti suggerisce, uno per uno emerge $pacchetto -1q e lascia solo nvidia, poi -t ci fa capire meglio chi tira dentro nvidia.


Mi genere questo il comando che mi hai suggerito:

Code:
versus tano # emerge -DuNpvt world

These are the packages that would be merged, in reverse order:

Calculating dependencies /

!!! Problem resolving dependencies for x11-misc/bumblebee from @selected
... done!

!!! The ebuild selected to satisfy "x11-misc/bumblebee" has unmet requirements.
- x11-misc/bumblebee-3.2.1::gentoo USE="bbswitch" VIDEO_CARDS="-nouveau -nvidia"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( video_cards_nouveau video_cards_nvidia )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Quindi a questo punto non capisco piu cosa dovrei fare, mi pare di capire che tutto come pensavo ha a che fare con la use "bbswitch" che ho dovuto mettere per installare e fare funzionare bumblebee. Quello che mi suggerisce cioè il "-nvidia -nouveau" per caso li devo settare nella parte del config VIDEO_CARDS nel make.conf e farlo diventare cosi?

VIDEO_CARDS="intel vesa fbdev -nvidia -nouveau"


Last edited by tano70 on Sun Sep 15, 2013 9:59 am; edited 1 time in total
Back to top
View user's profile Send private message
sabayonino
Apprentice
Apprentice


Joined: 03 Jan 2012
Posts: 255

PostPosted: Sun Sep 15, 2013 9:56 am    Post subject: Reply with quote

ho visto che hai commentato ACCEPT_KEYWORDS ,

hai dato il comando suggerito da portage ?

mi sembra più che normale che quando si toccano le USE vada ricompilato. mica portage può sapere cosa hai modificato se non glielo dici

e se avevi nvidia da qualche parte , sicuramente lui pensa che ci sia ancora (sicuramente in xorg-drivers)

Code:
# eix  --print-all-useflags | grep nvidia

_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Sun Sep 15, 2013 10:00 am    Post subject: Reply with quote

Bumblebee per funzionare ha bisogno di nvidia o ati...quindi sinceramente non so che stai combinando.

Se la situazione ti sta bene cosi e vuoi imbrogliare portage, crea un repo locale e crea un nvidia-drivers che non installa nulla.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Sun Sep 15, 2013 10:00 am    Post subject: Reply with quote

sabayonino wrote:
ho visto che hai commentato ACCEPT_KEYWORDS ,

hai dato il comando suggerito da portage ?

mi sembra più che normale che quando si toccano le USE vada ricompilato. mica portage può sapere cosa hai modificato se non glielo dici

e se avevi nvidia da qualche parte , sicuramente lui pensa che ci sia ancora (sicuramente in xorg-drivers)

Code:
# eix  --print-all-useflags | grep nvidia


Code:
versus tano # eix  --print-all-useflags | grep nvidia
bash: eix: command not found


P.S lo sto installando con emerge eix

Edit

Code:
versus tano # eix  --print-all-useflags | grep nvidia
+gfxnvidia
nvidia
video_cards_nvidia
versus tano #


sabayonino wrote:
ho visto che hai commentato ACCEPT_KEYWORDS ,

hai dato il comando suggerito da portage ?



Cioè quale comando dovrei dare? questo?
emerge --update --newuse --deep --with-bdeps=y @world


Last edited by tano70 on Sun Sep 15, 2013 10:14 am; edited 2 times in total
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Sun Sep 15, 2013 10:09 am    Post subject: Reply with quote

ago wrote:
Bumblebee per funzionare ha bisogno di nvidia o ati...quindi sinceramente non so che stai combinando.

Se la situazione ti sta bene cosi e vuoi imbrogliare portage, crea un repo locale e crea un nvidia-drivers che non installa nulla.


So benissimo che il funzionamento di "bumblebee" si basa sui driver ndivia o ati, visto che presuppone appunto un portatile con doppia scheda grafica. Il problema è che a me non serve proprio usare la nvidia, quindi non mi serve dare optirun nomeprogramma per fargli usare la nvidia !!
Il mio obbiettivo con bumblebee era spegnere la scheda discreta nvidia e ci sono riuscito, ma per qualche strano motivo non devo installare i driver nivida, perchè se li metto mi si blocca il sistema in fase di avvio, per un problema opengl mi pare!! su ubuntu e altri sistemi linux non so perchè ma anche avendo installato i driver nvidia, tutto mi funzionava bene, anche su archlinux ho installato i driver nividia, e il sistema non si blocca. Su gentoo non posso installarli. Quindi se mi date una soluzione concreta per continuare a tenere spenta la scheda grafica con bumblebee e al contempo non fargli installare i driver nvidia ve ne sarei davvero grato. Per questo avevo comunque aperto un post, su bumblebee e nvidia che non riuscivo ad avviare, ma non mi si è data alcuna soluzione
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Sun Sep 15, 2013 10:15 am    Post subject: Reply with quote

tano70 wrote:
So benissimo che il funzionamento di "bumblebee" si basa sui driver ndivia o ati, visto che presuppone appunto un portatile con doppia scheda grafica. Il problema è che a me non serve proprio usare la nvidia, quindi non mi serve dare optirun nomeprogramma per fargli usare la nvidia !!
Il mio obbiettivo con bumblebee era spegnere la scheda discreta nvidia e ci sono riuscito, ma per qualche strano motivo non devo installare i driver nivida, perchè se li metto mi si blocca il sistema in fase di avvio, per un problema opengl mi pare!! su ubuntu e altri sistemi linux non so perchè ma anche avendo installato i driver nvidia, tutto mi funzionava bene, anche su archlinux ho installato i driver nividia, e il sistema non si blocca. Su gentoo non posso installarli. Quindi se mi date una soluzione concreta per continuare a tenere spenta la scheda grafica con bumblebee e al contempo non fargli installare i driver nvidia ve ne sarei davvero grato. Per questo avevo comunque aperto un post, su bumblebee e nvidia che non riuscivo ad avviare, ma non mi si è data alcuna soluzione


Il mio suggerimento di prima dovrebbe risolvere
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Sun Sep 15, 2013 10:20 am    Post subject: Reply with quote

ago wrote:
tano70 wrote:
So benissimo che il funzionamento di "bumblebee" si basa sui driver ndivia o ati, visto che presuppone appunto un portatile con doppia scheda grafica. Il problema è che a me non serve proprio usare la nvidia, quindi non mi serve dare optirun nomeprogramma per fargli usare la nvidia !!
Il mio obbiettivo con bumblebee era spegnere la scheda discreta nvidia e ci sono riuscito, ma per qualche strano motivo non devo installare i driver nivida, perchè se li metto mi si blocca il sistema in fase di avvio, per un problema opengl mi pare!! su ubuntu e altri sistemi linux non so perchè ma anche avendo installato i driver nvidia, tutto mi funzionava bene, anche su archlinux ho installato i driver nividia, e il sistema non si blocca. Su gentoo non posso installarli. Quindi se mi date una soluzione concreta per continuare a tenere spenta la scheda grafica con bumblebee e al contempo non fargli installare i driver nvidia ve ne sarei davvero grato. Per questo avevo comunque aperto un post, su bumblebee e nvidia che non riuscivo ad avviare, ma non mi si è data alcuna soluzione


Il mio suggerimento di prima dovrebbe risolvere


si ma concretamente non saprei come fare quella soluzione che hai suggerito. Come creare in locale ciò che mi hai detto.
Se non ti pesa troppo puoi darmi un how to completo di comandi e passaggi per mettere in pratica correttamente il tuo suggerimento? possibilmente una guida completa adattata al mio caso, non esempi virtuali! sono inesperiente purtroppo e certe cose per voi ovvie per me non lo sono
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Sun Sep 15, 2013 10:43 am    Post subject: Reply with quote

Prima prova a fare qualcosa di più semplice, installa nvidia-drivers e rimuovi il modulo che installa in /lib/modules. Poi riavvia e vedi se si blocca
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Sun Sep 15, 2013 10:57 am    Post subject: Reply with quote

Allora ho aggiunto sotto VIDEO_CARDS="intel vesa fbdev nvidia"

poi ho ridato il comando che mi hai suggerito e mi propone questo, secondo te per stabilizzare il tutto devo eseguire tutto quello che mi propone il sistema?

Code:
versus tano # emerge -DuNpvt world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] app-portage/layman-2.0.0  USE="git subversion -bazaar -cvs -darcs -mercurial {-test}" PYTHON_TARGETS="python2_7 (-pypy2_0) -python2_6"
[ebuild   R    ]  virtual/python-argparse-1  PYTHON_TARGETS="python2_7 python3_2 (-pypy2_0) -python2_6 (-python3_3) (-pypy1_9%) (-python2_5%) (-python3_1%)" 0 kB
[nomerge       ] media-sound/pavucontrol-1.0  USE="nls"
[ebuild   R    ]  media-libs/libcanberra-0.30-r1  USE="alsa gtk gtk3 pulseaudio* sound udev -gnome -gstreamer -oss -tdb" 312 kB
[nomerge       ] www-client/chromium-30.0.1599.37  USE="cups pulseaudio -bindist -custom-cflags -gnome -gnome-keyring -gps -kerberos (-neon) (-selinux) (-system-sqlite) (-tcmalloc) {-test}" LINGUAS="am ar bg bn ca cs da de el en_GB es es_LA et fa fi fil fr gu he hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt_BR pt_PT ro ru sk sl sr sv sw ta te th tr uk vi zh_CN zh_TW"
[ebuild   R    ]  dev-libs/libxslt-1.1.28-r1  USE="crypt -debug -python -static-libs" PYTHON_TARGETS="python2_7 -python2_6 (-python2_5%)" 3,356 kB
[ebuild   R    ] www-client/opera-12.16_p1860  USE="gstreamer gtk (multilib) -kde" LINGUAS="-af -ar -az -be -bg -bn -cs -da -de -el -en_GB -es_ES -es_LA -et -fa -fi -fr -fr_CA -fy -gd -he -hi -hr -hu -id -it* -ja -ka -kk -ko -lt -lv -me -mk -ms -nb -nl -nn -pa -pl -pt -pt_BR -ro -ru -sk -sr -sv -sw -ta -te -th -tl -tr -uk -ur -uz -vi -zh_CN -zh_TW -zu" 13,691 kB
[ebuild   R    ] net-im/pidgin-2.10.7-r4  USE="dbus gnutls* gstreamer gtk ncurses networkmanager nls spell xscreensaver (-aqua) -debug -doc -eds -gadu -groupwise -idn -meanwhile -mxit -perl -prediction -python -sasl -silc -tcl -tk -zephyr -zeroconf" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 9,836 kB
[ebuild   R    ] xfce-extra/tumbler-0.1.25  USE="ffmpeg* jpeg pdf -debug -gstreamer -odf -raw" 468 kB
[ebuild   R    ] xfce-extra/xfce4-sensors-plugin-1.2.5  USE="acpi libnotify -debug -hddtemp -lm_sensors" VIDEO_CARDS="nvidia*" 391 kB
[ebuild   R    ] media-video/mplayer-1.1.1-r1  USE="X a52 aalib* alsa bidi* cdio dts dv dvd dvdnav enca encode faad fbcon* gif iconv ipv6 jpeg libass live mad mmx mng mp3 network opengl osdmenu png pulseaudio* quicktime rar rtc sdl shm speex sse sse2 theora toolame tremor truetype twolame unicode v4l* vorbis x264 xscreensaver xv xvid -3dnow -3dnowext (-altivec) (-aqua) -bindist -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dvb -dxr3 -faac -ftp -ggi -gsm -jack -joystick -jpeg2k -ladspa -libcaca -libmpeg2 -lirc -lzo -md5sum -mmxext -nas -nut -openal -oss -pnm -pvr -radio -rtmp -samba -ssse3 -tga -vdpau (-vidix) -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx" 10,940 kB
[nomerge       ] media-sound/audacious-3.2.2-r1  USE="gtk nls session -chardet -gtk3"
[ebuild   R    ]  media-plugins/audacious-plugins-3.2.2-r1  USE="aac alsa cdda ffmpeg* flac gtk ipv6 libnotify mp3 nls pulseaudio* sdl vorbis -adplug -bs2b -cue -fluidsynth -gnome -gtk3 -jack -lame -libsamplerate -midi -mms -mtp -oss -scrobbler -sid -sndfile -wavpack" 1,854 kB
[ebuild   R    ] net-misc/wget-1.14  USE="gnutls* ipv6 nls pcre ssl zlib -debug -idn -ntlm -static -uuid" 1,547 kB
[nomerge       ] xfce-extra/tumbler-0.1.25  USE="ffmpeg* jpeg pdf -debug -gstreamer -odf -raw"
[ebuild  N     ]  media-video/ffmpegthumbnailer-2.0.8  USE="gtk jpeg png -gnome" 359 kB
[nomerge       ] www-client/opera-12.16_p1860  USE="gstreamer gtk (multilib) -kde" LINGUAS="-af -ar -az -be -bg -bn -cs -da -de -el -en_GB -es_ES -es_LA -et -fa -fi -fr -fr_CA -fy -gd -he -hi -hr -hu -id -it* -ja -ka -kk -ko -lt -lv -me -mk -ms -nb -nl -nn -pa -pl -pt -pt_BR -ro -ru -sk -sr -sv -sw -ta -te -th -tl -tr -uk -ur -uz -vi -zh_CN -zh_TW -zu"
[ebuild   R    ]  media-plugins/gst-plugins-meta-0.10-r8:0.10  USE="X a52 aac alsa cdda dts dvd ffmpeg* flac mp3 mpeg ogg pulseaudio* theora* v4l* vcd* vorbis x264 xv xvid -dv -dvb -http -jack -lame -libass -libvisual -mms -musepack -opus -oss -taglib -vpx -wavpack" 0 kB
[ebuild  N     ]   media-plugins/gst-plugins-mplex-0.10.23:0.10  3,082 kB
[ebuild  N     ]    media-video/mjpegtools-2.0.0-r3:1  USE="gtk mmx png sdl v4l -dga -dv -quicktime -sdlgfx -static-libs" 1,709 kB
[ebuild  N     ]   media-plugins/gst-plugins-pulse-0.10.31:0.10  2,674 kB
[ebuild  N     ]   media-plugins/gst-plugins-ffmpeg-0.10.13_p201211:0.10  USE="orc" 4,199 kB
[nomerge       ] media-video/mplayer-1.1.1-r1  USE="X a52 aalib* alsa bidi* cdio dts dv dvd dvdnav enca encode faad fbcon* gif iconv ipv6 jpeg libass live mad mmx mng mp3 network opengl osdmenu png pulseaudio* quicktime rar rtc sdl shm speex sse sse2 theora toolame tremor truetype twolame unicode v4l* vorbis x264 xscreensaver xv xvid -3dnow -3dnowext (-altivec) (-aqua) -bindist -bl -bluray -bs2b -cddb -cdparanoia -cpudetection -debug -dga -directfb -doc -dvb -dxr3 -faac -ftp -ggi -gsm -jack -joystick -jpeg2k -ladspa -libcaca -libmpeg2 -lirc -lzo -md5sum -mmxext -nas -nut -openal -oss -pnm -pvr -radio -rtmp -samba -ssse3 -tga -vdpau (-vidix) -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx"
[ebuild   R    ]  media-sound/mpg123-1.15.4  USE="alsa ipv6 pulseaudio* sdl sse (-3dnow) (-3dnowext) (-altivec) (-coreaudio) -int-quality -jack (-mmx) -nas -oss -portaudio" 784 kB
[ebuild   R    ]  virtual/ffmpeg-0.10.3  USE="X encode mp3 sdl theora* truetype vaapi* x264 -gsm -jpeg2k -speex -threads -vdpau" 0 kB
[ebuild   R    ]  media-libs/libsdl-1.2.15-r2  USE="X aalib* alsa audio fbcon* joystick opengl pulseaudio* video xv -custom-cflags -dga -directfb -ggi -libcaca -nas -oss (-ps3) -static-libs (-svga) -tslib -xinerama" 3,829 kB
[nomerge       ] mail-client/thunderbird-17.0.8  USE="alsa crypt dbus ipc jit ldap libnotify lightning startup-notification -bindist -custom-cflags -custom-optimization -debug -gconf -minimal -mozdom (-selinux) -system-sqlite -wifi" LINGUAS="-ar -ast -be -bg -bn_BD -br -ca -cs -da -de -el -en_GB -es_AR -es_ES -et -eu -fi -fr -fy_NL -ga_IE -gd -gl -he -hr -hu -hy_AM -id -is -it -ja -ko -lt -nb_NO -nl -nn_NO -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -sq -sr -sv_SE -ta_LK -tr -uk -vi -zh_CN -zh_TW"
[ebuild   R    ]  app-text/hunspell-1.3.2-r3  USE="ncurses nls readline -static-libs" LINGUAS="-af -bg -ca -cs -cy -da -de -el -en -eo -es -et -fo -fr -ga -gl -he -hr -hu -ia -id -is -it* -km -ku -lt -lv -mk -ms -nb -nl -nn -pl -pt -pt_BR -ro -ru -sk -sl -sq -sv -sw -tn -uk -zu" 954 kB
[nomerge       ] virtual/jdk-1.7.0:1.7
[nomerge       ]  dev-java/icedtea-bin-7.2.4.1:7  USE="X alsa cups nsplugin -cjk -doc -examples -source"
[nomerge       ]   net-print/cups-1.6.2-r5  USE="X acl dbus filters gnutls* pam ssl threads usb -debug -java -kerberos -lprng-compat -python (-selinux) -static-libs -xinetd -zeroconf" LINGUAS="ca* es* fr* ja* ru*"
[nomerge       ]    net-print/foomatic-filters-4.0.17  USE="cups dbus"
[nomerge       ]     net-print/cups-filters-1.0.34-r1  USE="jpeg png tiff -perl -static-libs -zeroconf"
[ebuild   R    ]      app-text/poppler-0.22.2-r2:0/35  USE="cairo cxx introspection jpeg lcms png qt4* tiff utils -cjk -curl -debug -doc -jpeg2k" 2,164 kB
[ebuild   R    ]       dev-util/cmake-2.8.10.2-r2  USE="ncurses qt4* -emacs {-test} -vim-syntax" 5,634 kB
[nomerge       ] app-misc/screenfetch-2.7.7
[nomerge       ]  media-gfx/scrot-0.8  USE="-bash-completion"
[nomerge       ]   media-libs/giblib-1.2.4
[nomerge       ]    media-libs/imlib2-1.4.5  USE="X bzip2 gif jpeg mp3 nls png tiff zlib -doc (-mmx) -static-libs"
[ebuild   R    ]     sys-devel/gettext-0.18.2  USE="acl cxx git* nls openmp -cvs -doc -emacs -java -static-libs" 15,330 kB
[nomerge       ] mail-client/thunderbird-17.0.8  USE="alsa crypt dbus ipc jit ldap libnotify lightning startup-notification -bindist -custom-cflags -custom-optimization -debug -gconf -minimal -mozdom (-selinux) -system-sqlite -wifi" LINGUAS="-ar -ast -be -bg -bn_BD -br -ca -cs -da -de -el -en_GB -es_AR -es_ES -et -eu -fi -fr -fy_NL -ga_IE -gd -gl -he -hr -hu -hy_AM -id -is -it -ja -ko -lt -nb_NO -nl -nn_NO -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -sq -sr -sv_SE -ta_LK -tr -uk -vi -zh_CN -zh_TW"
[ebuild   R    ]  app-crypt/pinentry-0.8.2  USE="gtk ncurses qt4* -caps -static" 419 kB
[nomerge       ] gnome-extra/nm-applet-0.9.6.4  USE="bluetooth -gconf"
[nomerge       ]  net-wireless/gnome-bluetooth-2.32.0-r1:2  USE="introspection -debug -doc -nautilus {-test}"
[nomerge       ]   app-mobilephone/obexd-0.46  USE="usb -eds -nokia -server"
[nomerge       ]    net-wireless/bluez-4.101-r5  USE="alsa consolekit cups readline usb -debug -gstreamer -pcmcia (-selinux) -test-programs" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild   R    ]     net-print/cups-1.6.2-r5  USE="X acl dbus filters gnutls* pam ssl threads usb -debug -java -kerberos -lprng-compat -python (-selinux) -static-libs -xinetd -zeroconf" LINGUAS="ca* es* fr* ja* ru*" 8,168 kB
[nomerge       ] xfce-extra/xfce4-sensors-plugin-1.2.5  USE="acpi libnotify -debug -hddtemp -lm_sensors" VIDEO_CARDS="nvidia*"
[ebuild  N     ]  media-video/nvidia-settings-304.60  USE="-examples" 1,446 kB
[nomerge       ] net-im/pidgin-2.10.7-r4  USE="dbus gnutls* gstreamer gtk ncurses networkmanager nls spell xscreensaver (-aqua) -debug -doc -eds -gadu -groupwise -idn -meanwhile -mxit -perl -prediction -python -sasl -silc -tcl -tk -zephyr -zeroconf" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"
[nomerge       ]  media-plugins/gst-plugins-meta-0.10-r8:0.10  USE="X a52 aac alsa cdda dts dvd ffmpeg* flac mp3 mpeg ogg pulseaudio* theora* v4l* vcd* vorbis x264 xv xvid -dv -dvb -http -jack -lame -libass -libvisual -mms -musepack -opus -oss -taglib -vpx -wavpack"
[ebuild  N     ]   media-plugins/gst-plugins-v4l2-0.10.31:0.10  USE="udev" 0 kB
[ebuild  N     ]   media-plugins/gst-plugins-theora-0.10.36:0.10  2,309 kB
[nomerge       ] net-misc/wicd-1.7.2.4-r2  USE="X gtk libnotify ncurses nls pm-utils -ambiance (-ioctl) -mac4lin"
[nomerge       ]  dev-python/notify-python-0.1.1-r3  USE="-examples" PYTHON_TARGETS="python2_7 -python2_6"
[nomerge       ]   dev-python/pygtk-2.24.0-r3:2  USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild   R    ]    dev-python/numpy-1.6.2-r2  USE="-doc -lapack {-test}" PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python2_5%) (-python3_1%)" 2,525 kB
[ebuild   R    ]     dev-python/setuptools-0.8-r1  PYTHON_TARGETS="python2_7 python3_2 (-pypy2_0) -python2_6 (-python3_3) (-pypy1_9%) (-python2_5%) (-python3_1%)" 740 kB
[ebuild   R    ]    dev-python/pycairo-1.10.0-r4  USE="svg xcb -doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_3) (-python3_1%)" 634 kB
[ebuild   R    ]     x11-libs/xpyb-1.3.1-r1  USE="(-selinux) -static-libs" PYTHON_SINGLE_TARGET="python2_7 -python2_6 -python3_2 (-python3_3) (-python2_5%) (-python3_1%)" PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_3) (-python2_5%) (-python3_1%)" 268 kB
[nomerge       ] app-portage/layman-2.0.0  USE="git subversion -bazaar -cvs -darcs -mercurial {-test}" PYTHON_TARGETS="python2_7 (-pypy2_0) -python2_6"
[nomerge       ]  dev-vcs/git-1.8.1.5  USE="blksha1 curl gpg gtk iconv nls pcre perl python subversion threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight (-ppcsha1) {-test} -tk -xinetd"
[nomerge       ]   dev-vcs/subversion-1.7.13  USE="berkdb nls perl webdav-neon -apache2 -ctypes-python -debug -doc -dso -extras -gnome-keyring -java -kde -python -ruby -sasl {-test} -vim-syntax -webdav-serf" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild   R    ]    net-libs/neon-0.29.6-r2  USE="gnutls* nls ssl zlib -doc -expat -kerberos -libproxy -pkcs11 -static-libs" LINGUAS="-cs -de -fr -ja -nn -pl -ru -tr -zh_CN" 862 kB
[nomerge       ] media-video/vlc-2.0.7  USE="X a52 aac aalib alsa avcodec avformat bidi cdda dbus dts dvbpsi dvd encode ffmpeg flac gcrypt gnutls httpd libnotify live lua matroska mmx mp3 mpeg ncurses ogg opengl png postproc pulseaudio qt4 sdl sse svg swscale theora truetype udev v4l vaapi vlm vorbis x264 xcb xml xosd xv (-altivec) -atmo (-audioqueue) -avahi -bluray -cddb -dc1394 -debug -dirac (-direct2d) -directfb (-directx) (-dshow) -dvb (-dxva2) -egl -fbosd -fluidsynth -fontconfig -gme -gnome -growl -ieee1394 (-ios-vout) -jack -kate -kde -libass -libcaca -libproxy -libsamplerate -libtar -libtiger -linsys -lirc (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) (-media-library) -modplug -mtp -musepack (-neon) -omxil -optimisememory -opus -oss -portaudio -projectm -pvr -rtsp -run-as-root -samba -schroedinger -sdl-image -shine -shout -sid -skins -speex -sqlite -switcher -taglib -twolame -upnp -vcdx (-waveout) (-wingdi) -wma-fixed -zvbi"
[nomerge       ]  x11-libs/xcb-util-0.3.9  USE="-doc -static-libs {-test}"
[nomerge       ]   x11-libs/xcb-util-wm-0.3.9  USE="-doc -static-libs {-test}"
[ebuild   R    ]    x11-proto/xcb-proto-1.8-r1  PYTHON_SINGLE_TARGET="python2_7 -python2_6 -python3_2 (-python3_3) (-python2_5%) (-python3_1%)" PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_3) (-python2_5%) (-python3_1%)" 123 kB
[ebuild   R    ]     dev-libs/libxml2-2.9.1-r1:2  USE="icu ipv6 python readline -debug -examples -lzma -static-libs {-test}" PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_3) (-python2_5%) (-python3_1%)" 5,052 kB
[ebuild   R    ]      dev-python/python-exec-0.3.1  PYTHON_TARGETS="(jython2_5) (jython2_7) (python2_6) (python2_7) (python3_2) (-pypy2_0) (-python3_3) (-pypy1_9%) (-python2_5%) (-python3_1%)" 73 kB
[nomerge       ] xfce-extra/xfce4-mixer-4.10.0  USE="alsa -debug -oss"
[ebuild   R    ]  dev-libs/keybinder-0.3.0-r200  USE="introspection lua* -python" 369 kB
[nomerge       ] x11-base/xorg-drivers-1.13  INPUT_DEVICES="evdev synaptics -acecad -aiptek -elographics -fpit -hyperpen -joystick -keyboard -mouse -mutouch -penmount -tslib -vmmouse -void -wacom" VIDEO_CARDS="fbdev intel nvidia vesa -apm -ark -ast -chips -cirrus -dummy -epson -fglrx (-geode) -glint -i128 (-i740) -mach64 -mga -modesetting -neomagic (-newport) -nouveau -nv (-omap) (-omapfb) -qxl -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -via -virtualbox -vmware (-voodoo)"
[ebuild  N     ]  x11-drivers/nvidia-drivers-319.49  USE="X acpi (multilib) tools -pax_kernel" 0 kB
[nomerge       ] xfce-extra/xfce4-sensors-plugin-1.2.5  USE="acpi libnotify -debug -hddtemp -lm_sensors" VIDEO_CARDS="nvidia*"
[ebuild     U  ]  sys-devel/libtool-2.4.2:2 [2.4-r1:2] USE="-static-libs% {-test} -vanilla" 849 kB
[ebuild   R    ] net-misc/iputils-20121221  USE="gnutls* ipv6 ssl -SECURITY_HAZARD -caps -doc -idn -static" 175 kB

Total: 40 packages (1 upgrade, 9 new, 30 reinstalls), Size of downloads: 107,110 kB

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Oppure devo limitarmi ad installare solo nvidia-drivers e poi cancellare dal percorso /lib/modules ?
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Sun Sep 15, 2013 11:04 am    Post subject: Reply with quote

segui lo step che ti ho già suggerito
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Sun Sep 15, 2013 11:11 am    Post subject: Reply with quote

ago wrote:
segui lo step che ti ho già suggerito

ok ho fatto installare gli nvidia-drivers dando il comando emerge -uD world
Ti copio l'output della installazione...in modo che lo guardi e prima che io cancelli da /lib/modules mi dici se eventualmente ci sta uno step che io debba fare per correggere quel blocco in avvio.

Code:
>>> Installing (2 of 2) x11-drivers/nvidia-drivers-319.49
 * Updating module dependencies for 3.10.7-gentoo-ARCH ...               [ ok ]
 * Adding module to moduledb.
Switching to xorg-x11 OpenGL interface... done
Switching to nvidia OpenCL interface... done
 * You must be in the video group to use the NVIDIA device
 * For more info, read the docs at
 * http://www.gentoo.org/doc/en/nvidia-guide.xml#doc_chap3_sect6
 *
 * This ebuild installs a kernel module and X driver. Both must
 * match explicitly in their version. This means, if you restart
 * X, you must modprobe -r nvidia before starting it back up
 *
 * To use the NVIDIA GLX, run "eselect opengl set nvidia"
 *
 * To use the NVIDIA CUDA/OpenCL, run "eselect opencl set nvidia"
 *
 * NVIDIA has requested that any bug reports submitted have the
 * output of nvidia-bug-report.sh included.
 *

 * Messages for package x11-drivers/nvidia-drivers-319.49:

 * You must be in the video group to use the NVIDIA device
 * For more info, read the docs at
 * http://www.gentoo.org/doc/en/nvidia-guide.xml#doc_chap3_sect6
 *
 * This ebuild installs a kernel module and X driver. Both must
 * match explicitly in their version. This means, if you restart
 * X, you must modprobe -r nvidia before starting it back up
 *
 * To use the NVIDIA GLX, run "eselect opengl set nvidia"
 *
 * To use the NVIDIA CUDA/OpenCL, run "eselect opencl set nvidia"
 *
 * NVIDIA has requested that any bug reports submitted have the
 * output of nvidia-bug-report.sh included.
 *
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * Regenerating GNU info directory index...
 * Processed 116 info files.

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.


versus tano # eselect opengl list
Available OpenGL implementations:
[1] nvidia
[2] xorg-x11 *


Non è che prima di riavviare per evitare quel famoso blocco al sistema, devo impostare su nvidia?
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Sun Sep 15, 2013 11:23 am    Post subject: Reply with quote

tano70 wrote:
Non è che prima di riavviare per evitare quel famoso blocco al sistema, devo impostare su nvidia?


NO, tu NON devi usare nvidia.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Sun Sep 15, 2013 11:29 am    Post subject: Reply with quote

ago wrote:
tano70 wrote:
Non è che prima di riavviare per evitare quel famoso blocco al sistema, devo impostare su nvidia?


NO, tu NON devi usare nvidia.

ok era solo una domanda, mai impostato quella variabile.
comunque sotto /lib/modules non trovo nvidia.
mi trovo solo la cartella relativa ai kernel, vale a dire 30.10.7-gentoo e la cartella 3.10.7-gentoo-ARCH, e all'interno della cartella gentoo'ARCH (che sarebbe il kernel che ho in uso) mi trovo le cartelle:
acpi build kernel misc source video
e poi diversi files che sono quelli che non ho elencato come cartelle:

Code:
tano@versus /lib/modules/3.10.7-gentoo-ARCH $ ls
acpi    modules.alias        modules.dep      modules.softdep      video
build   modules.alias.bin    modules.dep.bin  modules.symbols
kernel  modules.builtin      modules.devname  modules.symbols.bin
misc    modules.builtin.bin  modules.order    source
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 444

PostPosted: Sun Sep 15, 2013 1:18 pm    Post subject: Reply with quote

Secondo me vi state facendo un sacco di problemi per niente, bumblebee non si occupa della gestione energetica, quello lo fa bbswitch.
Bumblebee si appoggia a bbswitch per accendere la scheda quando è richiesta e spegnerla subito dopo.

Se non vuoi usare la scheda nvidia, basta installare bbswitch.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Sun Sep 15, 2013 1:22 pm    Post subject: Reply with quote

pierino_89 wrote:
Secondo me vi state facendo un sacco di problemi per niente, bumblebee non si occupa della gestione energetica, quello lo fa bbswitch.
Bumblebee si appoggia a bbswitch per accendere la scheda quando è richiesta e spegnerla subito dopo.

Se non vuoi usare la scheda nvidia, basta installare bbswitch.

ho gia' installato bbswitch ma per fare si che la nvidia mi resti sempre spenta ho installato anche bumblebee che mi sta attivo come demone. Mi dici come usare solo bbswitch e averlo sempre attivo ad ogni boot in modo che la nvidia mi resti sempre DEFINITIVAMENTE spenta, e cosi posso sbarazzarmi di bumblebee e quei maledetti driver nvidia che mi bloccano sempre l'avvio (se li tengo installati)
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 444

PostPosted: Sun Sep 15, 2013 1:28 pm    Post subject: Reply with quote

tano70 wrote:

ho gia' installato bbswitch ma per fare si che la nvidia mi resti sempre spenta ho installato anche bumblebee che mi sta attivo come demone.

Beh se è spenta resta spenta, nessuno la accende.

Quote:

Mi dici come usare solo bbswitch e averlo sempre attivo ad ogni boot in modo che la nvidia mi resti sempre DEFINITIVAMENTE spenta

Quel che bumblebee fa sotto questo piano è lanciare all'avvio il famoso comando "echo OFF > /proc/acpi/bbswitch" che hai già visto nell'altra discussione.
Crea un file in /etc/local.d con quel comando, aggiungi il servizio local al runlevel di default e sei a posto.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum