Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge hängt beim Kernelcheck
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
schmidicom
l33t
l33t


Joined: 09 Mar 2006
Posts: 984
Location: Schweiz

PostPosted: Thu Sep 12, 2013 8:57 am    Post subject: emerge hängt beim Kernelcheck Reply with quote

Seit einiger Zeit habe ich ein extrem nerviges Problem und keine Idee woher das kommt oder wie man dem endlich ein ende bereiten könnte. Immer wieder hängt emerge beim Kernelcheck und macht dann einfach gar nichts mehr

Die letzten drei Meldungen in der Konsole sind dann:
Code:
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux

Danach passiert einfach nichts mehr, emerge läuft und läuft und läuft ohne ersichtlichen Fortschritt.
Der Kernel liegt in /usr/src wie es unter Gentoo eben üblich ist.

Bis jetzt konnte ich durch abbrechen und nochmal starten das ganze dann doch noch weiterlaufen lassen aber inzwischen geht auch das nicht mehr.
Kann mir einer von euch weiterhelfen?

EDIT:
Ich bin jetzt mal dem Prozessbaum nachgegangen bis hin zu dem wo das Problem entsteht.
Der letzte Prozess war sh und dieser wurde als "zombie" betitelt und lies sich auch nicht mit kill abschießen. Aber dafür konnte ich den nächst höheren Prozess "make" killen und dann machte emerge weiter.
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)


Last edited by schmidicom on Wed Oct 02, 2013 8:14 am; edited 2 times in total
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2681
Location: Hamburg/Germany

PostPosted: Thu Sep 12, 2013 5:02 pm    Post subject: Reply with quote

Und da gibt es auch keine rekursiven links a'la ./linux -> . oder so ?
Back to top
View user's profile Send private message
schmidicom
l33t
l33t


Joined: 09 Mar 2006
Posts: 984
Location: Schweiz

PostPosted: Thu Sep 12, 2013 5:37 pm    Post subject: Reply with quote

Daran dachte ich auch schon aber der Ordner ist sauber, keine rekursive Links oder der gleichen.
Es scheint fast so als ob emerge in dem Ordner wo sich die Kernelsourcen befinden make ausführt und das startet dann /bin/sh welches sich an irgendetwas aufhängt, nur wieso. Ich dachte immer emerge wurde sich nur für die Kernelkonfig interessieren.
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2681
Location: Hamburg/Germany

PostPosted: Thu Sep 12, 2013 5:58 pm    Post subject: Reply with quote

schmidicom wrote:
Daran dachte ich auch schon aber der Ordner ist sauber, keine rekursive Links oder der gleichen.
Es scheint fast so als ob emerge in dem Ordner wo sich die Kernelsourcen befinden make ausführt und das startet dann /bin/sh welches sich an irgendetwas aufhängt, nur wieso. Ich dachte immer emerge wurde sich nur für die Kernelkonfig interessieren.
ah - und /bin/sh zeigt nicht etwa auf /bin/dash ?
Back to top
View user's profile Send private message
schmidicom
l33t
l33t


Joined: 09 Mar 2006
Posts: 984
Location: Schweiz

PostPosted: Thu Sep 12, 2013 6:10 pm    Post subject: Reply with quote

Alles normal:
Code:
slap ~ # ls -l /bin/sh
lrwxrwxrwx 1 root root 4 28. Aug 14:46 /bin/sh -> bash

Aber ich könnte es ja mal mit der zsh versuchen, schlimmer kann es kaum noch werden oder. ;)
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2681
Location: Hamburg/Germany

PostPosted: Thu Sep 12, 2013 6:27 pm    Post subject: Reply with quote

schmidicom wrote:
Alles normal:
Code:
slap ~ # ls -l /bin/sh
lrwxrwxrwx 1 root root 4 28. Aug 14:46 /bin/sh -> bash

Aber ich könnte es ja mal mit der zsh versuchen, schlimmer kann es kaum noch werden oder. ;)
Jo, wobei ich nicht glaube, daß es besser wird ...
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5678
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Sep 12, 2013 11:22 pm    Post subject: Reply with quote

zufällig portage 2.2.1 oder 2.2.0 ?

hab ein ähnliches Problem beim (versuchten) Installieren von ZFS bzw. spl, etc. gehabt (es findet Teile der Header/Sourcen nicht bzw. bricht ab),

dass es hängt bzw. loopt ist neu für mich



hatte das nicht weiter verfolgt, da ich eine frühere gesicherte Version vom Juni zurückgespielt hatte und es damit wieder ging (2.2.0_alpha179),

damals war es wichtiger, dass das System wieder lauffähig war >> dem nachzugehen

das blöde ist, dass keine früheren alpha-Versionen im Baum zu installieren sind :?

damit könnte man etwas einfacher nachverfolgen, ab wann das auftrat
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
schmidicom
l33t
l33t


Joined: 09 Mar 2006
Posts: 984
Location: Schweiz

PostPosted: Fri Sep 13, 2013 4:14 am    Post subject: Reply with quote

Gestern machte ich ein Update auf sys-apps/portage-2.2.1 aber das Problem existierte schon vorher, hatte bis jetzt nur keinen Bock mich damit zu beschäftigen.

UPDATE:
Mit der ZSH (/bin/sh -> zsh) hat es dreimal hintereinander fehlerfrei funktioniert und mit der bash hat es sich zweimal aufgehängt.
Sehr seltsam das ganze...

EDIT 30.09.2013:
Wenn ich die bash mit dem USE-Flag "vanilla" bauen hängt sich die bash beim Kernelcheck auch nicht mehr auf.

EDIT 02.10.2013:
Die Freude darüber das der Fehler weg ist kam wohl etwas zu früh, es passiert immer noch aber dafür seltener. Dafür habe ich nun den ESET AntiVirus im Verdacht mal sehen ob ein paar Ausschlussfilter oder eine zeitweilige Deaktivierung helfen.
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum