Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GNOME 3.6.2 blocked packages (vala/gnome-applets)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
zolom
n00b
n00b


Joined: 07 Apr 2012
Posts: 18

PostPosted: Thu Sep 12, 2013 3:39 pm    Post subject: GNOME 3.6.2 blocked packages (vala/gnome-applets) Reply with quote

I'm trying to install Gnome 3.6.2 on this laptop and getting the following:
Code:
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0-r1)
[blocks B      ] gnome-base/gnome-applets ("gnome-base/gnome-applets" is blocking gnome-base/gnome-core-apps-3.8.0)

Not entirely sure where this vala is coming from as my tree goes from 18.1 to 20.1.
The entire emerge output -- http://pastebin.com/ewzZSB4V
make.conf -- http://pastebin.com/kHnUbmBP
package.accept_keywords -- http://bpaste.net/show/131816/

I am not muddling through this one at all! What can I do? Thanks!
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Thu Sep 12, 2013 6:03 pm    Post subject: Reply with quote

/etc/portage/package.mask
<dev-lang/vala-0.20.0

Code:
emerge - C dev-lang/vala gnome-base/gnome-applets && emerge dev-lang/vala gnome-base/gnome-core-apps

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
zolom
n00b
n00b


Joined: 07 Apr 2012
Posts: 18

PostPosted: Thu Sep 12, 2013 6:48 pm    Post subject: Reply with quote

Still a bit goofed up. This got rid of the gnome-applets bit but it's still stuck on vala.

Code:
emerge -av dev-lang/vala gnome-base/gnome-core-apps
...
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0-r1)

Total: 279 packages (275 new, 4 in new slots, 1 uninstall), Size of downloads: 328,344 kB
Conflict: 3 blocks (1 unsatisfied)


It also wants to unmask:
Code:
The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by net-libs/gssdp-0.12.2.1[introspection]
# required by net-libs/gupnp-0.18.4
# required by net-libs/gupnp-igd-0.2.1
# required by net-libs/libnice-0.1.3-r1[upnp]
# required by media-plugins/gst-plugins-libnice-0.1.3-r100
# required by net-libs/farstream-0.2.2
# required by net-libs/telepathy-farstream-0.6.0
# required by net-im/empathy-3.8.4
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-core-apps (argument)
# /etc/portage/package.mask:
=dev-lang/vala-0.14.2-r2


But of course after those changes it's still stuck on the same block.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Thu Sep 12, 2013 7:09 pm    Post subject: Reply with quote

/etc/portage/package.mask
#Block <0.16 and > 0.18
<dev-lang/vala-0.18
>dev-lang/vala-0.18
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
zolom
n00b
n00b


Joined: 07 Apr 2012
Posts: 18

PostPosted: Thu Sep 12, 2013 7:25 pm    Post subject: Reply with quote

It still wants the same thing:
Code:

[ebuild  N    ~] gnome-base/gnome-core-apps-3.8.0:3.0  USE="bluetooth cdr cups networkmanager" 0 kB
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0-r1)
...

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by media-video/cheese-3.8.3
# required by net-im/empathy-3.8.4[v4l]
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-core-apps (argument)
# /etc/portage/package.mask:
#<dev-lang/vala-0.20.0
#Block <0.16 and > 0.18
=dev-lang/vala-0.20.1
# required by net-libs/gssdp-0.12.2.1[introspection]
# required by net-libs/gupnp-0.18.4
# required by net-libs/gupnp-igd-0.2.1
# required by net-libs/libnice-0.1.3-r1[upnp]
# required by media-plugins/gst-plugins-libnice-0.1.3-r100
# required by net-libs/farstream-0.2.2
# required by net-libs/telepathy-farstream-0.6.0
# required by net-im/empathy-3.8.4
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-core-apps (argument)
# /etc/portage/package.mask:
#<dev-lang/vala-0.20.0
#Block <0.16 and > 0.18
=dev-lang/vala-0.14.2-r2
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Thu Sep 12, 2013 7:29 pm    Post subject: Reply with quote

/etc/portage/package.mask
#Block <0.20
<dev-lang/vala-0.20.0

emerge -C vala && emerge -av vala(Say n and post output)
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
zolom
n00b
n00b


Joined: 07 Apr 2012
Posts: 18

PostPosted: Thu Sep 12, 2013 7:36 pm    Post subject: Reply with quote

No vala:
Code:
emerge -C vala && emerge -av vala                       
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

--- Couldn't find 'vala' to unmerge.

>>> No packages selected for removal by unmerge


And for the second question:
Code:
 # emerge -av vala

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    #] dev-lang/vala-0.20.1:0.20  USE="vapigen {-test}" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] n

Quitting.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Thu Sep 12, 2013 8:05 pm    Post subject: Reply with quote

zolom wrote:
No vala:
Code:
emerge -C vala && emerge -av vala                       
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

--- Couldn't find 'vala' to unmerge.

>>> No packages selected for removal by unmerge


And for the second question:
Code:
 # emerge -av vala

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    #] dev-lang/vala-0.20.1:0.20  USE="vapigen {-test}" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] n

Quitting.


Code:
emerge -av vala && emerge -av gobject-introspection(Answer y)

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
zolom
n00b
n00b


Joined: 07 Apr 2012
Posts: 18

PostPosted: Thu Sep 12, 2013 8:45 pm    Post subject: Reply with quote

I built vala:
Code:

emerge -av vala
...
[ebuild   R   #] dev-lang/vala-0.20.1:0.20  USE="vapigen {-test}" 0 kB


I built gobject-introspection:
Code:

emerge -av gobject-introspection
...
[ebuild   R   ~] dev-libs/gobject-introspection-1.36.0-r1  USE="cairo -doctool {-test}" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB


But if I build vala and gnome-core-apps at the same time it goes back to this:
Code:
[ebuild  N    ~] gnome-base/gnome-core-apps-3.8.0:3.0  USE="bluetooth cdr cups networkmanager" 0 kB
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0-r1)

Total: 279 packages (273 new, 5 in new slots, 1 reinstall, 1 uninstall), Size of downloads: 328,344 kB
Conflict: 3 blocks (1 unsatisfied)
[/code]
Back to top
View user's profile Send private message
zolom
n00b
n00b


Joined: 07 Apr 2012
Posts: 18

PostPosted: Thu Sep 12, 2013 9:04 pm    Post subject: Reply with quote

Unfortunately, it's the same deal:

Code:

emerge -av gnome-core-apps
...
[ebuild  N    ~] gnome-base/gnome-core-apps-3.8.0:3.0  USE="bluetooth cdr cups networkmanager" 0 kB
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0-r1)
...

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by net-libs/gssdp-0.12.2.1[introspection]
# required by net-libs/gupnp-0.18.4
# required by net-libs/gupnp-igd-0.2.1
# required by net-libs/libnice-0.1.3-r1[upnp]
# required by media-plugins/gst-plugins-libnice-0.1.3-r100
# required by net-libs/farstream-0.2.2
# required by net-libs/telepathy-farstream-0.6.0
# required by net-im/empathy-3.8.4
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-core-apps (argument)
# /etc/portage/package.mask:
=dev-lang/vala-0.14.2-r2

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Thu Sep 12, 2013 9:09 pm    Post subject: Reply with quote

This Block is Happening Because:
Code:
# required by net-libs/gssdp-0.12.2.1[introspection]  <--Offending Package is requesting
# required by net-libs/gupnp-0.18.4
# required by net-libs/gupnp-igd-0.2.1
# required by net-libs/libnice-0.1.3-r1[upnp]
# required by media-plugins/gst-plugins-libnice-0.1.3-r100
# required by net-libs/farstream-0.2.2
# required by net-libs/telepathy-farstream-0.6.0
# required by net-im/empathy-3.8.4
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-core-apps (argument)
=dev-lang/vala-0.14.2-r2

0.14.2 is < 0.20 which blocks gobject-introspection

Add this to package.accept_keywords for Gnome
net-libs/gssdp ~amd64

I remember this Now. I'm reporting this to have it merged or marked duplicate. Look at Libsoup Nightmare
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
zolom
n00b
n00b


Joined: 07 Apr 2012
Posts: 18

PostPosted: Thu Sep 12, 2013 9:37 pm    Post subject: Reply with quote

Ah-ha! I can build gnome-applets now:
Code:
emerge -av gnome-applets
...
[ebuild  N    ~] gnome-base/gnome-applets-3.6.0-r1  USE="cpufreq gnome ipv6 policykit -networkmanager" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6" 7,715 kB

Total: 184 packages (180 new, 4 in new slots, 1 uninstall), Size of downloads: 223,686 kB
Conflict: 2 blocks


But building gnome gave me this:
Code:
 
emerge -av ="gnome-3.6.2"
...
[ebuild  N    ~] gnome-base/gnome-3.6.2:2.0  USE="bluetooth cdr cups extras fallback -accessibility" 0 kB
[blocks B      ] gnome-base/gnome-applets ("gnome-base/gnome-applets" is blocking gnome-base/gnome-core-apps-3.8.0))

I added this to package.mask and now gnome looks like it's ready to build:
Code:
>dev-libs/libgweather-3.8
>=gnome-base/gnome-core-apps-3.8.0


That's okay right? Gnome-core-apps-3.8 goes with Gnome 3.8, so I would think I shouldn't arbitrarily have 3.8 versions of things unless I'm installing Gnome 3.8.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Sat Sep 14, 2013 6:56 pm    Post subject: Reply with quote

gnome applets was deprecated in 3.8 it doesn't exist , which is why its blocked by gnome-core-apps. Also, you may want to mask GNOME 3.8 until systemd is stabilized...
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
aim nano
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2006
Posts: 119
Location: Jackson, MS

PostPosted: Mon Oct 28, 2013 4:18 pm    Post subject: Reply with quote

eyoung100 wrote:
This Block is Happening Because:
Code:
# required by net-libs/gssdp-0.12.2.1[introspection]  <--Offending Package is requesting
# required by net-libs/gupnp-0.18.4
# required by net-libs/gupnp-igd-0.2.1
# required by net-libs/libnice-0.1.3-r1[upnp]
# required by media-plugins/gst-plugins-libnice-0.1.3-r100
# required by net-libs/farstream-0.2.2
# required by net-libs/telepathy-farstream-0.6.0
# required by net-im/empathy-3.8.4
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-core-apps (argument)
=dev-lang/vala-0.14.2-r2

0.14.2 is < 0.20 which blocks gobject-introspection

Add this to package.accept_keywords for Gnome
net-libs/gssdp ~amd64

I remember this Now. I'm reporting this to have it merged or marked duplicate. Look at Libsoup Nightmare


I wanted to quote this because adding net-libs/gssdp ~amd64 to package.accept_keywords fixed my vala / gobject-introspection block issue while installing gnome 3.8 too (and a few other people's too)
_________________
Unanswered posts need love too.
--
~ # emerge -pv gentoo-love
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum