Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kerneltreiber nvidia G-Force [geloest]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 82
Location: Frankfurt

PostPosted: Sat Sep 07, 2013 9:46 pm    Post subject: Kerneltreiber nvidia G-Force [geloest] Reply with quote

HAllo, ich habe eine Grafikkarte nvidia G-Force 7600 GS und moechte mir den Kernel bauen.
Das make && make modules_install bricht ab mit der Meldung
Code:

make[3]: `arch/x86/realmode/rm/realmode.bin' is up to date.
  LINK    vmlinux
  LD      vmlinux.o
  MODPOST vmlinux.o
  GEN     .version
  CHK     include/generated/compile.h
  UPD     include/generated/compile.h
  CC      init/version.o
  LD      init/built-in.o
  LD      vmlinux
drivers/built-in.o: In function `nouveau_acpi_edid':
(.text+0x15f145): undefined reference to `acpi_video_get_edid'
make: *** [vmlinux] Error 1



Was mache ich falsch?

ps: soll ich den open-source oder den proprietairen Treiber in der make.conf nehmen?

Danke schonmal.


Last edited by Gentoo-kid on Thu Oct 03, 2013 6:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
AmonAmarth
l33t
l33t


Joined: 03 Mar 2005
Posts: 714

PostPosted: Sun Sep 08, 2013 10:46 pm    Post subject: Reply with quote

meine persönliche empfehlung ist den propritären nvidia treiber zu nehmen und das aus dem kernel raus zu lassen (1. weil du damit dein problem umgehst und 2. wegen der 3D performance)
Back to top
View user's profile Send private message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 82
Location: Frankfurt

PostPosted: Tue Sep 10, 2013 5:53 pm    Post subject: Reply with quote

Es scheint, als wuerde nur noch der open spource Treiber unterstuetzt,
Laut internet ist die 7600GS unter den nicht unterstuetzten aufgelistet.
Immerhin funktioniert der, aber ich weiss nicht, ob der gut ist, was 3d anbelangt.
Videos habe ich auch noch nicht testen koennen, weil ich mein system neu aufsetze.
Back to top
View user's profile Send private message
mvaterlaus
Apprentice
Apprentice


Joined: 01 Oct 2010
Posts: 155
Location: Switzerland

PostPosted: Wed Sep 11, 2013 7:16 am    Post subject: Reply with quote

hi,
keine Ahnung, woher du die Info's hast, dass deine GPU nicht vom proprietären Treiber unterstützt wird, aber laut nvidia [1] wird der sehr wohl unterstützt. Deinen Fehler kannst du mit folgender Kernel Einstellung beheben (x86_64):

Code:

-> Power management and ACPI options
    -> ACPI (Advanced Configuration and Power Interface)
       <*> Video


oder folgende Option in der .config des Kernels suchen und auf 'y' setzen
Code:

CONFIG_ACPI_VIDEO=y



[1]http://us.download.nvidia.com/XFree86/Linux-x86_64/319.49/README/supportedchips.html
Back to top
View user's profile Send private message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 82
Location: Frankfurt

PostPosted: Wed Sep 11, 2013 8:24 pm    Post subject: Reply with quote

Diese Kerneleinstellung hatte ich, sie ist in meinem Kernel fest drinn und auch nicht deaktivierbar oder als Modul zu laden.
Code:
-> Power management and ACPI options
    -> ACPI (Advanced Configuration and Power Interface)
       <*> Video

http://www.nvidia.com/object/IO_32667.html
scheint auf eine Liste der nicht mehr unterstuetzten Karten zu weisen, auch meine nvidia G-Force 7600 GS ist gelistet.
emerge nvidia-drivers ergibt am Schluss diese Meldung, wobei die
Code:
Access denied
jeweils mit anderen Nummern /.246....tmp vorkommt.
Code:

............................................
* ACCESS DENIED:  open_wr:      /.24647.tmp
 * ISE:write_logfile: unable to append logfile: /var/log/sandbox/sandbox-23614.log
 * ../../sandbox-2.6/libsandbox/libsandbox.c:check_syscall():879: failure (Bad file descriptor):
 * ISE:
        abs_path: /.24647.tmp
        res_path: /.24647.tmp
 * ACCESS DENIED:  unlinkat:     /.24647.tmp
 * ISE:write_logfile: unable to append logfile: /var/log/sandbox/sandbox-23614.log
 * ../../sandbox-2.6/libsandbox/libsandbox.c:check_syscall():879: failure (Bad file descriptor):
 * ISE:
        abs_path: /.24647.tmp
        res_path: /.24647.tmp
nvidia-drivers-325.15>  * Found kernel object directory:
nvidia-drivers-325.15>  *     /lib/modules/3.10.7-gentoo/build
nvidia-drivers-325.15>  * Found sources for kernel version:
nvidia-drivers-325.15>  *     3.10.7-gentoo

nvidia-drivers-325.15>  * ***** WARNING *****
nvidia-drivers-325.15>  *
nvidia-drivers-325.15>  * You are currently installing a version of nvidia-drivers that is
nvidia-drivers-325.15>  * known not to work with a video card you have installed on your
nvidia-drivers-325.15>  * system. If this is intentional, please ignore this. If it is not
nvidia-drivers-325.15>  * please perform the following steps:
nvidia-drivers-325.15>  *
nvidia-drivers-325.15>  * Add the following mask entry to /etc/portage/package.mask by
nvidia-drivers-325.15>  * echo ">=x11-drivers/nvidia-drivers-305.0.0" >> /etc/portage/package.mask
nvidia-drivers-325.15>  *
nvidia-drivers-325.15>  * Failure to perform the steps above could result in a non-working
nvidia-drivers-325.15>  * X setup.
nvidia-drivers-325.15>  *
nvidia-drivers-325.15>  * For more information please read:
nvidia-drivers-325.15>  * http://www.nvidia.com/object/IO_32667.html
nvidia-drivers-325.15>  * Checking for suitable kernel configuration opt [ ok ]
nvidia-drivers-325.15>
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2288
Location: Germany

PostPosted: Wed Sep 11, 2013 9:20 pm    Post subject: Reply with quote

Gentoo-kid wrote:
http://www.nvidia.com/object/IO_32667.html
scheint auf eine Liste der nicht mehr unterstuetzten Karten zu weisen, auch meine nvidia G-Force 7600 GS ist gelistet.
Hehe nein, das ist die Liste der zu der genanten Treiberversion unterstützten GPU's
Quote:
The 304.xx driver supports the following set of GPUs:
...
GeForce 7600 GS 0x02E1
...


Beachte und nutze auch die Info aus deiner Ausgabe:
Quote:
Code:
nvidia-drivers-325.15>  * You are currently installing a version of nvidia-drivers that is
nvidia-drivers-325.15>  * known not to work with a video card you have installed on your
nvidia-drivers-325.15>  * system. If this is intentional, please ignore this. If it is not
nvidia-drivers-325.15>  * please perform the following steps:
nvidia-drivers-325.15>  *
nvidia-drivers-325.15>  * Add the following mask entry to /etc/portage/package.mask by
nvidia-drivers-325.15>  * echo ">=x11-drivers/nvidia-drivers-305.0.0" >> /etc/portage/package.mask
(Auszug)
Sprich maskiere alle >=nvidia-drivers-305 Versionen, so das stets die aktuelle, für deine 7600 GS Karte kompatible 304.xx Version installiert wird.
Back to top
View user's profile Send private message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 82
Location: Frankfurt

PostPosted: Sat Sep 14, 2013 7:33 pm    Post subject: Reply with quote

Danke, das ging soweit gut, bricht nur waehrend der installation ab:

Code:
checking if x86_64-pc-linux-gnu-gcc -std=gnu99 supports -pedantic... yes
checking if x86_64-pc-linux-gnu-gcc -std=gnu99 supports -Werror... yes
checking if x86_64-pc-linux-gnu-gcc -std=gnu99 supports -Werror=attributes... yes
Package xorg-macros was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-macros.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-macros' found
checking whether malloc(0) returns NULL... yes
checking for XVMC... configure: error: Package requirements (x11 xext xv xextproto videoproto) were not met:

No package 'xv' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XVMC_CFLAGS
and XVMC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Es half auch nicht, xv von Hand zu installieren, (was geklappt hat).
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4218

PostPosted: Sun Sep 15, 2013 8:10 am    Post subject: Reply with quote

xvmc hat nichts mit dem Paket xv zu tun. Es geht vermutlich um USE=xvmc im Paket mesa oder das davon hereingezogene x11-lib/libXvMC.
Back to top
View user's profile Send private message
Gentoo-kid
Tux's lil' helper
Tux's lil' helper


Joined: 14 Oct 2009
Posts: 82
Location: Frankfurt

PostPosted: Thu Oct 03, 2013 6:43 pm    Post subject: Reply with quote

Danke, hat geklappt, sowohl mit open source, als auch mit nvidia-treiber, dazu habe ich halt alles neu installiert, das war einfacher.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum