Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
vmware player stopped working: NOT_IMPLEMENTED in codeset.c
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
wichtounet
n00b
n00b


Joined: 17 Mar 2012
Posts: 70

PostPosted: Mon Apr 29, 2013 12:06 pm    Post subject: vmware player stopped working: NOT_IMPLEMENTED in codeset.c Reply with quote

Hi,

Since this morning, I cannot run vmplayer. The last time I run it, about one week ago, it was working well. I've made several updates since this time.

I've rebuild the kernel too, but I've run module-rebuild build.

Whenever I try to launch it, it outputs this error:

Quote:
NOT_IMPLEMENTED /build/mts/release/bora-1031769/bora/lib/misc/codeset.c:1708
[1] 3542 abort /opt/vmware/bin/vmplayer


Is there a solution to this problem ?

Thanks

Baptiste
Back to top
View user's profile Send private message
wichtounet
n00b
n00b


Joined: 17 Mar 2012
Posts: 70

PostPosted: Tue Apr 30, 2013 5:55 am    Post subject: Reply with quote

I tried to unmerge vmware-player vmware-tools and vmware-modules and then emerge then again, but it didn't change anything :(
Back to top
View user's profile Send private message
wichtounet
n00b
n00b


Joined: 17 Mar 2012
Posts: 70

PostPosted: Tue Apr 30, 2013 8:59 am    Post subject: Reply with quote

If I rename the folder containing the virtual machine, I can launch vmplayer, but I cannot open the virtual machine (the same error occurs).

Does that mean that my virtual machine is corrupted ?

Thanks
Back to top
View user's profile Send private message
wichtounet
n00b
n00b


Joined: 17 Mar 2012
Posts: 70

PostPosted: Tue Apr 30, 2013 1:29 pm    Post subject: Reply with quote

I just tried installing the player from the official bundle, but at the end the error is exactly the same :(
Back to top
View user's profile Send private message
wichtounet
n00b
n00b


Joined: 17 Mar 2012
Posts: 70

PostPosted: Thu May 02, 2013 8:54 am    Post subject: Reply with quote

Uwe on stack overflow (http://superuser.com/questions/589501/vmware-player-does-not-start-not-implemented) found the answer for me :)

It was coming from the last version of dev-libs/icu who seems to be incompatible with vmware.
Back to top
View user's profile Send private message
anton_kg
Tux's lil' helper
Tux's lil' helper


Joined: 10 Feb 2007
Posts: 91
Location: Singapore

PostPosted: Tue May 07, 2013 3:25 am    Post subject: Reply with quote

wichtounet wrote:
Uwe on stack overflow (http://superuser.com/questions/589501/vmware-player-does-not-start-not-implemented) found the answer for me :)

It was coming from the last version of dev-libs/icu who seems to be incompatible with vmware.


Yep, that's right. Here is the bug report:
https://bugs.gentoo.org/show_bug.cgi?id=465126
Back to top
View user's profile Send private message
wichtounet
n00b
n00b


Joined: 17 Mar 2012
Posts: 70

PostPosted: Wed Aug 07, 2013 11:25 am    Post subject: Reply with quote

I ran again on this problem.

I updated my system and didn't saw that icu was to be updated and I let it do it to update to 51.1. After that vmplayer started crashing again. I tried updating to 51.2 but it didn't change a thing.

I know that the workaround is to disable icu in libxml2, but chromium requires libxml2 with icu use flag, so I'm kind of stuck :(

Is there a clean workaround to this problem ?

Thanks
Back to top
View user's profile Send private message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Wed Aug 07, 2013 2:33 pm    Post subject: Reply with quote

when close sauce's rotten there's open sauces out there that do the job.

not trying to be rude but sometimes ppl get mad when they're are told about open source solutions.

/me running qemu {M}(~)1.5.2-r1 flawlessly
Back to top
View user's profile Send private message
wichtounet
n00b
n00b


Joined: 17 Mar 2012
Posts: 70

PostPosted: Thu Aug 08, 2013 7:43 am    Post subject: Reply with quote

Thanks. I didn't know about Qemu.

I just tried installing KVM, but my kernel with KVM enabled gives me a black screen once gdm starts :(

I would love to get rid of Vmware :) In the past, I've already tried to use Virtualbox, but without success on this particular virtual machine. I can't make the virtual machine by hand because it is distributed by my company with specific software on it for which I don't have the installation files. I will try again to run this virtual machine on virtual box, that would still be better than Vmware.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9849
Location: Córdoba (Spain)

PostPosted: Wed Sep 04, 2013 6:39 am    Post subject: Reply with quote

So, at the current state of things (only icu-51.x in the tree), you simply can't run vmware in Gentoo, can you? :?
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
wichtounet
n00b
n00b


Joined: 17 Mar 2012
Posts: 70

PostPosted: Wed Sep 04, 2013 6:51 am    Post subject: Reply with quote

If you have libxml2 with icu support, for instance because of chromium, that's right you can't.

According to some people, chromium may work without icu, but I don't like bypassing its dependencies very much.

The solution presented by Jason A. Donenfeld in the bug report works, but it is quite ugly, but still better than nothing.
Back to top
View user's profile Send private message
jwoelper
n00b
n00b


Joined: 10 Sep 2013
Posts: 1

PostPosted: Tue Sep 10, 2013 3:25 pm    Post subject: vmware Reply with quote

Got it to work using icu-51.1 and the "new" product vmware player plus 6 from the vmware web site. Manually installed it using
Code:
bash VMware-Player-6.0.0-1295980.x86_64.txt --console --ignore-errors
. Unfortunately, i do need Vmware, and it really keeps troubling me every time.
Back to top
View user's profile Send private message
grotti
n00b
n00b


Joined: 03 Oct 2013
Posts: 1

PostPosted: Thu Oct 03, 2013 6:16 am    Post subject: Reply with quote

Hi,.

LD_PRELOAD=/opt/vmware/lib/vmware/lib/libxml2.so.2/libxml2.so.2 vmplayer works for me, with app-emulation/vmware-player-5.0.2.1031769

Br,
Grotti
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum