Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Microdia Sonix webcam problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
paramnesioid
n00b
n00b


Joined: 31 Aug 2013
Posts: 5

PostPosted: Mon Sep 09, 2013 12:38 pm    Post subject: [SOLVED] Microdia Sonix webcam problem Reply with quote

Hey, can someone please help me figure out what I should do?

I've got an inbuilt camera on my Dell Vostro 1320,

(lsusb)
Bus 002 Device 002: ID 0c45:63e0 Microdia Sonix Integrated Webcam

I've added the uvc and gspca, the linux firmware on portage, and whatever I can see that remotely looks like it could work apart from some deprecated v4l stuff and I still don't get /dev/video

does it change anything if I only add them as modules?


here's the atrocious config I've created:

http://bpaste.net/show/130786/


thanks.


Last edited by paramnesioid on Tue Sep 10, 2013 2:48 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31711
Location: 56N 3W

PostPosted: Mon Sep 09, 2013 1:55 pm    Post subject: Reply with quote

paramnesioid,

Welcome to Gentoo.

You seem to be on the right track. What makes you think your webcam needs firmware?
With linux-firmare installed and the drivers made as kernel built ins, the firmware will not load.
This would give you error messages in dmesg.

Google suggests that at least one kernel version has a problem with your webcam and the workaround is to remove the module then reload it.
Of course, you need to make the UVC driver as a module to be able to do this.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
paramnesioid
n00b
n00b


Joined: 31 Aug 2013
Posts: 5

PostPosted: Tue Sep 10, 2013 2:48 am    Post subject: Reply with quote

thanks NeddySeagoon!

I made everything webcam-related into modules and disabled anything V4L I added and it worked.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum