Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't get vmware tools to work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
slicedtoad
n00b
n00b


Joined: 06 Sep 2013
Posts: 3

PostPosted: Sat Sep 07, 2013 3:02 pm    Post subject: Can't get vmware tools to work Reply with quote

I've installed Gentoo on VMware with gnome and am trying to get vmware tools to work.

I was able to install the tools from the "cd" that is "inserted" via VM->'Install VMware Tools' but starting it gave an error saying /proc/fs/vmblock/dev can't be opened.

I couldn't find a fix so I uninstalled and tried the open version.
emerge app-emulation/open-vm-tools fails with the following:
Code:
* Messages for package sys-apps/util-linux-2.22.2:

 * The agetty util now clears the terminal by default.  You
 * might want to add --noclear to your /etc/inittab lines.

 * Messages for package app-emulation/open-vm-tools-kmod-2013.04.16.1098359:

 *   CONFIG_DRM_VMWGFX:    is not set when it should be.
 *   CONFIG_VMWARE_BALLOON:    is not set when it should be.
 *   CONFIG_VMWARE_PVSCSI:    is not set when it should be.
 *   CONFIG_VMXNET3:    is not set when it should be.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.
 * ERROR: app-emulation/open-vm-tools-kmod-2013.04.16.1098359 failed (compile phase):
 *   emake failed


Can someone help me out here? Let me know if you need more log/config files.

just in case here are some files:
/etc/portage/make.conf
open-vm-tools buildlog
emerge --info
Back to top
View user's profile Send private message
fturco
Apprentice
Apprentice


Joined: 08 Dec 2010
Posts: 289
Location: Italy

PostPosted: Sun Sep 08, 2013 10:38 am    Post subject: Reply with quote

It seems you should enable the specified modules in the kernel and re-emerge open-vm-tools-kmod.
Back to top
View user's profile Send private message
sk3l
n00b
n00b


Joined: 14 Jul 2012
Posts: 70
Location: CT USA

PostPosted: Sun Sep 08, 2013 11:18 am    Post subject: Reply with quote

I have another box that runs Kubuntu inside VMWare. When installing vmware-tools, I kept getting errors in the compilation phase for the vhgfs support. It turned out that vmware tools doesn't well support linux kernel 3.8.x, so I had to patch a few files in the vmware-tools source, and then everything built and worked. Perhaps this is not related to your troubles, but I thought I'd chime in nonetheless.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum