Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Grub does not recognize vga mode
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Zagloj
Guru
Guru


Joined: 17 Jun 2005
Posts: 314

PostPosted: Fri Sep 06, 2013 12:30 pm    Post subject: Grub does not recognize vga mode Reply with quote

Hi, I changed recently the vga mode on my grub and I used vga=ask to choose a vga mode, then I wrote it to grub.conf like this:

Code:
title Gentoo
root (hd0,2)
kernel /boot/kernel-genkernel-x86_64-3.6.11-gentoo root=/dev/ram0 real_root=/dev/sda6 vga=361 video=vesafb:mtrr:3,ywrapp rootfstype=ext4
initrd /boot/initramfs-genkernel-x86_64-3.6.11-gentoo


Before using vga=ask it worked without problems, but now it says that it does not recognize that vga mode, for example: 169, not the vga mode I wrote to the conf file, and even before that I see the kernel line in my screen and the mode is clearly correct, then it prompts me for a vga valid mode, I write 361 and it works ok, what might be wrong?

Thanks in advance for your time.

Just in case it is of use my grub version is 0.97-r12
_________________
Your ideology seems to be: "I hate the fanatics, we shoud kill them all" juantxorena dixit.
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4733
Location: Saint Amant, Acadiana

PostPosted: Sat Sep 07, 2013 1:57 am    Post subject: Reply with quote

I have to admit I have hard time understanding your problem. Anyway, GRUB is a bootloader, the vga parameter is passed to the kernel. Whatever problems you are experiencing is not a GRUB problem, it is about your kernel and hardware.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Goverp
Guru
Guru


Joined: 07 Mar 2007
Posts: 353

PostPosted: Sat Sep 07, 2013 7:53 am    Post subject: Reply with quote

Looks like you have two grub.conf files - the one you're editing, and the one it's using. Perhaps you have a /boot partition and you sometimes forget to mount it before editing grub.conf?
_________________
Greybeard
Back to top
View user's profile Send private message
Zagloj
Guru
Guru


Joined: 17 Jun 2005
Posts: 314

PostPosted: Sat Sep 07, 2013 8:07 am    Post subject: Reply with quote

Hi, thanks for the answers, the /boot partition is always mounted, there is no problem with that, even when I choose to boot Gentoo on grub, before that error, it prints among other things, the kernel line, and that line is correct with the vga mode and all the options fine.

Then, it says, bad vga mode 169, choose one, I press enter and it gives me a list.

This is the complete conf file, my kernel is compiled with genkernel:
Code:
# This is a sample grub.conf for use with Genkernel, per the Gentoo handbook
# http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=10#doc_chap2
# If you are not using Genkernel and you need help creating this file, you
# should consult the handbook. Alternatively, consult the grub.conf.sample that
# is included with the Grub documentation.

default 0
timeout 30
#splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Gentoo
root (hd0,2)
kernel /boot/kernel-genkernel-x86_64-3.6.11-gentoo root=/dev/ram0 real_root=/dev/sda6 vga=361 video=vesafb:mtrr:3,ywrapp rootfstype=ext4
initrd /boot/initramfs-genkernel-x86_64-3.6.11-gentoo

title Windows
rootnoverify (hd0,0)
makeactive
chainloader +1

# vim:ft=conf:


Is there anything in the kernel which can be causing this problem? I thought it is a problem with grub because I saw a problem with one option in my grub.conf file.

Thanks for your time.
_________________
Your ideology seems to be: "I hate the fanatics, we shoud kill them all" juantxorena dixit.
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1510
Location: St. Wendel

PostPosted: Sat Sep 07, 2013 10:47 am    Post subject: Reply with quote

Use of vga= is deprecated, use video instead. Also it should be 761 not 361.

Bye
Py
Back to top
View user's profile Send private message
Zagloj
Guru
Guru


Joined: 17 Jun 2005
Posts: 314

PostPosted: Sat Sep 07, 2013 11:06 am    Post subject: Reply with quote

Ok, I try and I see in next reboot, by the way, 361 works ok at this moment, but I will try 761 (I was changing this recently cause I changed the monitor and I have 1920x1080 resolution in X). Before I tried vga=ask it worked fine with vga parameter.

Reporting soon thanks for the help :)


NEWS:

Changed the kernel line to:
Code:
kernel /boot/kernel-genkernel-x86_64-3.6.11-gentoo root=/dev/ram0 real_root=/dev/sda6 video=uvesafb:mtrr:3,ywrapp,1280x800-24 rootfstype=ext4


Using uvesafb now, I choose that resolution cause it is the highest supported as hwinfo --framebuffer reports, but I feel that the resolucion is lower than that. At least it does not ask for a correct mode anymore :D
_________________
Your ideology seems to be: "I hate the fanatics, we shoud kill them all" juantxorena dixit.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum