Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Realtek ALC887 + Nvidia HDMI = sound in HDMI, no other sound
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Tatsh
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2007
Posts: 102

PostPosted: Fri Sep 06, 2013 2:58 am    Post subject: Realtek ALC887 + Nvidia HDMI = sound in HDMI, no other sound Reply with quote

I cannot get a single headphone jack to work with my motherboard, ASUS M5A97. In it I have a GeForce GTX 560 Ti which seems to take over audio.

aplay -l:
Code:

**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ID 887 Analog [ID 887 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ID 887 Digital [ID 887 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


I have modules built for ALSA, rather than things being built-in. lsmod:
Code:

Module                  Size  Used by
it87                   27230  0
hwmon_vid               3076  1 it87
gspca_kinect            3863  0
gspca_main             23113  1 gspca_kinect
vboxnetadp             17606  0
vboxnetflt             15858  0
vboxdrv              1805789  2 vboxnetadp,vboxnetflt
snd_hda_codec_hdmi     28273  4
nvidia               9316868  53
snd_hda_intel          25944  4
snd_hda_codec         119360  2 snd_hda_codec_hdmi,snd_hda_intel
k10temp                 2866  0
hwmon                   1241  2 it87,k10temp
i2c_piix4               8239  0


Also I have a slightly modified /etc/modprobe.d/alsa.conf:

Code:

# Alsa kernel modules' configuration file.

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=2

options snd_hda_intel model=generic


Last line is the added line.

Does anyone have this combination and have audio working through the card itself (and not going through HDMI)? Any suggestions on things to try?
Back to top
View user's profile Send private message
aim nano
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2006
Posts: 120
Location: Jackson, MS

PostPosted: Tue Sep 10, 2013 1:18 am    Post subject: Reply with quote

not sure about the realtek, but the nvidia hdmi is supported via the intel hda audio, so if you remove that you won't be getting sound from hdmi and can go from there.

edit:

actually the realtek seemingly uses the same kernel driver, so i found this on the debian forums:

Quote:
The problem was that I needed to blacklist the snd-hda-codec-hdmi module. After adding the line:
blacklist snd-hda-codec-hdmi
to my /etc/modprobe.d/alsa-base-blacklist.conf and rebooting, all I had to do was go into alsamixer and adjust the settings there.
Hope this helps.


not sure if applicable, but blacklisting the snd-hda-codec-hdmi seemed to work for this guy, and i think for gentoo kernel modules you'd want to blacklist in:
/etc/modprobe.d/blacklist.conf
_________________
Unanswered posts need love too.
--
~ # emerge -pv gentoo-love
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum