Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xfce:suspend and poweroff menu botton are disabled
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 79
Location: Torino

PostPosted: Mon Sep 02, 2013 10:12 pm    Post subject: Xfce:suspend and poweroff menu botton are disabled Reply with quote

Hi all, I have a very strange problem with my system, I use Xfce DE. The button "shutdown" and "sleep" are gray. How can I fix this situation?

i try this solution but not work for me:
http://forum.xfce.org/viewtopic.php?pid=21807#p21807

also not allowed to mount disks (usb pen drive) or partitions of my system, I can only do this by logging in as root!!
how can i resolve this?
Back to top
View user's profile Send private message
BradN
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2382
Location: Wisconsin (USA)

PostPosted: Tue Sep 03, 2013 9:09 pm    Post subject: Reply with quote

I believe in general the desktop environment either has to talk to the display manager (login screen) *or* to lower level libraries (udev/hal, etc) to initiate those actions.

Maybe there is a use flag turned off that enables that?
Back to top
View user's profile Send private message
alex_im_netz
n00b
n00b


Joined: 01 Jan 2008
Posts: 4

PostPosted: Wed Sep 04, 2013 6:50 am    Post subject: Reply with quote

I found this solution: https://bugs.gentoo.org/show_bug.cgi?id=479660 (downgrade to <=x11-misc/lightdm-1.7.4)

Before that I tried this without success: http://forums.gentoo.org/viewtopic-t-858965-highlight-tips+consolekit+policykit.html.

Good luck ;)
Back to top
View user's profile Send private message
chaseguard
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2004
Posts: 136

PostPosted: Mon Sep 16, 2013 3:10 am    Post subject: Reply with quote

I too had the same problem and could never seem to find a fix in the forums or elsewhere. Finally, I stumbled on this somewhere.

Put the line below in your SUDO file -- it fixed the issue for me:



%users ALL = (root) NOPASSWD: /usr/lib/xfce4/session/xfsm-shutdown-helper


By the way, use visudo to edit the file!!! (No SUDO? emerge sudo).


Rgds,
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum