Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Intel Fortran Compiler 11 64bit
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
natrix
Apprentice
Apprentice


Joined: 23 Aug 2013
Posts: 285

PostPosted: Tue Aug 27, 2013 6:25 pm    Post subject: Intel Fortran Compiler 11 64bit Reply with quote

Hello Gentoo community!!

My problem is this, I want to install Intel Fortran Compiler 11 64bit and when I install it tells me that there is no support for 32bit. With Ubuntu I had the same problem but I found the following solution.

http://hawknotes.blogspot.com.ar/2010/05/ubuntu-1004-installing-64-bit-intel.html
http://ubuntuforums.org/showthread.php?t=1082782

where you had to make a link to libstdc + +. so.5.0.7 in /lib32.

I wanted to do the same in Gentoo (multilib) but I can´t.
Anyone know how to fix it or had the same problem?

Thank you very much
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4971

PostPosted: Tue Aug 27, 2013 8:51 pm    Post subject: Reply with quote

does this helps?
http://software.intel.com/en-us/forums/topic/269236
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
natrix
Apprentice
Apprentice


Joined: 23 Aug 2013
Posts: 285

PostPosted: Tue Aug 27, 2013 10:30 pm    Post subject: Reply with quote

Yes, I tried those steps too. This is the screen:

Code:

32-bit libraries not found on this system.
This product release requires the presence of 32-bit compatibility libraries
when running on Intel(R) 64 architecture systems. One or more of these libraries
could not be found:
    libstdc++
    libstdc++5
    glibc
    libgcc
Without these libraries, the compiler will not function properly. These
libraries,



thanks
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4971

PostPosted: Wed Aug 28, 2013 7:36 am    Post subject: Reply with quote

do you have emul-linux-x86-baselibs installed?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
natrix
Apprentice
Apprentice


Joined: 23 Aug 2013
Posts: 285

PostPosted: Thu Aug 29, 2013 1:54 am    Post subject: Reply with quote

Yes, I installed:

emul-linux-x86-baselibs
emul-linux-x86-glibc-errno-compat
lib-compat
libstdc++-v3
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4971

PostPosted: Thu Aug 29, 2013 6:06 am    Post subject: Reply with quote

natrix wrote:
Yes, I installed:

emul-linux-x86-baselibs
emul-linux-x86-glibc-errno-compat
lib-compat
libstdc++-v3


check if the above files exists, if so, try running the compiler with strace to see where exactly the compiler is searching for the files and create sym links accordingly.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum