Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Mate and Slot Conflict
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
OldTango
Guru
Guru


Joined: 21 Feb 2004
Posts: 496

PostPosted: Mon Aug 26, 2013 10:58 pm    Post subject: [SOLVED] Mate and Slot Conflict Reply with quote

Thought I would install Mate and give it a go but when attempting to install I get a slot conflict I can't seem to sort out
Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.36.4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.35.2:2 required by (gnome-base/dconf-0.16.1::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (dev-libs/glib-2.32.4-r1::gentoo, installed) pulled in by
    <dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)


When trying to update glib I get this
Code:
ACCEPT_KEYWORDS="~amd64" emerge -avu =dev-libs/glib-2.36.4

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/glib-2.36.4:2 [2.32.4-r1:2] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7%* (-python2_5) -python2_6%" 0 kB
[blocks B      ] <dev-libs/gobject-introspection-1.36 ("<dev-libs/gobject-introspection-1.36" is blocking dev-libs/glib-2.36.4)

Total: 1 package (1 upgrade), Size of downloads: 0 kB
Conflict: 1 block (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.36.4::gentoo, ebuild scheduled for merge) pulled in by
    =dev-libs/glib-2.36.4

  (dev-libs/glib-2.32.4-r1::gentoo, installed) pulled in by
    <dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)


Anyone have any ideas on how I can solve the problem?

TIA


Last edited by OldTango on Sat Dec 14, 2013 8:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5625

PostPosted: Tue Aug 27, 2013 10:58 am    Post subject: Reply with quote

Well, the solution seems obvious: keyword (and emerge) >=dev-libs/gobject-introspection-1.36.0.
Back to top
View user's profile Send private message
OldTango
Guru
Guru


Joined: 21 Feb 2004
Posts: 496

PostPosted: Tue Aug 27, 2013 2:49 pm    Post subject: Reply with quote

VoidMage wrote:
Well, the solution seems obvious: keyword (and emerge) >=dev-libs/gobject-introspection-1.36.0.

Thank you for your input, I thought so as well but as it turns out the problem seems to get bigger and bigger.

Unmasking dev-libs/glib-2.36.4 and dev-libs/gobject-introspection-1.36.0 then updating causes more issues
Code:

emerge -avu =dev-libs/gobject-introspection-1.36.0

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] dev-libs/gobject-introspection-common-1.36.0 [1.32.1] 0 kB
[ebuild     U ~] dev-libs/glib-2.36.4:2 [2.32.4-r1:2] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7%* (-python2_5) -python2_6%" 0 kB
[ebuild     U ~] dev-libs/gobject-introspection-1.36.0 [1.32.1] USE="cairo%* -doctool {-test} (-doc%)" PYTHON_SINGLE_TARGET="python2_7%*" PYTHON_TARGETS="python2_7%*" 0 kB
[blocks b      ] <dev-libs/gobject-introspection-1.36 ("<dev-libs/gobject-introspection-1.36" is blocking dev-libs/glib-2.36.4)
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0)

Total: 3 packages (3 upgrades), Size of downloads: 0 kB
Conflict: 2 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/vala-0.14.2-r2::gentoo, installed) pulled in by
    dev-lang/vala:0.14[vapigen] required by (net-libs/gssdp-0.12.2.1::gentoo, installed)

  (dev-libs/gobject-introspection-1.36.0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gst-plugins-base-1.0.5-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6 required by (app-text/evince-2.32.0-r4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:= required by (gnome-base/gconf-2.32.4-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-gnome-2.38.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.4 required by (net-libs/gupnp-0.18.4::gentoo, installed)
    =dev-libs/gobject-introspection-1.36.0
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.20-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    dev-libs/gobject-introspection required by (dev-libs/keybinder-0.3.0-r200::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.4.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (net-libs/gssdp-0.12.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10 required by (net-libs/gupnp-igd-0.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.110::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.17::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.26.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.11 required by (net-libs/farstream-0.1.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.28.2-r204::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.22.2-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:0/0= required by (gnome-base/gconf-2.32.4-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.38.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.6.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.36.4::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gstreamer-1.0.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (gnome-extra/gucharmap-3.6.1::gentoo, installed)

I managed to work around many of these problems and blockers yesterday and emerged mate only to hit a brick wall on the last four required packages.

x11-libs/gdk-pixbuf introspection
x11-libs/gtk+ introspection
mate-base/mate-menu-editor
mate-base/mate

After updating dev-libs/gobject-introspection than x11-libs/gdk-pixbuf with the introspection USE FLAG required by the mate ebuild breaks with a variation of the BUG # 463884 and can't be installed causing emerge to refuse to continue due to unsatisfied dependencies.

Code:

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by x11-libs/gtk+-2.24.17
# required by x11-misc/mate-menu-editor-1.6.0::mate-overlay
# required by mate-base/mate-1.6.0::mate-overlay
# required by mate (argument)
=x11-libs/gdk-pixbuf-2.26.4 introspection  <---- Updating gobject-introspection breaks pixbuf with BUG# 463844
# required by x11-misc/mate-menu-editor-1.6.0::mate-overlay
# required by mate-base/mate-1.6.0::mate-overlay
# required by mate (argument)
>=mate-base/mate-menus-1.6.0 introspection
# required by x11-libs/gtk+-2.24.17
# required by x11-misc/mate-menu-editor-1.6.0::mate-overlay
# required by mate-base/mate-1.6.0::mate-overlay
# required by mate (argument)
=x11-libs/pango-1.30.1 introspection
# required by x11-misc/mate-menu-editor-1.6.0::mate-overlay
# required by mate-base/mate-1.6.0::mate-overlay
# required by mate (argument)
=x11-libs/gtk+-2.24.17 introspection
# required by x11-libs/gtk+-2.24.17
# required by x11-misc/mate-menu-editor-1.6.0::mate-overlay
# required by mate-base/mate-1.6.0::mate-overlay
# required by mate (argument)
=dev-libs/atk-2.6.0 introspection


While I will continue to work on these problems and hopefully sort it all out, I was hoping somebody with a lot more knowledge than me with portage, ebuilds and dependencies could point me in the right direction.

TIA..... :)
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Tue Aug 27, 2013 3:33 pm    Post subject: Reply with quote

Always resolve blockers prior to resolving slot conflicts.

Quote:
[blocks B ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0)


Accept keywords for >=dev-lang/vala-0.20.0 and unmask it, then try again.
Back to top
View user's profile Send private message
OldTango
Guru
Guru


Joined: 21 Feb 2004
Posts: 496

PostPosted: Tue Aug 27, 2013 4:55 pm    Post subject: Reply with quote

TomWij wrote:
Always resolve blockers prior to resolving slot conflicts.

Quote:
[blocks B ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0)


Accept keywords for >=dev-lang/vala-0.20.0 and unmask it, then try again.

Thanks I actually sorted it out and have MATE installed though I haven't started it up just yet.

STEP 1.
It seems a lot of packages have the USE FLAG introspection set by default and because I couldn't build x11-libs/gdk-pixbuf with the newer gobject-introspection I added -introspection to my make.conf and added =x11-libs/gdk-pixbuf-2.26.4 introspection, >=mate-base/mate-menus-1.6.0 introspection, =x11-libs/pango-1.30.1 introspection, =x11-libs/gtk+-2.24.17 introspection, =dev-libs/atk-2.6.0 introspection to /etc/portage/package.use and ran an NewUse update using the older version of gobject-introspection first to satisfy the mate ebuilds.

Not sure this was this wisest of choices, however I will attempt to revert back to the default introspection USE setup.

STEP 2.
Next I added =dev-lang/vala-0.20.1 and =dev-libs/vala-common-0.20.1(required by vala-0.20.1 to /etc/portage/package.keywords and updated vala. This process auto uninstalled the older version of vala already installed.

STEP 3.
Next I added =dev-libs/gobject-introspection-1.36.0, =dev-libs/gobject-introspection-common-1.36.0(required by gobject-introspection) and =dev-libs/glib-2.36.4 to /etc/portage/package.keywords and updated gobject-introspection which also updated gobject-introspection-common and glib.

STEP 4.
Install MATE from the layman overlay. Which finally completed without errors.

STEP 5. To Do Yet
Revert back to the default introspection USE setup and check for system breakage.

I installed Xfce about a year ago knowing Gnome2 was dead. I tried Gnome3 and its different flavors both installing it on one of my Gentoo machines and several other distros in VirtualBox. No matter how hard I tried I just can't stand it and I have been a Gnome user since the Mandrake 6 days. Xfce is great but I have had to install a lot of gnome2 apps to get the complete system I like and when Gnome3 goes stable Gentoo will drop Gnome2, as it should be and I will loose most of my Xfce unless I want to maintain my own ebuilds which I don't. I think MATE will a viable fully functioning alternative DE.

Thanks All..... :D
Back to top
View user's profile Send private message
OldTango
Guru
Guru


Joined: 21 Feb 2004
Posts: 496

PostPosted: Tue Aug 27, 2013 10:44 pm    Post subject: Reply with quote

Completing STEP 5.
Removing -introspection from my make.conf and running a world update caused a vala blocker immediately and I had to unmask =net-libs/gssdp-0.14.3 to get around that. Than librsvg failed in reference to gdk-pixbuf-2.26.4 which failed again. Unmasking =x11-libs/gdk-pixbuf-2.26.5 finally sorted it all out.

Couldn't start MATE from the console (I don't use a login manager, never have) and had to create a ~. xinitrc file with
Code:
"exec ck-launch-session mate-session"
in it before MATE would start up.

Thanks All..... :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum