Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] mesa-9.1.6 mit r600-llvm-compiler
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1062
Location: Schweiz

PostPosted: Sun Aug 25, 2013 3:41 pm    Post subject: [solved] mesa-9.1.6 mit r600-llvm-compiler Reply with quote

Beim Versuch mesa-9.1.6 mit dem USE-Flag "r600-llvm-compiler" zu bauen kommen immer zwei Fehlermeldung die ich zwar beide verstehe aber die zweite nicht nachvollziehen kann.
Code:
checking for nm... /usr/bin/nm -B
checking for XVMC... yes
Package libclc was not found in the pkg-config search path.
Perhaps you should add the directory containing `libclc.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libclc' found
Package libclc was not found in the pkg-config search path.
Perhaps you should add the directory containing `libclc.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libclc' found
checking for XCB_DRI2... yes
checking for llvm-config... /usr/bin/llvm-config
checking for RADEON... yes
checking for RADEON... yes
checking for LIBUDEV... yes
configure: error: LLVM 3.2 with R600 target enabled is required.
                     To use the r600/radeonsi LLVM backend, you need to fetch the LLVM source from:
                     git://people.freedesktop.org/~tstellar/llvm master
                     and build with --enable-experimental-targets=R600

Bei der ersten scheint mesa nicht sonderlich glücklich darüber zu sein das "dev-libs/libclc" nicht installiert ist, aber bei der zweiten liegt mesa komplett daneben denn llvm ist mit r600 Support installiert.
Code:
# qlist -IUv llvm
sys-devel/llvm-3.3-r1 (abi_x86_32 abi_x86_64 clang gold libffi ocaml python_targets_python2_7 udis86 video_cards_radeon)

Einer ne Idee wie ich mesa mit diesem USE-Flag gebaut bekomme?
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)


Last edited by schmidicom on Tue Aug 27, 2013 5:49 am; edited 1 time in total
Back to top
View user's profile Send private message
SilverPenguin
n00b
n00b


Joined: 11 Sep 2012
Posts: 8

PostPosted: Mon Aug 26, 2013 5:43 pm    Post subject: Reply with quote

Mesa 9.1 verlangt explizit llvm 3.2!
Die änderungen in llvm 3.3 würden Mesa mit diesem USE-Flag nicht kompiliert bekommen.
Du musst im package.unmask Mesa 9.2 freischalten oder du kompilierst llvm 3.2 selbst mit aktiviertem r600 backend(das offizielle ebuild unterstützt nicht das r600 backend in 3.2)
_________________
Sorry for my Bad English :?

Intel Core i5 3570
8 GB DDR3 RAM
AMD Radeon HD 7970 (Mesa 9.3-devel TAHITI)
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1062
Location: Schweiz

PostPosted: Tue Aug 27, 2013 5:48 am    Post subject: Reply with quote

SilverPenguin wrote:
Mesa 9.1 verlangt explizit llvm 3.2!
Die änderungen in llvm 3.3 würden Mesa mit diesem USE-Flag nicht kompiliert bekommen.
Du musst im package.unmask Mesa 9.2 freischalten oder du kompilierst llvm 3.2 selbst mit aktiviertem r600 backend(das offizielle ebuild unterstützt nicht das r600 backend in 3.2)

Sowas habe ich schon fast befürchtet, trotzdem Danke.
Da aber mesa 9.2 offiziell noch nicht als fertig gilt ist es wohl besser noch ein bisschen zu warten, lange wird es wohl nicht mehr dauern.
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3982
Location: Irgendwo im Nirgendwo

PostPosted: Tue Aug 27, 2013 8:12 am    Post subject: Reply with quote

Ich hatte noch zu kde-Zeiten auf mesa-9999 umgestellt (Lanczos-FIlter in kwin buggy/unperformant mit intel-Treiber) und irgendwie war ich zu faul das wieder in stabile Bahnen zu leiten. Alle 1-2 Wochen wird aktualisiert und bisher hatte ich nie Probleme. Ich gehe daher davon aus, dass der rc2 stabil laufen wird :) Solltest dann aber auch das neueste kernel-release nehmen (aktuell 3.10.9).
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1062
Location: Schweiz

PostPosted: Tue Aug 27, 2013 8:42 am    Post subject: Reply with quote

mesa-9999 ist mir dann doch eine spur zu experimentell, vor allem bei meinen Versuchen mit Steam (so weit wie möglich) von Windows zu Linux umzuziehen. :wink:
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum