Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201308-04 ] Puppet: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1539

PostPosted: Fri Aug 23, 2013 6:26 pm    Post subject: [ GLSA 201308-04 ] Puppet: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Puppet: Multiple vulnerabilities (GLSA 201308-04)
Severity: high
Exploitable: remote
Date: August 23, 2013
Bug(s): #456002, #461656, #473720, #481186
ID: 201308-04

Synopsis

Multiple vulnerabilities have been found in Puppet, the worst of
which could lead to execution of arbitrary code.


Background

Puppet is a system configuration management tool written in Ruby.

Affected Packages

Package: app-admin/puppet
Vulnerable: < 2.7.23
Unaffected: >= 2.7.23
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in Puppet. Please review
the CVE identifiers referenced below for details.


Impact

A remote attacker could possibly execute arbitrary code with the
privileges of the process, cause a Denial of Service condition, obtain
sensitive information, or bypass security restrictions.


Workaround

There is no known workaround at this time.

Resolution

All Puppet users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-admin/puppet-2.7.23"
   


References

CVE-2012-6120
CVE-2013-1640
CVE-2013-1652
CVE-2013-1653
CVE-2013-1654
CVE-2013-1655
CVE-2013-2274
CVE-2013-2275
CVE-2013-3567
CVE-2013-4761
CVE-2013-4956


Last edited by GLSA on Mon Aug 26, 2013 4:31 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum