Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
screen goes black on boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
imesg
Apprentice
Apprentice


Joined: 12 Jul 2002
Posts: 252

PostPosted: Fri Aug 16, 2013 2:05 pm    Post subject: screen goes black on boot Reply with quote

During boot, screen brightness goes to zero. However I can adjust the brightness with the screen brightness keys and things are normal after that. However I would like to boot with the screen brightness of the previous session. This setting should be persistent.

Does anyone know were a setting might be to set screen brightness for bootup?

Thanks,

Gene
Back to top
View user's profile Send private message
clintonbailey
n00b
n00b


Joined: 16 Jul 2013
Posts: 1

PostPosted: Fri Aug 16, 2013 3:01 pm    Post subject: Reply with quote

what do you mean during boot? is it during boot or after boot?

Hidden spamlink removed and user banned. Spam and SEO is not welcome here. -- Admin
(Apologies to imesg. This newly-registered user wasn't sincere was just posting to try to slide a link in. If you'd like, this post and your reply can be moved away so that your thread again appears on the unanswered posts page. Use the report button if you would like this done.)


Last edited by clintonbailey on Sun Aug 18, 2013 3:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
imesg
Apprentice
Apprentice


Joined: 12 Jul 2002
Posts: 252

PostPosted: Fri Aug 16, 2013 9:56 pm    Post subject: Reply with quote

clintonbailey wrote:
what do you mean during boot? is it during boot or after boot?


I have a lenovo. So right after I power on the lenovo splash screen appears for a few seconds and then the screen goes dark. It boots in about 1 second or so. I can press the screen brightness key about 10 times and the screen brightens and I can then see the login prompt and continue normally.

I never see any of the boot messages.

Thanks,

Gene
Back to top
View user's profile Send private message
windz
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2006
Posts: 88

PostPosted: Tue Aug 20, 2013 1:54 pm    Post subject: Reply with quote

imesg wrote:
clintonbailey wrote:
what do you mean during boot? is it during boot or after boot?


I have a lenovo. So right after I power on the lenovo splash screen appears for a few seconds and then the screen goes dark. It boots in about 1 second or so. I can press the screen brightness key about 10 times and the screen brightens and I can then see the login prompt and continue normally.

I never see any of the boot messages.

Thanks,

Gene


I have a Lenovo G400s. Running Windows 8, Ubuntu 12.04 and Gentoo on UEFI with rEFind as bootloader. I also have a problem with the screen going dark after booting up Gentoo on rEFind. My temporary solution is to create a file called "backlight.start" (Remember to chmod +x the file) in" /etc/local.d" The content of the file is as follows:

Code:
#!/bin/sh

echo 60 >> /sys/class/backlight/acpi_video0/brightness


This will cause the backlight to be set at 60 when I see the login prompt. You may have to check your system first to see if setting value in /sys/class/backlight/acpi_video0/brightness will actually change the brightness or not. For some people it might be /sys/class/backlight/acpi_video1 or /sys/class/backlight/intel_backlight.

This is just temporary fix, I guess. I'm trying to find out why this problem doesn't occur when booting up Ubuntu on the same laptop but am having no luck at the moment.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum