Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
G15 keyboard Fail [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
twobit
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2011
Posts: 76

PostPosted: Thu Aug 15, 2013 4:51 am    Post subject: G15 keyboard Fail [SOLVED] Reply with quote

ok so i did this whole walkthrough http://wiki.gentoo.org/wiki/Logitech_G15

simple enough, and i get * ERROR: g15daemon failed to start
when starting the daemon... not alot of other info. is this Wiki outdated?
I feel like there is something that has been updated that i may need to change to make this work...

??


Last edited by twobit on Fri Aug 16, 2013 11:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
marco.difresco
n00b
n00b


Joined: 29 Jul 2011
Posts: 56

PostPosted: Fri Aug 16, 2013 2:37 pm    Post subject: Reply with quote

I have the same problem.

I tried to create a script with the following:
Quote:

#!/bin/bash
g15daemon -d

and put it in /etc/local.d/ as g15daemon.start and technically it works as substitute, but for some strange reason it conflict with accessing the virtual terminals (CTRL+ALT+F1 to CTRL+ALT+F6) that occasionally use (to the OP: if you don't use virtual terminals, this may be a good interim workaround - it would automatically work from the next reboot, so for a running session you should call 'g15daemon -d' manually).

Therefore I am looking forward to make /etc/init.d/g15daemon working normally.

Thank in advance.
_________________
Marco Di Fresco
Silicon Gadget
Back to top
View user's profile Send private message
marco.difresco
n00b
n00b


Joined: 29 Jul 2011
Posts: 56

PostPosted: Fri Aug 16, 2013 2:45 pm    Post subject: Reply with quote

Ok, now this was quick. I made it works :P

In /etc/conf.d/g15daemon I changed both options to yes and in /etc/g15daemon.conf I changed ShowDate to yes (contrary to what is shown in the wiki, on my system it was set to Off as default).
_________________
Marco Di Fresco
Silicon Gadget
Back to top
View user's profile Send private message
twobit
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2011
Posts: 76

PostPosted: Fri Aug 16, 2013 11:03 pm    Post subject: Reply with quote

Nice ... for some reason changing my options to "yes" fixed it! Nice.. weird that that alone would make it not function
Back to top
View user's profile Send private message
marco.difresco
n00b
n00b


Joined: 29 Jul 2011
Posts: 56

PostPosted: Sat Aug 17, 2013 10:29 am    Post subject: Reply with quote

Indeed it is strange: if only one option works and not the other, it is not really an option.

And beside, it would have been nice if g15daemon was more verbose on the cause of failure instead of a generic "failed to start".

I'll find a way to make an official bug report.

Update
Bug report done: https://bugs.gentoo.org/show_bug.cgi?id=481454
_________________
Marco Di Fresco
Silicon Gadget
Back to top
View user's profile Send private message
iss
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2006
Posts: 133
Location: Poland/Bydgoszcz

PostPosted: Sun Aug 18, 2013 7:27 pm    Post subject: Reply with quote

So this was probably the reason app-misc/g15daemon stopped working for me after upgrade to 1.9.5.3-r7.

app-misc/g15daemon-1.9.5.3-r5 doesn't have this problem, so something was messed up in-between.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum