Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
3D printing with Gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
deltamalloc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2013
Posts: 135

PostPosted: Fri Aug 09, 2013 10:08 pm    Post subject: 3D printing with Gentoo Reply with quote

I got Pronterface running, but not Slic3r.

I have downloaded Slic3r from the git repo and it should be straightforward to start. This simply just "works" on other distros I've tried.

Code:

$ perl slic3r.pl
Can't locate Moo.pm in @INC (@INC contains: /home/printer/programs/Slic3r/lib /etc/perl /usr/lib64/perl5/site_perl/5.12.4/x86_64-linux /usr/lib64/perl5/site_perl/5.12.4 /usr/lib64/perl5/vendor_perl/5.12.4/x86_64-linux /usr/lib64/perl5/vendor_perl/5.12.4 /usr/lib64/perl5/site_perl /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.12.4/x86_64-linux /usr/lib64/perl5/5.12.4 /usr/local/lib/site_perl .) at /home/printer/programs/Slic3r/lib/Slic3r.pm line 24.
BEGIN failed--compilation aborted at /home/printer/programs/Slic3r/lib/Slic3r.pm line 24.
Compilation failed in require at slic3r.pl line 13.
BEGIN failed--compilation aborted at slic3r.pl line 13.


Any ideas about what is wrong here?
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1555
Location: Just over the horizon

PostPosted: Fri Aug 09, 2013 10:24 pm    Post subject: Reply with quote

Slic3r 0.9.10b works fine for me. Just unpacked it in my home directory.

What's odd is that I got an actual executable...not a perl script with my version.

It runs fine in Gentoo. Maybe you should give 0.9.10b a try.
Back to top
View user's profile Send private message
deltamalloc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2013
Posts: 135

PostPosted: Sat Aug 10, 2013 12:19 am    Post subject: Reply with quote

Solution: Read the instructions.

Execute the Build script.

This, however requires cpanminus, which requires an overlay to work. Not having messed around with overlays before, this was a painful experience.
Back to top
View user's profile Send private message
deltamalloc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2013
Posts: 135

PostPosted: Sat Aug 10, 2013 12:21 am    Post subject: Reply with quote

platojones wrote:
Slic3r 0.9.10b works fine for me. Just unpacked it in my home directory.

What's odd is that I got an actual executable...not a perl script with my version.

It runs fine in Gentoo. Maybe you should give 0.9.10b a try.


I cloned the latest git commit. I guess that is why.

However, when I download an earlier version, I get an executable too, but it doesn't give me a GUI. How did you solve that?
Back to top
View user's profile Send private message
deltamalloc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2013
Posts: 135

PostPosted: Sat Aug 10, 2013 3:06 pm    Post subject: Reply with quote

Solution: emerge libpng:1.2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum