Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas con el PERL
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
RazaRecords
n00b
n00b


Joined: 06 Aug 2013
Posts: 8

PostPosted: Tue Aug 06, 2013 5:16 pm    Post subject: Problemas con el PERL Reply with quote

Hola a toda la comunidad esta ves tengo el siguiente inconveniente espero me puedan ayudar, actualize el perl de mi gentoo 2.6.32-gentoo-r7 con el siguiente comando USE="ithreads" emerge perl ya que me salia un error threads a la hora de ejecutar un script con perl si mal no recuerdo mi version de perl era 5.8.8 y ahora es 5.12.4, luego de actualizar ejecute el siguiente comando perl-cleaner --all y listo. Trate de ejecutar mi script con perl y me salio el siguiente error:

Quote:
Can't locate DBI.pm in @INC (@INC contains: /etc/perl /usr/lib/perl5/site_perl/5.12.4/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.12.4 /usr/lib/perl5/vendor_perl/5.12.4/i686-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.4 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.12.4/i686-linux-thread-multi /usr/lib/perl5/5.12.4 /usr/local/lib/site_perl .) at /etc/script/monitoreo/sMonitoreoSimple.pl line 9.
BEGIN failed--compilation aborted at /etc/script/monitoreo/sMonitoreoSimple.pl line 9.


Un amigo me dijo que le instale el DBI, le hago un emerge DBI y me sale el siguiente error:

Quote:
* ERROR: dev-perl/DBD-mysql-4.01.7 failed (compile phase):
* Unable to build!
*
* Call stack:
* ebuild.sh, line 85: Called src_compile
* environment, line 2351: Called perl-module_src_compile
* environment, line 2004: Called perl-module_src_prep
* environment, line 2095: Called die
* The specific snippet of code:
* perl Makefile.PL "$@" <<< "${pm_echovar}" || die "Unable to build!";
*
* If you need support, post the output of 'emerge --info =dev-perl/DBD-mysql-4.01.7',
* the complete build log and the output of 'emerge -pqv =dev-perl/DBD-mysql-4.01.7'.
* The complete build log is located at '/var/tmp/portage/dev-perl/DBD-mysql-4.01.7/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-perl/DBD-mysql-4.01.7/temp/environment'.
* S: '/var/tmp/portage/dev-perl/DBD-mysql-4.01.7/work/DBD-mysql-4.017'


La verdad que nose que mas hacer, estoy con este problema estoy investigando pero no llego a alguna solucion, ojala alguno de ustedes me puedan ayudar. Gracias de antemano

Saludos
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1531

PostPosted: Tue Aug 06, 2013 8:12 pm    Post subject: Reply with quote

Quote:
/etc/script/monitoreo/sMonitoreoSimple.pl line 9

A lo mejor ayuda ver lo que contiene esa línea.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
RazaRecords
n00b
n00b


Joined: 06 Aug 2013
Posts: 8

PostPosted: Tue Aug 06, 2013 10:18 pm    Post subject: Reply with quote

Esto es lo que contiene esta linea 9

Quote:
use DBI;


Aunque no creo que el script sea el problema ya que tengo como 4 scrips que me salen errores similares. Antes funcionaba los demas scrips pero desde que actualize el perl me sale este error en todos
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1531

PostPosted: Wed Aug 07, 2013 6:36 am    Post subject: Reply with quote

ejecuta emerge -s DBI, si sale alguna version anterior de DBI instalada la desinstalas e intentas instalar de nuevo.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Wed Aug 07, 2013 8:13 am    Post subject: Re: Problemas con el PERL Reply with quote

RazaRecords wrote:
...
actualize el perl de mi gentoo 2.6.32-gentoo-r7 con el siguiente comando USE="ithreads" emerge perl
...

@RazaRecords:

¿Hiciste antes un emerge --sync?
Back to top
View user's profile Send private message
RazaRecords
n00b
n00b


Joined: 06 Aug 2013
Posts: 8

PostPosted: Wed Aug 07, 2013 12:18 pm    Post subject: Re: Problemas con el PERL Reply with quote

esteban_conde wrote:
ejecuta emerge -s DBI, si sale alguna version anterior de DBI instalada la desinstalas e intentas instalar de nuevo.


Ya lo desintale y lo volvi a instalar pero me sale un error

Quote:
* ERROR: dev-perl/DBI-1.618.0 failed (configure phase):
* Unable to build!
*
* Call stack:
* ebuild.sh, line 85: Called src_configure
* environment, line 2558: Called perl-module_src_configure
* environment, line 2176: Called perl-module_src_prep
* environment, line 2248: Called die
* The specific snippet of code:
* perl Makefile.PL "$@" <<< "${pm_echovar}" || die "Unable to build!";
*
* If you need support, post the output of 'emerge --info =dev-perl/DBI-1.618.0',
* the complete build log and the output of 'emerge -pqv =dev-perl/DBI-1.618.0'.
* The complete build log is located at '/var/tmp/portage/dev-perl/DBI-1.618.0/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-perl/DBI-1.618.0/temp/environment'.
* S: '/var/tmp/portage/dev-perl/DBI-1.618.0/work/DBI-1.618'


quilosaq wrote:
RazaRecords wrote:
...
actualize el perl de mi gentoo 2.6.32-gentoo-r7 con el siguiente comando USE="ithreads" emerge perl
...

@RazaRecords:

¿Hiciste antes un emerge --sync?


Hace poco le hice un emerge --sync, desde que hice eso cada ves que quiero actualizar algo me sale esto

Quote:
Reason: Failed on WHIRLPOOL verification
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1531

PostPosted: Wed Aug 07, 2013 3:47 pm    Post subject: Reply with quote

Quote:
* ERROR: dev-perl/DBI-1.618.0 failed (configure phase):
* Unable to build!

El error en configure puede venir por muchas causas, unas cuantas líneas más atras suele aparecer el verdadero error, no encuentra tal archivo .... cosas así vuelve a emerger y busca esas líneas.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
RazaRecords
n00b
n00b


Joined: 06 Aug 2013
Posts: 8

PostPosted: Wed Aug 07, 2013 4:15 pm    Post subject: Reply with quote

Hice lo indicado y si efectivamente aparece el verdadero error

Quote:
Checking if your kit is complete...
Looks good
JSON::PP 2.27103 is not available
at /usr/lib/perl5/site_perl/5.12.4/i686-linux-thread-multi/CPAN/Meta/Converter.pm line 22
at /usr/lib/perl5/site_perl/5.12.4/i686-linux-thread-multi/ExtUtils/MM_Any.pm line 767
Can't locate object method "allow_blessed" via package "JSON::PP" at /usr/lib/perl5/site_perl/5.12.4/i686-linux-thread-multi/CPAN/Meta/Converter.pm line 23.
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1531

PostPosted: Wed Aug 07, 2013 4:32 pm    Post subject: Reply with quote

Quote:
con el siguiente comando USE="ithreads" emerge perl

No puedo reproducir el error ya que no tengo instalado DBI el cual por cierto lleva aparejadas un monton de dependencias y posiblemente no las resuelva por si mismo.
La pregunta es ¿por qué usar "ithreads"? el paquete perl trae esa use -theads por defecto, en todo caso si necesitas compilarlo con esa use que posiblemente sea el motivo de reclamar DBI que asi mismo pide perl-DBI y tiene mysql como backend, la forma de hacerlo seria:
echo "dev-lang/perl ithreads">/etc/portage/package.use/perl
luego emerge -uDN perl
Suerte.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Wed Aug 07, 2013 5:43 pm    Post subject: Re: Problemas con el PERL Reply with quote

RazaRecords wrote:
...
Hace poco le hice un emerge --sync, desde que hice eso cada ves que quiero actualizar algo me sale esto

Quote:
Reason: Failed on WHIRLPOOL verification

Prueba:
Code:

# emerge portage
Back to top
View user's profile Send private message
RazaRecords
n00b
n00b


Joined: 06 Aug 2013
Posts: 8

PostPosted: Thu Aug 08, 2013 1:41 am    Post subject: Reply with quote

esteban_conde wrote:
Quote:
con el siguiente comando USE="ithreads" emerge perl

No puedo reproducir el error ya que no tengo instalado DBI el cual por cierto lleva aparejadas un monton de dependencias y posiblemente no las resuelva por si mismo.
La pregunta es ¿por qué usar "ithreads"? el paquete perl trae esa use -theads por defecto, en todo caso si necesitas compilarlo con esa use que posiblemente sea el motivo de reclamar DBI que asi mismo pide perl-DBI y tiene mysql como backend, la forma de hacerlo seria:
echo "dev-lang/perl ithreads">/etc/portage/package.use/perl
luego emerge -uDN perl
Suerte.


El archivo /etc/portage/package.use/perl no existe. Tampoco existe la carpeta package.use.

quilosaq wrote:
RazaRecords wrote:
...
Hace poco le hice un emerge --sync, desde que hice eso cada ves que quiero actualizar algo me sale esto

Quote:
Reason: Failed on WHIRLPOOL verification

Prueba:
Code:

# emerge portage


Al hacerle emerge portage o instalar cualquier otra cosa me sale el mismo error "Reason: Failed on WHIRLPOOL verification".

Estoy perdiendo las esperanzas de solucionar este problema :(
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1531

PostPosted: Thu Aug 08, 2013 8:01 am    Post subject: Reply with quote

Quote:
El archivo /etc/portage/package.use/perl no existe. Tampoco existe la carpeta package.use.

¡Ya! se me olvidó comentarlo, como root y desde /etc/portage ejecuta: mkdir package.use, el archivo se creará al ejecutar el comando del post anterior.
Por cierto respecto a wirlpool hay un post en el cual parece que lo solucionan http://forums.gentoo.org/viewtopic-t-929736-start-0.html
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
agdg
Guru
Guru


Joined: 15 Aug 2010
Posts: 320

PostPosted: Thu Aug 08, 2013 8:08 am    Post subject: Reply with quote

Ese error se debe a que tienes una versión de portage vieja. portage ha incorporado un nuevo sistema de verificación (WHIRLPOOL). Para solucionar el problema que tienes puedes intentar con:
Code:
sed 's/manifest-hashes = SHA256 SHA512 WHIRLPOOL/manifest-hashes = SHA256 SHA512/' /usr/portage/metadata/layout.conf  | tee /usr/portage/metadata/layout.conf

emerge -ql portage

sed 's/manifest-hashes = SHA256 SHA512/manifest-hashes = SHA256 SHA512 WHIRLPOOL/' /usr/portage/metadata/layout.conf  | tee /usr/portage/metadata/layout.conf

Después de eso, y con suerte, debería de funcionar sin problemas. Si no es así, busca el binario de portage en http://tinderbox.dev.gentoo.org/ e instalalo.

PD: ¿Que versión de portage tienes (emerge --info portage) y que versión de python usas (eselect python show)?
_________________
make install . es
Noticias, apuntes y pequeños tutoriales sobre GNU/Linux
Back to top
View user's profile Send private message
RazaRecords
n00b
n00b


Joined: 06 Aug 2013
Posts: 8

PostPosted: Thu Aug 08, 2013 2:04 pm    Post subject: Reply with quote

agdg wrote:
Ese error se debe a que tienes una versión de portage vieja. portage ha incorporado un nuevo sistema de verificación (WHIRLPOOL). Para solucionar el problema que tienes puedes intentar con:
Code:
sed 's/manifest-hashes = SHA256 SHA512 WHIRLPOOL/manifest-hashes = SHA256 SHA512/' /usr/portage/metadata/layout.conf  | tee /usr/portage/metadata/layout.conf

emerge -ql portage

sed 's/manifest-hashes = SHA256 SHA512/manifest-hashes = SHA256 SHA512 WHIRLPOOL/' /usr/portage/metadata/layout.conf  | tee /usr/portage/metadata/layout.conf

Después de eso, y con suerte, debería de funcionar sin problemas. Si no es así, busca el binario de portage en http://tinderbox.dev.gentoo.org/ e instalalo.

PD: ¿Que versión de portage tienes (emerge --info portage) y que versión de python usas (eselect python show)?


Igual el mismo problema...

emerge --info portage

Quote:
Portage 2.1.10.49 (default/linux/x86/10.0, gcc-4.3.4, glibc-2.10.1-r1, 2.6.32-gentoo-r7 i686)
=================================================================
System Settings
=================================================================
System uname: Linux-2.6.32-gentoo-r7-i686-Intel-R-_Xeon-R-_CPU_E5620_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Wed, 07 Aug 2013 13:00:01 +0000
app-shells/bash: 4.0_p35
dev-java/java-config: 2.1.10
dev-lang/python: 2.6.4
dev-util/cmake: 2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc: 0.6.1-r1
sys-apps/sandbox: 2.5
sys-devel/autoconf: 2.13, 2.68
sys-devel/automake: 1.10.2, 1.11.1
sys-devel/binutils: 2.18-r3
sys-devel/gcc: 4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.6b
sys-devel/make: 3.81
sys-kernel/linux-headers: 2.6.30-r1 (virtual/os-headers)
sys-libs/glibc: 2.10.1-r1
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 modules mudflap ncurses nls nptl openmp pam pcre readline session ssl tcpd unicode x86 zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="access authn_alias authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_owner authz_user auth_dbm auth_anon auth_digest alias file-cache echo charset-lite cache disk-cache mem-cache ext-filter case_filter case-filter-in deflate mime-magic cern-meta expires headers usertrack unique-id proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http info include cgi cgid dav dav-fs vhost-alias speling rewrite log_config logio env setenvif mime status autoindex asis negotiation dir imap actions userdir so filter unique_id authz_host" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
Package Settings
=================================================================

sys-apps/portage-2.1.10.49 was built with the following:
USE="(ipc) -build -doc -epydoc -pypy1_8 -python2 -python3 (-selinux) -xattr" LINGUAS="-pl"


eselect python show

Quote:
python2.6
Back to top
View user's profile Send private message
agdg
Guru
Guru


Joined: 15 Aug 2010
Posts: 320

PostPosted: Thu Aug 08, 2013 2:33 pm    Post subject: Reply with quote

RazaRecords wrote:
eselect python show

python2.6

Tu versión de portage y python son viejas. portage lo deberás de instalar desde un binario; después puede que funcione, o puede que necesites actualizar python también desde un binario.

1.- Instala el ultimo binario de portage disponible en tinderbox
2.- Actualiza python, o instala desde un binario de tinderbox (de la rama 2.7)
3.- Selecciona python2.7
4.- Haz un python-updater
5.- Actualizar el sistema, revdep-rebuild...

Suerte ;)
_________________
make install . es
Noticias, apuntes y pequeños tutoriales sobre GNU/Linux
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 838

PostPosted: Thu Aug 08, 2013 2:38 pm    Post subject: Reply with quote

RazaRecords wrote:
...
Igual el mismo problema...
...

Tienes que arreglar el problema del WHIRLPOOL antes que nada. esteban_conde te ha dado el enlace a un post sobre el tema. Aquí tienes otro mas corto: http://www.oneroot.ca/gentoo-linux/gentoo-linux-whirlpool
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum