Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Mounting /boot error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
hcyildiran
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2011
Posts: 101

PostPosted: Sun Jul 28, 2013 9:56 pm    Post subject: [SOLVED]Mounting /boot error Reply with quote

I`m back on a new install. Previously I couldn`t fix similar problem. http://forums.gentoo.org/viewtopic-t-963776-highlight-.html
Code:
# cat /usr/src/linux/.config

#
# File systems
#
CONFIG_DCACHE_WORD_ACCESS=y
CONFIG_EXT2_FS=m
# CONFIG_EXT2_FS_XATTR is not set
# CONFIG_EXT2_FS_XIP is not set
# CONFIG_EXT3_FS is not set
CONFIG_EXT4_FS=y
CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXT4_FS_POSIX_ACL=y
CONFIG_EXT4_FS_SECURITY=y
# CONFIG_EXT4_DEBUG is not set


Code:
tux cy # modprobe ext2
tux cy # mount /boot
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so
tux cy #


Last edited by hcyildiran on Tue Jul 30, 2013 7:53 pm; edited 2 times in total
Back to top
View user's profile Send private message
defer-
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2007
Posts: 132
Location: Finland

PostPosted: Sun Jul 28, 2013 10:19 pm    Post subject: Reply with quote

Does this work?
# mount -t ext2 /boot
_________________
https://github.com/defer-
Back to top
View user's profile Send private message
hcyildiran
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2011
Posts: 101

PostPosted: Sun Jul 28, 2013 10:21 pm    Post subject: Reply with quote

Code:
 # mount -t ext2 /boot
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so
Back to top
View user's profile Send private message
defer-
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2007
Posts: 132
Location: Finland

PostPosted: Mon Jul 29, 2013 12:16 am    Post subject: Reply with quote

I think you should format your /boot partition and install grub and kernel again.
_________________
https://github.com/defer-
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8903

PostPosted: Mon Jul 29, 2013 12:46 am    Post subject: Re: Mounting /boot error Reply with quote

hcyildiran wrote:
Code:

       In some cases useful info is found in syslog - try
       dmesg | tail or so
Back to top
View user's profile Send private message
hcyildiran
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2011
Posts: 101

PostPosted: Mon Jul 29, 2013 8:10 pm    Post subject: Reply with quote

Code:
tux cy # syslog-ng - try
Excess number of arguments
tux cy # dmesg | tail
[   11.842214] r8169 0000:05:00.0 enp5s0: link down
[   13.474739] r8169 0000:05:00.0 enp5s0: link up
[   13.474761] IPv6: ADDRCONF(NETDEV_CHANGE): enp5s0: link becomes ready
[   23.831937] iwlwifi 0000:09:00.0: L1 Disabled; Enabling L0S
[   23.838621] iwlwifi 0000:09:00.0: Radio type=0x2-0x2-0x1
[   24.032657] iwlwifi 0000:09:00.0: L1 Disabled; Enabling L0S
[   24.039336] iwlwifi 0000:09:00.0: Radio type=0x2-0x2-0x1
[   24.242241] IPv6: ADDRCONF(NETDEV_UP): wlp9s0: link is not ready
[   46.505214] EXT4-fs (sda3): re-mounted. Opts: commit=0
[  302.140494] kworker/u:0 (6) used greatest stack depth: 4000 bytes left
tux cy #

Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31835
Location: 56N 3W

PostPosted: Mon Jul 29, 2013 8:17 pm    Post subject: Reply with quote

hcyildiran,

You have
Code:
CONFIG_EXT2_FS=m
...
CONFIG_EXT4_FS=y
CONFIG_EXT4_USE_FOR_EXT23=y


You do not need both CONFIG_EXT2_FS=m and CONFIG_EXT4_USE_FOR_EXT23=y
If the ext2 module is loaded, look in lsmod, remove it the try your mount /boot again.

You have made the ext4 filesystem driver support ext2 and ext3.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
hcyildiran
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2011
Posts: 101

PostPosted: Mon Jul 29, 2013 8:28 pm    Post subject: Reply with quote

Code:
$ lsmod
Module                  Size  Used by
ext2                   49994  0


But I dont know how to remove it
Back to top
View user's profile Send private message
hcyildiran
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2011
Posts: 101

PostPosted: Mon Jul 29, 2013 8:49 pm    Post subject: | Reply with quote

Code:
tux cy # modprobe -r ext2
tux cy # lsmod
Module                  Size  Used by
tux cy # mount /boot
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so


Is it right? If so no solve yet.

Maybe making CONFIG_EXT4_USE_FOR_EXT23=n and reload ext2 module the right path?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31835
Location: 56N 3W

PostPosted: Mon Jul 29, 2013 9:02 pm    Post subject: Reply with quote

hcyildiran,

Code:
modprobe -r ext2
-r means remove.

Please post your /etc/fstab
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
hcyildiran
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2011
Posts: 101

PostPosted: Mon Jul 29, 2013 9:05 pm    Post subject: Reply with quote

Code:
/dev/sda1               /boot           ext2            defaults,noatime0 2
/dev/sda3               /               ext3            noatime         0 1
/dev/sda2               none            swap            sw              0 0
/dev/cdrom              /mnt/cdrom      auto            noauto,user     0 0
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31835
Location: 56N 3W

PostPosted: Mon Jul 29, 2013 9:09 pm    Post subject: Reply with quote

hcyildiran,

/boot should already be mounted as you have the options set to defaults, not noauto.
What does ls /boot show ?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
hcyildiran
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2011
Posts: 101

PostPosted: Mon Jul 29, 2013 9:17 pm    Post subject: Reply with quote

Code:
tux cy # ls /boot
tux cy #


Nothing?

In fstab / partition shows ext3 filesystem. It must be typo while installing. I made it appropriate to handbook. May it be reason?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31835
Location: 56N 3W

PostPosted: Mon Jul 29, 2013 9:32 pm    Post subject: Reply with quote

hcyildiran,

What you have for root is not related to the entry for boot.

Try
Code:
mount -t auto -o ro /dev/sda1 /mnt/cdrom

/mnt/cdrom must exist.

This will tell mount to guess the filesystem type. It will try all the filesystems the kernel knows.
This guessing is not safe, hence the -o ro, so if it does mount with the wrong filesystem type, it cannot be written to.

What does the first few lines of
Code:
dumpe2fs /dev/sda1
You need to be root.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
hcyildiran
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2011
Posts: 101

PostPosted: Mon Jul 29, 2013 9:33 pm    Post subject: Reply with quote

Code:
tux cy # modprobe -r ext2
tux cy # lsmod
Module                  Size  Used by
tux cy # mount /boot
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so
tux cy # lsmod
Module                  Size  Used by
ext2                   49994  0
tux cy #


modprobe -r command doesnt remove the module permanently.

Code:
tux cy # mount -t auto -o ro /dev/sda1 /mnt/cdrom
mount: mount point /mnt/cdrom does not exist


tux cy # dumpe2fs /dev/sda1
dumpe2fs 1.42.7 (21-Jan-2013)
Filesystem volume name:   <none>
Last mounted on:          <not available>
Filesystem UUID:          b0abdd49-29d1-410d-b603-a1fd2bfa13c7
Filesystem magic number:  0xEF53
Filesystem revision #:    1 (dynamic)
Filesystem features:      ext_attr resize_inode dir_index filetype sparse_super
Filesystem flags:         signed_directory_hash
Default mount options:    user_xattr acl
Filesystem state:         clean
Errors behavior:          Continue
Filesystem OS type:       Linux
Inode count:              8032
Block count:              32096
Reserved block count:     1604
Free blocks:              19525
Free inodes:              7997
First block:              1
Block size:               1024
Fragment size:            1024
Reserved GDT blocks:      125
Blocks per group:         8192
Fragments per group:      8192
Inodes per group:         2008
Inode blocks per group:   251
RAID stride:              4
RAID stripe width:        4
Filesystem created:       Thu Jul 25 23:29:39 2013
Last mount time:          n/a
Last write time:          Sun Jul 28 15:48:44 2013
Mount count:              8
Maximum mount count:      -1
Last checked:             Thu Jul 25 23:29:39 2013
Check interval:           0 (<none>)
Reserved blocks uid:      0 (user root)
Reserved blocks gid:      0 (group root)
First inode:              11
Inode size:               128
Default directory hash:   half_md4
Directory Hash Seed:      0005c7b9-1fd8-4b4f-a72f-e2b782fc0e48
..............
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31835
Location: 56N 3W

PostPosted: Mon Jul 29, 2013 9:46 pm    Post subject: Reply with quote

hcyildiran,

Find ext2.ko in /lib/modules/`uname -r`/... and rename it so modprobe cannot load it.

Also, use the long form of mount, so /etc/fstab is not consulted.
Hmm ... I think that
Code:
Default mount options:    user_xattr acl
makes it ext3 or ext4

My ext2 /boot says Default mount options: (none)
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8903

PostPosted: Mon Jul 29, 2013 10:12 pm    Post subject: Reply with quote

hcyildiran wrote:
Code:
/dev/sda1               /boot           ext2            defaults,noatime0 2
The mount options are supposed to be separated from the next field by at least one whitespace.
Back to top
View user's profile Send private message
hcyildiran
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2011
Posts: 101

PostPosted: Mon Jul 29, 2013 10:17 pm    Post subject: Reply with quote

Code:
 /lib/modules/3.8.13-gentoo/kernel/fs/ext2/ext2.ko


rename what and how please



What is your suggestion about Default mount options: user_xattr acl
Back to top
View user's profile Send private message
hcyildiran
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2011
Posts: 101

PostPosted: Mon Jul 29, 2013 10:29 pm    Post subject: Reply with quote

Hu wrote:
hcyildiran wrote:
Code:
/dev/sda1               /boot           ext2            defaults,noatime0 2
The mount options are supposed to be separated from the next field by at least one whitespace.


When changed fstab model in livecd install medium suitable for Gentoo Handbook, there were no space remainder. I just saved so. If I changed the column would be replaced
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31835
Location: 56N 3W

PostPosted: Tue Jul 30, 2013 4:37 pm    Post subject: Reply with quote

hcyildiran,

Change /lib/modules/3.8.13-gentoo/kernel/fs/ext2/ext2.ko to /lib/modules/3.8.13-gentoo/kernel/fs/ext2/ext2_.ko
So that you can rename it back.

As Hu says, change defaults,noahtime0 2 to defaults,noatime 0 2
Note the space before the zero. However, if you use the long form of mount, /etc/fstab is not consulted
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
hcyildiran
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2011
Posts: 101

PostPosted: Tue Jul 30, 2013 7:51 pm    Post subject: Reply with quote

Hu,
now my fstab:
Code:
/dev/sda1               /boot           ext2            defaults,noatime 0 2
/dev/sda3               /               ext3            noatime         0 1
/dev/sda2               none            swap            sw              0 0
/dev/cdrom              /mnt/cdrom      auto            noauto,user     0 0


and as you tell, mount /boot 's working. Thank you.

NeddySeagoon,
I learnt many things by your explanations

hcyildiran wrote:

Quote:
When changed fstab model in livecd install medium suitable for Gentoo Handbook, there were no space remainder. I just saved so. If I changed the column would be replaced


hcyildiran
for now you should listen to veterans more
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum