Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[QT5] qtdeclarative not found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1500
Location: Switzerland (Romandie)

PostPosted: Fri Jul 26, 2013 9:10 am    Post subject: [QT5] qtdeclarative not found Reply with quote

I am trying to make a live ebuild for musescore. I installed the qt5 overlay, and I get the following warnig with musescore:

Code:
CMake Warning at build/FindQt5Transitional.cmake:29 (find_package):
  By not providing "FindQt5Declarative.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "Qt5Declarative", but CMake did not find one.

  Could not find a package configuration file provided by "Qt5Declarative"
  with any of the following names:

    Qt5DeclarativeConfig.cmake
    qt5declarative-config.cmake

  Add the installation prefix of "Qt5Declarative" to CMAKE_PREFIX_PATH or set
  "Qt5Declarative_DIR" to a directory containing one of the above files.  If
  "Qt5Declarative" provides a separate development package or SDK, be sure it
  has been installed.
Call Stack (most recent call first):
  CMakeLists.txt:26 (include)


Of course, I put qtdeclarative:5 in the DEPEND of musescore, and qtdeclarative is installed. So, I am confused. Know someone which package provide QT5Declarative, if it is not qtdeclarative:5? Or what should I do?
_________________
[[[ To any NSA and FBI agents reading that text: please consider ]]]
[[[ whether defending the US Constitution against all enemies, ]]]
[[[ foreign or domestic, requires you to follow Snowden's example. ]]]
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sat Jul 27, 2013 9:50 pm    Post subject: Reply with quote

Of course it is qtdeclarative:5. This is more likely a problem with cmake.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1500
Location: Switzerland (Romandie)

PostPosted: Sat Jul 27, 2013 11:39 pm    Post subject: Reply with quote

I installed qtdeclarative:5 from the qt overlay, but musescore build system doesn't find it. It search for Qt5DeclarativeConfig.cmake or qt5declarative-config.cmake and don't find them. I checked with both equery and locate, but it is no such files into my system.

I also see some qt5 packages are missing into the qt overlay. I understand it is a work in progress and will take some time. For me, used to a big screen with big fonts, qtconfig:5 will be very useful. I succeeded with my musescore ebuild, but the menu fonts are way too small for me at that point.
_________________
[[[ To any NSA and FBI agents reading that text: please consider ]]]
[[[ whether defending the US Constitution against all enemies, ]]]
[[[ foreign or domestic, requires you to follow Snowden's example. ]]]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum