Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ffmpeg failing with ' Unknown encoder 'libx264' '
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
nooster
n00b
n00b


Joined: 23 Feb 2007
Posts: 33

PostPosted: Fri Jul 19, 2013 11:02 pm    Post subject: ffmpeg failing with ' Unknown encoder 'libx264' ' Reply with quote

Hi all. I've spend all evening trying to read up on use flags and the like and am none the wiser on how to go about fixing this.

I guess a little hand holding is required - sorry.

I have emerged media-video.ffmpeg-1.0.7 and while it runs the following command successful
Code:
ffmpeg -n -threads 0 -i "$1" -acodec copy -vcodec copy -pix_fmt yuv420p -f mov "${1%%.*}.mov"


I get a 'Unknown encoder 'libx264' error when trying
Code:
ffmpeg -n -threads 0 -i "$1" -s 320x180 -r 30000/1001 -b:v 200k -bt 240k -vcodec libx264 -acodec libfaac -ac 2 -ar 48000 -ab 192k "${1%%.*}.mp4"


First I tried 'emerge libx264 but that doesn't exist.

Looking further the output of ffmpeg -codecs is
Code:
 D.V.LS h264                 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10


So I'm guessing the libx264 codec is not installed.

But if libx264 isn't a package I can't see how to resolve this and reading google hits doesn't make it clear what I should do.

Can anyone offer a a light at the end of the tunnel, please?
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4742
Location: Saint Amant, Acadiana

PostPosted: Fri Jul 19, 2013 11:37 pm    Post subject: Reply with quote

Output of emerge -pv ffmpeg please?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
nooster
n00b
n00b


Joined: 23 Feb 2007
Posts: 33

PostPosted: Fri Jul 19, 2013 11:48 pm    Post subject: Reply with quote

emerge -pv ffmpeg:-

Code:

These are the packages that would be merged, in order:

Calculating dependencies  ... done!
[ebuild   R    ] media-video/ffmpeg-1.0.7  USE="bzip2 encode hardcoded-tables mmx zlib -3dnow -3dnowext -X -aac -aacplus -alsa (-altivec) -amr -avx -bindist -bluray -cdio (-celt) -cpudetection -debug -doc -examples -faac -fdk -flite -fontconfig -frei0r -gnutls -gsm -iec61883 -ieee1394 -jack -jpeg2k -libass -libcaca -libv4l -mmxext -modplug -mp3 (-neon) -network -openal -openssl -opus -oss -pic -pulseaudio -rtmp -schroedinger -sdl -speex -ssse3 -static-libs {-test} -theora -threads -truetype -twolame -v4l -vaapi -vdpau (-vis) -vorbis -vpx -x264 -xvid" FFTOOLS="aviocat cws2fws ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

 * IMPORTANT: 9 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.



I tried putting
Code:
media-video/ffmpeg-1.0.7 libx264


but it gives an 'invalid atom' error
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4742
Location: Saint Amant, Acadiana

PostPosted: Sat Jul 20, 2013 12:00 am    Post subject: Reply with quote

Your USE flags show -x264 ... you may want to turn it on.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Chiitoo
l33t
l33t


Joined: 28 Feb 2010
Posts: 912
Location: Here and Away Again

PostPosted: Wed Jul 24, 2013 8:48 pm    Post subject: ><)))°€ Reply with quote

Teegrins, nooster!


The actual issue was likely addressed already, but in case you did not figure out the following part, I'd like to say a thing or few about that.

nooster wrote:
I tried putting
Code:
media-video/ffmpeg-1.0.7 libx264


but it gives an 'invalid atom' error

The reason for this is that the format is incorrect, or rather incomplete, and thus rendered invalid (see man portage for more). Whenever you specify a version, you will need to also define if you want only the exact version, the version equal to and greater than... less or greater than... like so:

Code:
=media-video/ffmpeg-1.0.7 x264
>=media-video/ffmpeg-1.0.7 x264

And so on and forth.

Considering it is a package that will likely be used for a while to come, one might omit the version altogether, and define the category/package alone:

Code:
media-video/ffmpeg x264

Or, enable the flag globally. ^^


I hope this helps~
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum