Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
forums.gentoo.org intermittently drops out of DNS existence
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo Forums Feedback
View previous topic :: View next topic  
Author Message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1566
Location: U.S.A.

PostPosted: Fri Jul 12, 2013 12:31 pm    Post subject: forums.gentoo.org intermittently drops out of DNS existence Reply with quote

Seems to happen quite often, even with highly reliable DNS servers.

As I investigate why my web browser says the server can't be found, and discover that ping fails (unknown host):
Code:
~ # nslookup forums.gentoo.com 8.8.8.8
Server:      8.8.8.8
Address:   8.8.8.8#53

** server can't find forums.gentoo.com: NXDOMAIN

~ # nslookup forums.gentoo.com 4.2.2.1
Server:      4.2.2.1
Address:   4.2.2.1#53

** server can't find forums.gentoo.com: NXDOMAIN

And yet (done immediately after):
Quote:
t~ # dig forums.gentoo.org

; <<>> DiG 9.9.2 <<>> forums.gentoo.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43543
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;forums.gentoo.org. IN A

;; ANSWER SECTION:
forums.gentoo.org. 223 IN CNAME forums-lb.gentoo.org.
forums-lb.gentoo.org. 379 IN CNAME gossamer-ipvs-forums-v4v6.gentoo.org.
gossamer-ipvs-forums-v4v6.gentoo.org. 389 IN A 204.187.15.12

;; Query time: 3 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Fri Jul 12 08:27:13 2013
;; MSG SIZE rcvd: 135

Something wrong with the records being posted by the hosting service?

And then, by the time I finished this post:
Code:
twister ~ # nslookup forums.gentoo.org
Server:      127.0.0.1
Address:   127.0.0.1#53

Non-authoritative answer:
forums.gentoo.org   canonical name = forums-lb.gentoo.org.
forums-lb.gentoo.org   canonical name = gossamer-ipvs-forums-v4v6.gentoo.org.
Name:   gossamer-ipvs-forums-v4v6.gentoo.org
Address: 204.187.15.12


This has been going on for a long time. Like a year or two.
_________________
pjp wrote:
I didn't misquote you, I just misunderstood you.
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Mon Jul 15, 2013 5:06 pm    Post subject: Re: forums.gentoo.org intermittently drops out of DNS existe Reply with quote

BoneKracker wrote:
Seems to happen quite often, even with highly reliable DNS servers.

As I investigate why my web browser says the server can't be found, and discover that ping fails (unknown host):
Code:
~ # nslookup forums.gentoo.com 8.8.8.8
Server:      8.8.8.8
Address:   8.8.8.8#53

** server can't find forums.gentoo.com: NXDOMAIN

~ # nslookup forums.gentoo.com 4.2.2.1
Server:      4.2.2.1
Address:   4.2.2.1#53

** server can't find forums.gentoo.com: NXDOMAIN


forums.gentoo.com There's your problem.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1566
Location: U.S.A.

PostPosted: Mon Jul 15, 2013 5:46 pm    Post subject: Re: forums.gentoo.org intermittently drops out of DNS existe Reply with quote

tomk wrote:
BoneKracker wrote:
Seems to happen quite often, even with highly reliable DNS servers.

As I investigate why my web browser says the server can't be found, and discover that ping fails (unknown host):
Code:
~ # nslookup forums.gentoo.com 8.8.8.8
Server:      8.8.8.8
Address:   8.8.8.8#53

** server can't find forums.gentoo.com: NXDOMAIN

~ # nslookup forums.gentoo.com 4.2.2.1
Server:      4.2.2.1
Address:   4.2.2.1#53

** server can't find forums.gentoo.com: NXDOMAIN


forums.gentoo.com There's your problem.

:oops: :lol: :lol: :lol:

I swear I've checked this several times before though, but maybe I made the same blunder then.

At an rate, I frequently get "could not find server", as well as "message_die() was called multiple times", "unable to look up user information", and other errors.

Since I've just proved myself daft, though, I'll assume that it's all been user error, and pay more attention if I investigate it in the future.
:lol:
_________________
pjp wrote:
I didn't misquote you, I just misunderstood you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Forums Feedback All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum