Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to install Handbrake on gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2192

PostPosted: Tue May 28, 2013 12:41 pm    Post subject: Reply with quote

lyallp ...

I don't have this particular ebuild so I can't check, but this looks like one of two things: the ebuild has a hardcoded libav dependency, or (more likely) your getting libav-9999 to meet the virtual/ffmpeg-9 requirement. Unfortunately, the only way to move forward on this is to unmask media-video/ffmpeg and virtual/ffmpeg-9.

/etc/portage/package.unmask
Code:
media-video/ffmpeg::gentoo
=virtual/ffmpeg-9

/etc/portage/package.accept_keywords
Code:
=media-video/ffmpeg-1.2.1
=virtual/ffmpeg-9

With these set a '-pv' should at least show if ffmpeg can provide the dependency, however, installing media-video/ffmpeg-1.2.1 may break other packages currently dependent on the stable 0.10.7 package (which is in part the reason for the mask). You would need to revdep-rebuild any packages currently built against 0.10.7 and probably won't be able to tell which will succeed/fail until then.

The following will show the extent of potential problem packages:

Code:
# equery depends ffmpeg

HTH & best ... khay
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1254
Location: Adelaide/Australia

PostPosted: Mon Jun 03, 2013 11:29 am    Post subject: Reply with quote

Just a bit of breakage... :)

/etc/portage/package.unmask/handbrake.unmask
Code:
=media-video/handbrake-9999
=virtual/ffmpeg-9

/etc/portage/package.keywords/handbrake.keywords
Code:

media-video/handbrake      **
media-libs/libmkv      ~amd64
virtual/ffmpeg         ~amd64
media-video/libav      **

Code:

root@lyalls-pc ~
# emerge --pretend --verbose --tree handbrake

These are the packages that would be merged, in reverse order:

Calculating dependencies  ... . ... done!
[ebuild  N    #] media-video/handbrake-9999  USE="ffmpeg -fdk -gstreamer -gtk" 0 kB
[ebuild     U #]  virtual/ffmpeg-9 [0.10.3] USE="X encode jpeg2k mp3 sdl threads truetype x264 -gsm -opus% -speex -theora -vaapi -vdpau" 0 kB
[ebuild  N    *]   media-video/libav-9999:0/9  USE="X aac alsa amr bzip2 cdio encode gpl hardcoded-tables jpeg2k mmx mmxext mp3 oss sdl ssl threads truetype v4l vorbis x264 xvid zlib -3dnow -3dnowext (-altivec) -avx -bindist -cpudetection -custom-cflags -debug -doc -faac -fdk -frei0r -gsm -ieee1394 -jack (-neon) -network -openssl -opus -pic -pulseaudio -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -theora -tools -vaapi -vdpau (-vis) -vpx" 0 kB
[ebuild  N    ~]  media-libs/libmkv-0.6.5.1  32 kB
[ebuild  N     ]  media-libs/libbluray-0.2.3  USE="java xml -aacs -static-libs -utils" 455 kB
[blocks B      ] media-video/ffmpeg ("media-video/ffmpeg" is blocking media-video/libav-9999)

Total: 5 packages (1 upgrade, 4 new), Size of downloads: 487 kB
Conflict: 1 block (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

virtual/ffmpeg:0

  (virtual/ffmpeg-0.10.3::gentoo, installed) pulled in by
    =virtual/ffmpeg-0.10* required by (media-plugins/gst-plugins-ffmpeg-0.10.13-r2::gentoo, installed)

  (virtual/ffmpeg-9::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/ffmpeg-9 required by (media-video/gpac-0.5.0::gentoo, installed)
    (and 17 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

root@lyalls-pc ~
# equery depends ffmpeg
 * These packages depend on ffmpeg:
app-cdr/k3b-2.0.2-r4 (ffmpeg ? virtual/ffmpeg)
app-misc/strigi-0.7.7-r2 (ffmpeg ? virtual/ffmpeg)
kde-base/nepomuk-core-4.10.2 (ffmpeg ? virtual/ffmpeg)
media-libs/gegl-0.1.6 (ffmpeg ? virtual/ffmpeg)
media-libs/libquicktime-1.2.4 (ffmpeg ? virtual/ffmpeg)
media-libs/openal-1.15.1 (alstream ? virtual/ffmpeg)
media-libs/opencv-2.4.3 (ffmpeg ? virtual/ffmpeg)
media-libs/xine-lib-1.2.2 (media-video/ffmpeg)
                          (virtual/ffmpeg)
media-plugins/gst-plugins-ffmpeg-0.10.13-r2 (=virtual/ffmpeg-0.10*)
                                            (media-video/ffmpeg)
media-sound/audacity-2.0.0 (ffmpeg ? virtual/ffmpeg)
media-sound/kid3-2.2.1 (acoustid ? virtual/ffmpeg)
media-sound/sox-14.4.1 (ffmpeg ? >=virtual/ffmpeg-0.9)
media-video/dvdrip-0.98.11-r1 (ffmpeg ? virtual/ffmpeg)
media-video/ffmpegthumbnailer-2.0.8 (>=virtual/ffmpeg-0.10.2)
media-video/gpac-0.5.0 (ffmpeg ? virtual/ffmpeg)
media-video/kino-1.3.4 (virtual/ffmpeg)
media-video/mplayer-1.1-r1 (>=virtual/ffmpeg-0.10.3)
media-video/transcode-1.1.7-r1 (>=virtual/ffmpeg-0.10)
                               (postproc ? >=virtual/ffmpeg-0.10)
media-video/vlc-2.0.5 (avcodec ? virtual/ffmpeg)
                      (avformat ? virtual/ffmpeg)
                      (postproc ? media-video/ffmpeg)
                      (swscale ? virtual/ffmpeg)
net-misc/mediatomb-0.12.1-r6 (ffmpeg ? virtual/ffmpeg)
net-misc/minidlna-1.1.0-r2 (virtual/ffmpeg)
net-p2p/tribler-6.0.3 (vlc ? media-video/ffmpeg)
virtual/ffmpeg-0.10.3 (>=media-video/ffmpeg-0.10.3[X?,encode?,gsm?,jpeg2k?,mp3?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?])
www-client/chromium-27.0.1453.93 (system-ffmpeg ? >=media-video/ffmpeg-1.0[opus])
www-misc/zoneminder-1.25.0-r1 (ffmpeg ? >=media-video/ffmpeg-0.5-r1)
root@lyalls-pc ~
#

_________________
...Lyall
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1546

PostPosted: Wed Jun 05, 2013 2:10 pm    Post subject: Reply with quote

tomk wrote:
Moved from Multimedia to Unsupported Software as it's not in the Portage tree.


It is now. :wink:

lyallp wrote:
Just a bit of breakage... :)


Where? No bug, no party. :D

lyallp wrote:
virtual/ffmpeg:0

(virtual/ffmpeg-0.10.3::gentoo, installed) pulled in by
=virtual/ffmpeg-0.10* required by (media-plugins/gst-plugins-ffmpeg-0.10.13-r2::gentoo, installed)

(virtual/ffmpeg-9::gentoo, ebuild scheduled for merge) pulled in by
=virtual/ffmpeg-9 required by (media-video/gpac-0.5.0::gentoo, installed)
(and 17 more with the same problem)


virtual/ffmpeg-0.10.3 and virtual/ffmpeg-9 both have SLOT="0"; to resolve this slot conflict, unmerge and mask =media-plugins/gst-plugins-ffmpeg-0.10.13-r2 and =virtual/ffmpeg-0.10.3 and unmerge anything that only depends on those two, unless you can change the USE flags around. Also, if you want media-video/libav; you'll need to unmerge and mask media-video/ffmpeg and unmerge anything that has a dependency on those two, unless you can change the USE flags around.

Quote:
net-p2p/tribler-6.0.3 (vlc ? media-video/ffmpeg)
www-client/chromium-27.0.1453.93 (system-ffmpeg ? >=media-video/ffmpeg-1.0[opus])
www-misc/zoneminder-1.25.0-r1 (ffmpeg ? >=media-video/ffmpeg-0.5-r1)


From a quick look; the above is a list of packages you'll want to disable the relevant USE flags for, other packages appear to list alternatives.
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1254
Location: Adelaide/Australia

PostPosted: Thu Jun 06, 2013 9:36 am    Post subject: Reply with quote

That it's in portage now, great :)

No bug? Well, I didn't consider it a bug, I considered that the config of my system was preventing it's install.

net-p2p/tribler - hell, I didn't even realise I had that installed, gone!
www-client/chromium - I used eix to examine the use flags on this one, system-ffmpeg is disabled already. The only use flag I have enabled for chromium is 'cups'.

Anyway, I only wanted to look at Handbrake. Maybe I am overestimating the amount of effort but having to re-jig my system just so I can install one package is all too hard, at least at this point.

Thanks for your post, though. :)
_________________
...Lyall
Back to top
View user's profile Send private message
The Unabeefer
n00b
n00b


Joined: 23 Dec 2008
Posts: 60
Location: Chicago, IL

PostPosted: Thu Jun 06, 2013 9:26 pm    Post subject: Reply with quote

Has anyone tried merely unmasking media-video/ffmpeg 1.2.1?? Seems virtual/ffmpeg-9 only wants libav OR a version of ffmpeg greater than 1.1.

I am mid-compile of something else at the moment, but when that's done, I'll be trying it out....

When I place the following in my /etc/portage/package.unmask
Quote:
=media-video/handbrake-0.9.9
=virtual/ffmpeg-9
>=media-video/ffmpeg-1.2.1

an "emerge -p handbrake" shows no blocked packages or masking issues.
_________________
I am a flying cow... worship me or DIE!!!

...and there he was, reigning supreme at number two...
The One... The Only... The Unabeefer
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1546

PostPosted: Thu Jun 06, 2013 9:39 pm    Post subject: Reply with quote

The Unabeefer wrote:
Has anyone tried merely unmasking media-video/ffmpeg 1.2.1?? Seems virtual/ffmpeg-9 only wants libav OR a version of ffmpeg greater than 1.1.

I am mid-compile of something else at the moment, but when that's done, I'll be trying it out....

When I place the following in my /etc/portage/package.unmask
Quote:
=media-video/handbrake-0.9.9
=virtual/ffmpeg-9
>=media-video/ffmpeg-1.2.1

an "emerge -p handbrake" shows no blocked packages or masking issues.


Yes, the new virtual is for the newer versions of ffmpeg and libav; which are currently masked because they result in at least audio issues for some people.

The Portage tree version of Handbrake only works with the newer versions of virtual/ffmpeg, older versions of virtual/ffmpeg give compile errors that aren't easy to fix (and even if you fix them, it probably wouldn't work well)

So, we just have to wait until the audio issues get fixed and the masks drop before we finally have a non-masked way to use Handbrake...
Back to top
View user's profile Send private message
nickel
Tux's lil' helper
Tux's lil' helper


Joined: 21 Oct 2005
Posts: 146

PostPosted: Mon Jun 24, 2013 6:30 pm    Post subject: Reply with quote

I don't know, if i made something stupid, but i managed to compile handbrake-0.9.9!

I did read what was written above and frst i tried handbrake on ubuntu, to see, if it's worth the pain :x
I wrote an script, which uses mencoder, mplayer, faac and mkvmerge to do the thing. It works great, but it takes 8-12 hours! (i have an i7 -> 8 cores)
Handbrake did the job with a similar quality in 2-3 hours!
So, i'ge got have it on gentoo! I don't like ubuntu.

I read here about the slot conflicts and ffmpeg older versions not working and did exctly what's here. With the only diference, i unmerged gst-plugins- ffmpeg and ffmeg (virtual too).
I emerged handbrabe and then ffmpeg.
I ran revdep-rebuild and 5 programms are recompiling (e.g. mplayer uses ffmpeg, so far i know).

At least mplayer is working right... for the moment
Back to top
View user's profile Send private message
nickel
Tux's lil' helper
Tux's lil' helper


Joined: 21 Oct 2005
Posts: 146

PostPosted: Tue Jun 25, 2013 3:33 pm    Post subject: Reply with quote

well, it compiled and runs well. But after setting everything and start encoding, at 1% i get segmentaton fault and the programm crashes.
Perhaps, do someone know why?
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1546

PostPosted: Wed Jun 26, 2013 3:24 pm    Post subject: Reply with quote

See http://www.gentoo.org/proj/en/qa/backtraces.xml on how to obtain more information about a segmentation fault.
Back to top
View user's profile Send private message
jazernorth
n00b
n00b


Joined: 26 Oct 2004
Posts: 50
Location: Heber City, UT

PostPosted: Sun Jul 14, 2013 8:50 pm    Post subject: Reply with quote

I get the following error when trying to emerge handbrake-9999. I have verified I have the latest handbrake-9999-remove-faac-dependency.patch file and that it is in files directory in the media-video/handbrake directory. There seems to be an error within the patch itself. Any ideas on the fix?

Code:
>>> Emerging (1 of 1) media-video/handbrake-9999
>>> Unpacking source...
 * subversion update start -->
 *      repository: svn://svn.handbrake.fr/HandBrake/trunk
Updating '.':
U    win/CS/HandBrakeWPF/HandBrakeWPF.csproj
U    win/CS/HandBrakeWPF/Views/PictureSettingsView.xaml
U    win/CS/HandBrakeWPF/Helpers/PictureSize.cs
U    win/CS/HandBrakeWPF/ViewModels/PictureSettingsViewModel.cs
Updated to revision 5650.
 *    working copy: /usr/portage/distfiles/svn-src/handbrake/trunk

>>> Source unpacked in /var/tmp/portage/media-video/handbrake-9999/work
>>> Preparing source in /var/tmp/portage/media-video/handbrake-9999/work/handbrake-9999 ...
 * Applying handbrake-9999-expand-MK_SUBTITLE_PGS.patch ...                                                                                    [ ok ]
 * Applying handbrake-9999-fix-compilation-with-mp4v2-v1.9.1.patch ...                                                                         [ ok ]
 * Applying handbrake-9999-remove-dvdnav-dup.patch ...                                                                                         [ ok ]
 * Applying handbrake-9999-remove-faac-dependency.patch ...

 * Failed Patch: handbrake-9999-remove-faac-dependency.patch !
 *  ( /usr/portage/media-video/handbrake/files/handbrake-9999-remove-faac-dependency.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/media-video/handbrake-9999/temp/handbrake-9999-remove-faac-dependency.patch.out

 * ERROR: media-video/handbrake-9999 failed (prepare phase):
 *   Failed Patch: handbrake-9999-remove-faac-dependency.patch!
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 3876:  Called epatch '/usr/portage/media-video/handbrake/files/handbrake-9999-remove-faac-dependency.patch'
 *   environment, line 1940:  Called die
 * The specific snippet of code:
 *               die "Failed Patch: ${patchname}!";
 *
 * If you need support, post the output of `emerge --info '=media-video/handbrake-9999'`,
 * the complete build log and the output of `emerge -pqv '=media-video/handbrake-9999'`.
 * The complete build log is located at '/var/tmp/portage/media-video/handbrake-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/handbrake-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/media-video/handbrake-9999/work/handbrake-9999'
 * S: '/var/tmp/portage/media-video/handbrake-9999/work/handbrake-9999'

_________________
http://www.jaynorth.net
http://www.blgc.org
I build it, they will come.
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1546

PostPosted: Mon Jul 15, 2013 10:06 am    Post subject: Reply with quote

jazernorth wrote:
Any ideas on the fix?


Yeah, saw this earlier as well; you could attempt to drop the patch and add the faac dependency, but I'm not so sure how well that will work out. The patch just needs to be checked and updated.

If I don't get it working today I'll look at this by August; I also need to set up something that automatically tests 9999 versions for packages I maintain daily.
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1546

PostPosted: Mon Jul 15, 2013 3:03 pm    Post subject: Reply with quote

Fixed the patch, although it might be unnecessary to use that patch due to --disable-faac; I can't determine that, because 9999 currently fails to build for some other reason I haven't figured out yet.

Quote:
+ 15 Jul 2013; Tom Wijsman <TomWij@gentoo.org>
+ +files/handbrake-0.9.9-remove-faac-dependency.patch,
+ -handbrake-0.9.9_pre5441-r1.ebuild,
+ files/handbrake-9999-remove-faac-dependency.patch, handbrake-0.9.9.ebuild,
+ handbrake-9999.ebuild:
+ Fix faac dependency removal patch for handbrake-9999, currently it still fails
+ to build due to a yasm based cpuid detection they introduced that doesn't
+ appear to work; also heavily documented that ebuild with TODOs that would be
+ nice to have for the upcoming release. Fixed up src_configure a bit. Removed
+ old snapshot version 0.9.9_pre5441-r1.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum