Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Removing wpa_supplicant
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Silent-Hunter
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2013
Posts: 76

PostPosted: Fri Jul 12, 2013 11:00 pm    Post subject: Removing wpa_supplicant Reply with quote

I don't know why I have it installed. I use wicd, not wpa_supplicant. wpa_supplicant refuses to start because it can't find its configuration file, and as a result, rpcbind doesn't start either. Unmerging wpa_supplicant makes the wifi not work. Can I make some kind of dummy wpa_supplicant.conf so it doesn't complain, but doesn't use wpa_supplicant instead of wicd?
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4635
Location: Saint Amant, Acadiana

PostPosted: Fri Jul 12, 2013 11:18 pm    Post subject: Reply with quote

You need wpa_supplicant to connect to secured networks, wicd is not a replacement of wpa_supplicant.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Silent-Hunter
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2013
Posts: 76

PostPosted: Sat Jul 13, 2013 1:39 am    Post subject: Reply with quote

Oh. Well, I figured it out. I had net.wlp3s0 in the default runlevel. That was calling wpa_supplicant at boot, where it would complain about lack of wpa_supplicant.conf. I assume it's called by wicd then?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum