Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Strange graphic bug + strange Xorg warning
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
alex6
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2011
Posts: 139

PostPosted: Wed Jul 10, 2013 10:07 pm    Post subject: Strange graphic bug + strange Xorg warning Reply with quote

I have a strange problem with any DE : when I move a window, it's like tearing, like if the borders were but like if there was something like broken anti-aliasing...And scrolling on a page with text (like here on firefox) make the text like liquid...Very hard to describe.
I tried the two 319 nvidia drivers but still have the same problem.Also tried thing about adding anti-aliasing to my DE and using eselect fontconfig to activate 10-autohint.conf but it didn't help...
Currently using kernel-3.8.13

In my Xorg.0.log, there is this strange warning :

Quote:
(WW) Unresolved symbol: fbGetGCPrivateKey


Is that only due to the fact I don't use a framebuffer (like uvesafb), or is it something else ?

I had the same kernel/drivers when I was on 32 bit gentoo (now I'm on a 64 bit one) but didn't have that problem


Here is the complete Xorg log : http://bpaste.net/show/113539/


Last edited by alex6 on Thu Jul 11, 2013 9:58 am; edited 1 time in total
Back to top
View user's profile Send private message
alex6
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2011
Posts: 139

PostPosted: Thu Jul 11, 2013 9:55 am    Post subject: Reply with quote

Switched to nvidia-drivers 325.08, problem is still there.

For a better description of the problem : when I move a window, even slowly, if this is the border of a window :

|
|
|
|
|
|
|
|

it becomes like (cut in several parts) :

|
|
|
. |
. |
. |
|
|
|
|

When the window stop moving it becomes normal again
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Thu Jul 11, 2013 11:54 am    Post subject: Reply with quote

As a wild guess:

Code:
nvidia-settings -a AllowFlipping=0


On the PCs I've used, Nvidia's flipping is unstable - can hang xorg - I'm surprised it's on by default.

Another thing to try is compton to force vsync on. E.g.:
Code:
nice -n -1 /usr/bin/compton --backend glx --vsync opengl-swc --unredir-if-possible --glx-swap-method exchange -m 0.94 --inactive-dim 0.09

_________________
Improve your font rendering and ALSA sound
Back to top
View user's profile Send private message
alex6
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2011
Posts: 139

PostPosted: Thu Jul 11, 2013 12:11 pm    Post subject: Reply with quote

PaulBredbury wrote:
As a wild guess:
nice -n -1 /usr/bin/compton --backend glx --vsync opengl-swc --unredir-if-possible --glx-swap-method exchange -m 0.94 --inactive-dim 0.09]


That retuns me (with newer version : 0_pre20121114) :
Code:
compton: unrecognized option '--backend'
compton (development version)


Same result with older version : 0_pre20120330
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Thu Jul 11, 2013 12:36 pm    Post subject: Reply with quote

Year 2012?? Do a git checkout.
Back to top
View user's profile Send private message
alex6
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2011
Posts: 139

PostPosted: Fri Jul 12, 2013 10:53 am    Post subject: Reply with quote

Installed version from git (9999)

Code:
nice -n -1 /usr/bin/compton --backend glx --vsync opengl-swc --unredir-if-possible --glx-swap-method exchange -m 0.94 --inactive-dim 0.09


Quote:
restack_win(0x00807715, 0x00807561): Failed to found new above window.
restack_win(0x00807715, 0x00807561): Failed to found new above window.
[ 0.17 ] error 3 (BadWindow) request 2 minor 0 serial 827 ("BadWindow (invalid Window parameter)")
[ 0.17 ] error 3 (BadWindow) request 2 minor 0 serial 902 ("BadWindow (invalid Window parameter)")
[ 0.18 ] error 9 (BadDrawable) request 14 minor 0 serial 970 ("BadDrawable (invalid Pixmap or Window parameter)")
glx_bind_pixmap(0x028000c2): Failed to query Pixmap info.
win_paint_win(0x008075ac): Failed to bind texture. Expect troubles.
win_paint_win(0x008075ac): Missing painting data. This is a bad sign.
[ 0.23 ] error 3 (BadWindow) request 2 minor 0 serial 1243 ("BadWindow (invalid Window parameter)")
[ 0.23 ] error 3 (BadWindow) request 2 minor 0 serial 1267 ("BadWindow (invalid Window parameter)")
[ 0.24 ] error 4 (BadPixmap) request 54 minor 0 serial 1319 ("BadPixmap (invalid Pixmap parameter)")



that actually correct that thing with broken borders of windows when moving them ! That also remove the green borders bug when scrolling when scrolling on a page with a flash video ! Also, the text on pages stop flickering when scrolling down/up ! what a nice program ! but everything is kind of blue and gamma changed...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum