Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xbmc: where is MythTV plugin?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
sws
n00b
n00b


Joined: 08 Sep 2009
Posts: 29

PostPosted: Thu May 09, 2013 4:53 am    Post subject: xbmc: where is MythTV plugin? Reply with quote

Hi,

after updating MythTV to 0.26 my mythfrontend is somehow corrupted. There is no more audio playing and escaping a menu results in a black screen. Well ...

So I tried to switch to xbmc as a new frontend for MythTV.

Emerging xbmc with useflag "pvr" doesn't do the job. I cannot see the plugin in xbmc. Also there is no menu button for "Get Addons".
Also emerging xbmc-addon-xvdr didn't help.

Then I tried to build the plugin from github https://github.com/fetzerch/xbmc-pvr-addons. I configured with
Code:
./configure --prefix=/usr/share/xbmc --enable-addons-with-dependencies=/usr/lib64/libmysqlclient --enable-addons-with-dependencies=/usr/include/boost
After that i did a
Code:
make zip
and tried to import it as a ZIP file but it says that there are dependencies missing.

At last I followed http://forums.gentoo.org/viewtopic-t-926936-highlight-xbmc+mythtv.html in the forum, but it didn't work out also.

So I am stuck again. :evil:

Can anyone help me to get a hand on the connection between xbmc and MythTV backend, please.

MythTV:
Code:
Installed versions:  0.26.0_p20130419(12:26:32 04.05.2013)(alsa dvb dvd fftw hls lirc python theora vorbis xml xvid -altivec -autostart -bluray -cec -crystalhd -debug -egl -ieee1394 -jack -lcd -libass -perl -pulseaudio -raop -vaapi -vdpau -xmltv INPUT_DEVICES="-joystick")


XBMC:
Code:
Installed versions:  12.1(06:28:27 09.05.2013)(X alsa java joystick midi mysql opengl projectm pvr rsxs samba sdl sse sse2 udev upnp usb xrandr -airplay -altivec -avahi -bluetooth -bluray -caps -cec -css -debug -gles -goom -neon -nfs -profile -pulseaudio -rtmp -sftp -vaapi -vdpau -webserver)


Greets Sebastian
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2646

PostPosted: Thu May 09, 2013 12:44 pm    Post subject: Reply with quote

I recently tried XBMC again, after having tried and given up a few years ago. (I believe I first used it at XBMC-9.x, and when it upgraded to XBMC-10.x I had build problems, and gave up.) In XBMC-9.x I found the MythTV plugin to be "too flat" when displaying my recorded video.

In XBMC-12 I "somehow" found and installed the MythTV plugin, but then saw that it was for mythtv-0.25.0 when I was (and still am) running mythtv-0.25.3, and indeed it didn't talk to my server. I don't remember if I've gotten around to removing XBMC or not, yet. Nor do I remember exactly how I installed the plugin, just that it wasn't going to work for me because of the vintage mismatch.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
sws
n00b
n00b


Joined: 08 Sep 2009
Posts: 29

PostPosted: Thu May 09, 2013 1:20 pm    Post subject: Reply with quote

Yes, it seems to be quite a mess with the different versions of xbmc and MythTV. So I had to accept that MythBox addon in xbmc does not cope with MythTV 0.26. Got that after inserting the credentials for the MythTV server for about 20 times! :twisted: Also the other possible ways to connect xbmc to MythTV are either too old or not supporting the current version. It's kind of a puzzle with moving targets.

I didn't want to mention it first, but I installed xbmc on my notebook. My wife also uses this notebook and "forbid" me to install Linux, so it runs on MS Windows (unfortunately). Installation was three clicks and all plugins were where they ought to be. Connecting to my MythTV server was a piece of a cake, hmmm ...

So there MUST be a way to get this running on Gentoo, right?
Back to top
View user's profile Send private message
sws
n00b
n00b


Joined: 08 Sep 2009
Posts: 29

PostPosted: Mon May 13, 2013 1:44 pm    Post subject: Reply with quote

After switching from pure alsa to pulseaudio Mythfrontend is working again.

Still I do not find the pvr plugin for MythTV in xbmc. I emerged xbmc for several times now including the explicit use of USE="pvr" although I have it written in /etc/portage/package.use already.
I really wonder where this plugin went? :?: :?: :?:

Greets,
Sebastian
Back to top
View user's profile Send private message
daktak
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2002
Posts: 141
Location: Melbourne, Victoria

PostPosted: Fri Jul 12, 2013 4:52 am    Post subject: Reply with quote

Try this ebulid https://bugs.gentoo.org/show_bug.cgi?id=455204
or
https://bugs.gentoo.org/show_bug.cgi?id=449996
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum