Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] where to get libwebkitgtk-1.0.so.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
DZoom
n00b
n00b


Joined: 13 Jun 2010
Posts: 48

PostPosted: Thu Jul 11, 2013 7:59 am    Post subject: [SOLVED] where to get libwebkitgtk-1.0.so.0 Reply with quote

Hi,

I want to use rainlendar with my current gentoo installation.
i tried to use the one from the bgo-overlay, but the ebuild seems to be broke (0kB download).
so i switched to the Rainlendar 2.12 beta 132 from here: http://www.rainlendar.net/cms/index.php?option=com_kunena&Itemid=42&func=view&catid=7&id=19573#19573
after unpacking to /usr/lib/rainlendar2 and trying to start, the only problem left seems to be the missing lib
Code:
libwebkitgtk-1.0.so.0

but the only libwebkit library available in portage seems to be
Code:
libwebkitgtk-3.0.so

Quote:
miPC ~ # ls -l /usr/lib/libwebkitgtk*
lrwxrwxrwx 1 root root 26 Jul 11 09:21 /usr/lib/libwebkitgtk-3.0.so -> libwebkitgtk-3.0.so.0.13.4
lrwxrwxrwx 1 root root 26 Jul 11 09:21 /usr/lib/libwebkitgtk-3.0.so.0 -> libwebkitgtk-3.0.so.0.13.4
-rwxr-xr-x 1 root root 25856168 Jul 11 09:21 /usr/lib/libwebkitgtk-3.0.so.0.13.4

can anyone tell me, where to get that specific version of the lib?

thanks


Last edited by DZoom on Thu Jul 11, 2013 8:23 am; edited 1 time in total
Back to top
View user's profile Send private message
Pes88
Apprentice
Apprentice


Joined: 06 May 2009
Posts: 243

PostPosted: Thu Jul 11, 2013 8:10 am    Post subject: Reply with quote

HI,

Usually libraries are back-compatible, before trying to install an old version of a library try to use the library you have already installed on your machine.
You can do this by creating a symbol link between the library you have already installed and the version you need. For instance :
Code:

ln -s libwebkitgtk-3.0.so.0.13.4  libwebkitgtk-1.0.so.0

_________________
Pygoscelis papua, chiamato Gentoo dagli abitanti delle isole Falkland/Malvinas, noto per essere il pinguino più veloce!!! XD
Back to top
View user's profile Send private message
DZoom
n00b
n00b


Joined: 13 Jun 2010
Posts: 48

PostPosted: Thu Jul 11, 2013 8:23 am    Post subject: Reply with quote

Pes88 wrote:
HI,

Usually libraries are back-compatible, before trying to install an old version of a library try to use the library you have already installed on your machine.
You can do this by creating a symbol link between the library you have already installed and the version you need. For instance :
Code:

ln -s libwebkitgtk-3.0.so.0.13.4  libwebkitgtk-1.0.so.0


thought this was not generally true due to interface changes between releases (e. g. gtk 3x, gtk 2x)?
anyway, in this case it worked. just 5 other libs that can not be found, even though they are present -.-
Back to top
View user's profile Send private message
Pes88
Apprentice
Apprentice


Joined: 06 May 2009
Posts: 243

PostPosted: Thu Jul 11, 2013 11:05 am    Post subject: Reply with quote

Quote:
thought this was not generally true due to interface changes between releases (e. g. gtk 3x, gtk 2x)?


Yes, you 're right for major releases ( i.e. gtk2 to gtk3 ) but for small releases ( from 2.x to 2.y) the interface usually is the same.
Quote:

anyway, in this case it worked
.

However, you cannot be sure that this method worked out until you compile the code.


What are those libraries?
Have you tried to look them up in the overlays with eix -R ?
_________________
Pygoscelis papua, chiamato Gentoo dagli abitanti delle isole Falkland/Malvinas, noto per essere il pinguino più veloce!!! XD
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Thu Jul 11, 2013 1:26 pm    Post subject: Reply with quote

webkit 2.0.3, when compiled with --with-gtk=2.0, provides /usr/lib/libwebkitgtk-1.0.so.0 -> libwebkitgtk-1.0.so.0.18.8

So it's nicely backwards-compatible, in complete contrast to the usual let's-break-API-because-we-can Linux library version mess :x
Back to top
View user's profile Send private message
DZoom
n00b
n00b


Joined: 13 Jun 2010
Posts: 48

PostPosted: Fri Oct 18, 2013 10:11 am    Post subject: Reply with quote

just to get it right: to compile it with gtk-2 support, i have to compile it by hand; besides portage?
or how do i pass that gtk2-usage- option to the package for emerge?
Back to top
View user's profile Send private message
Freeky
Tux's lil' helper
Tux's lil' helper


Joined: 11 Mar 2011
Posts: 80
Location: Novosibirsk, Russia

PostPosted: Fri Oct 18, 2013 5:04 pm    Post subject: Reply with quote

DZoom wrote:
just to get it right: to compile it with gtk-2 support, i have to compile it by hand; besides portage?
or how do i pass that gtk2-usage- option to the package for emerge?


I think installing net-libs/webkit-gtk:2 will be enough for you.
Back to top
View user's profile Send private message
DZoom
n00b
n00b


Joined: 13 Jun 2010
Posts: 48

PostPosted: Mon Oct 21, 2013 6:12 pm    Post subject: Reply with quote

Freeky wrote:
DZoom wrote:
just to get it right: to compile it with gtk-2 support, i have to compile it by hand; besides portage?
or how do i pass that gtk2-usage- option to the package for emerge?


I think installing net-libs/webkit-gtk:2 will be enough for you.


yes, that finally did the trick!
thank you
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum