Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Boot endet in Konsole
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 882
Location: Eppingen, Germany

PostPosted: Wed Jul 10, 2013 7:27 pm    Post subject: [gelöst] Boot endet in Konsole Reply with quote

Ich hatte ein System mit systemd LVM, das lief bis vor 2 Tagen. Nach einem Update kam ich beim nächsten Start nur in die Konsole. Der erste lesbare Fehler war der fehlgeschlagene LVM-Start. Vorher kamen auch Fehlermeldungen, die aber zu schnell über den Bildschirm liefen.

Vom Life-System mit chroot habe ich gestern nach dem Gentoo-Wiki systemd eingespielt und revdep-rebuild laufen lassen - ohne Erfolg.

Da LVM & metalog nicht starten habe ich auch keine Fehler-Logs...

Die LVM-Partitionen kann ich mit
Code:
vgchange -a z group
aktivieren. Wie kann ich mir die aktiven Partitionen anzeigen lassen?

Wie bekomme ich die Kiste zum interaktiven Booten? Er zeigt immer "press i" - aber das klappt nicht...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Sat Aug 10, 2013 8:29 am; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3983
Location: Irgendwo im Nirgendwo

PostPosted: Wed Jul 10, 2013 8:27 pm    Post subject: Reply with quote

Verwendest du genkernel?
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 882
Location: Eppingen, Germany

PostPosted: Wed Jul 10, 2013 8:34 pm    Post subject: Reply with quote

nein, und der Kernel ist unver'ndert geblieben....

ich tippe auf udev oder so.


zwischenzeitlich weiss ich, dass der erste Fehler von libudev.so.1 verursacht wurde. das geoert wohl zu udev. Und das brauche ich eigentlich nicht mehr, da ich systemd habe...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4124

PostPosted: Thu Jul 11, 2013 6:13 am    Post subject: Reply with quote

uhai wrote:
zwischenzeitlich weiss ich, dass der erste Fehler von libudev.so.1 verursacht wurde. das geoert wohl zu udev. Und das brauche ich eigentlich nicht mehr, da ich systemd habe...

Hast du dir mal ansgeschaut, welche dateien das systemd ebuild im system installiert?
Denn systemd benötigt auch udev. Da udev im systemd source paket integriert ist, benötigst du das separate udev ebuild nicht...
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 882
Location: Eppingen, Germany

PostPosted: Thu Jul 11, 2013 7:21 pm    Post subject: Reply with quote

Code:
euse -i udev
global use flags (searching: udev)
************************************************************
no matching entries found

local use flags (searching: udev)
************************************************************
[-    ] udev (media-sound/pulseaudio):
Use sys-fs/udev for autodiscovery of sound devices; this replaces the deprecated sys-apps/hal autodiscovery code.

[-    ] udev (media-sound/rhythmbox):
Enable hardware detection via sys-fs/udev replacing the deprecated sys-apps/hal code.

[-    ] udev (net-misc/connman):
Enable udev support.

[-    ] udev (net-misc/ofono):
Use sys-fs/udev for modem detection.


Code:
 eix -I udev
[I] sys-apps/udevil
     Available versions:  0.3.6 ~0.4.0 0.4.1 {{systemd}}
     Installed versions:  0.4.1(22:30:11 09.07.2013)(systemd)
     Homepage:            http://ignorantguru.github.com/udevil/
     Description:         mount and unmount removable devices without a password

[I] sys-fs/udev-init-scripts
     Available versions:  23^t 25^t 26^t **9999^t
     Installed versions:  26^t(22:29:49 09.07.2013)
     Homepage:            http://www.gentoo.org
     Description:         udev startup scripts for openrc

[I] virtual/udev
     Available versions:  197-r3 ~200 {{gudev hwdb introspection keymap +kmod selinux static-libs}}
     Installed versions:  197-r3(22:29:39 09.07.2013)(gudev hwdb introspection keymap kmod -selinux -static-libs)
     Description:         Virtual to select between sys-fs/udev and sys-fs/eudev



Koennte das das Problem sein?

Code:

revdep-rebuild -p
 * Configuring search environment for revdep-rebuild
 * Environment mismatch from previous run, deleting temporary files...

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 1% ]  *   broken /lib64/libgudev-1.0.so.0.1.0 (requires libudev.so.0)
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *  !!! /lib64/libgudev-1.0.so.0.1.0 not owned by any package is broken !!!
 *   /lib64/libgudev-1.0.so.0.1.0 -> (none)
 * Generated new 4_raw.rr and 4_owners.rr
 * Found some broken files, but none of them were associated with known packages
 * Unable to proceed with automatic repairs.
 * The broken files are listed in 4_owners.rr


Wie kann die Lösung aussehen?
equery belongs libgudev-1.0 spuckt systemd als Package aus. Nach einem ermge systemd bringt aber ein revdep-rebuild den gleichen Fehler wie oben wieder... ???


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4124

PostPosted: Thu Jul 11, 2013 8:49 pm    Post subject: Reply with quote

was sagt ein ls -l /usr/lib64/libgudev*
bei mir ist die datei libgudev.so.1.0.so.0.1.3 installiert. Kann gut sein, dass die problematische lib ein überbleibsel eines updates ist (portage löscht nicht eine lib, falls diese noch verwendet wird -> steht meist auch in der post message drinn wenn dieser fall auftritt)
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 882
Location: Eppingen, Germany

PostPosted: Thu Jul 11, 2013 8:53 pm    Post subject: Reply with quote

Code:
(chroot) livecd / # ls -l /usr/lib64/libgudev*
lrwxrwxrwx 1 root root    21 11. Jul 21:51 /usr/lib64/libgudev-1.0.so -> libgudev-1.0.so.0.1.3
lrwxrwxrwx 1 root root    21 11. Jul 21:51 /usr/lib64/libgudev-1.0.so.0 -> libgudev-1.0.so.0.1.3
-rwxr-xr-x 1 root root 42872 11. Jul 21:51 /usr/lib64/libgudev-1.0.so.0.1.3


Gesehen habe ich keine post message, vielleicht übersehen?..

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2306
Location: Germany

PostPosted: Thu Jul 11, 2013 10:51 pm    Post subject: Reply with quote

Hm, /lib64/libgudev-1.0.so.0.1.0 stammt noch aus den alten <=udev-171 Versionen (oder auch eudev).
Ist das bei revdep-rebuild eventuell noch ein veralteter Cache Eintrag, der immer wieder (erfolglos) abgearbeitet werden soll?
Schau doch mal was ein
Code:
revdep-rebuild -i
dazu sagt.

Und bezüglich LVM mit systemd wirst du dich aktuell vermutlich noch mit bug 453594 auseinandersetzen müssen.

/edit:
uhai wrote:
Wie bekomme ich die Kiste zum interaktiven Booten? Er zeigt immer "press i" - aber das klappt nicht...
Hm, das stammt doch aber vermutlich von OpenRC?
Bist du dir sicher das dein System mit systemd gebotet wird? Magst du dazu mal die kernel Zeile aus dem Bootloader mit posten?
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 882
Location: Eppingen, Germany

PostPosted: Fri Jul 12, 2013 4:41 am    Post subject: Reply with quote

@Josef95:
Code:
revdep-rebuild -pi
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 1% ]  *   broken /lib64/libgudev-1.0.so.0.1.0 (requires libudev.so.0)
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *  !!! /lib64/libgudev-1.0.so.0.1.0 not owned by any package is broken !!!
 *   /lib64/libgudev-1.0.so.0.1.0 -> (none)
 * Generated new 4_raw.rr and 4_owners.rr
 * Found some broken files, but none of them were associated with known packages
 * Unable to proceed with automatic repairs.
 * The broken files are listed in 4_owners.rr


Habe ich schon probiert, ist dasselbe...

Der grub.conf - Eintrag:
Code:
title Gentoo 3.8.13
root(hd0,0)
kernel /boot/kernel-3.8.13-gentoo root=/dev/sda3


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1063
Location: Schweiz

PostPosted: Fri Jul 12, 2013 1:07 pm    Post subject: Reply with quote

uhai wrote:
Der grub.conf - Eintrag:
Code:
title Gentoo 3.8.13
root(hd0,0)
kernel /boot/kernel-3.8.13-gentoo root=/dev/sda3

Da fehlt der Parameter "init=/usr/lib/systemd/systemd" würde ich mal sagen, zumindest dann wenn der Kernel mit systemd booten soll.
Code:
title Gentoo 3.8.13
root(hd0,0)
kernel /boot/kernel-3.8.13-gentoo root=/dev/sda3 init=/usr/lib/systemd/systemd

_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2306
Location: Germany

PostPosted: Sat Jul 13, 2013 9:59 am    Post subject: Reply with quote

uhai,
auch deine "euse -i udev" Ausgabe ist ein wenig ungewöhnlich - demnach hast du scheinbar USE=-udev global gesetzt. Wenn dem so ist, ist das so wirklich beabsichtigt? (In den meisten Fällen wird man auf die udev Unterstützung nicht verzichten wollen)
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 882
Location: Eppingen, Germany

PostPosted: Sun Jul 14, 2013 12:01 pm    Post subject: Reply with quote

Anscheinend habe ich die Umstellung zu systemd gründlich versaut, oder?

Kann ich in der make.conf USE= udev systemd kombinieren? Den bug bzgl lvm muss ich jedenfalls auch berückscihtigen, oder?

Vielleicht wäre es einfacher bei udev zu bleiben?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4124

PostPosted: Sun Jul 14, 2013 12:53 pm    Post subject: Reply with quote

uhai wrote:
Anscheinend habe ich die Umstellung zu systemd gründlich versaut, oder?

Kann ich in der make.conf USE= udev systemd kombinieren? Den bug bzgl lvm muss ich jedenfalls auch berückscihtigen, oder?

Vielleicht wäre es einfacher bei udev zu bleiben?

uhai

Wenn du nur die udev features brauchst dann ja ;). Aber durch eine Umstellung des init-systems auf systemd musst du nicht die udev Unsterstützung global deaktivieren, da systemd selbst udev mitbringt. Und das udev ebuild den udev part nur aus dem systemd archiv entpackt und baut.
AFAIK ist das systemd useflag nur dafür da um die systemd unterstützung in einem programm zu aktivieren/deaktivieren. Aber das hat mit udev selbst nichts zu tun.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 882
Location: Eppingen, Germany

PostPosted: Sun Jul 14, 2013 1:16 pm    Post subject: Reply with quote

D.h. mit USE=systemd bekomme ich virtual/udev?

Dann wräe das bei mir ja richtig...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4124

PostPosted: Sun Jul 14, 2013 1:36 pm    Post subject: Reply with quote

uhai wrote:
D.h. mit USE=systemd bekomme ich virtual/udev?

Dann wräe das bei mir ja richtig...

uhai

Nein nicht durch das systemd useflag. Sondern das systemd paket erfüllt die Bedingung für virtual/udev ;)
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 882
Location: Eppingen, Germany

PostPosted: Sun Jul 14, 2013 3:23 pm    Post subject: Reply with quote

Also kann ich USE = systemd udev kombinieren?

aus dem englsichen Systemd-Wiki werde ich nicht wirklich schlau.... Ich habe systemd immer für einen Ersatz von udev gehalten. Ist es aber nicht, oder?
uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2306
Location: Germany

PostPosted: Sun Jul 14, 2013 3:40 pm    Post subject: Reply with quote

uhai wrote:
Also kann ich USE = systemd udev kombinieren?
Ja.

Nutze zb auch die
Code:
euse -I udev
Ausgabe, darin ist recht schön zu sehen welche installierten Pakete das udev USE-Flag nutzen.
Und ob das udev nun aus sys-apps/systemd oder aus dem separaten Paket sys-fs/udev stammt ist ziemlich wurscht. Bezüglich udev stellen beide die selben Funktionen bereit.
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4124

PostPosted: Sun Jul 14, 2013 3:40 pm    Post subject: Reply with quote

uhai wrote:
Also kann ich USE = systemd udev kombinieren?

aus dem englsichen Systemd-Wiki werde ich nicht wirklich schlau.... Ich habe systemd immer für einen Ersatz von udev gehalten. Ist es aber nicht, oder?
uhai


ja kannst du kombinieren. systemd komplett ersetzt nicht udev. systemd hat nur udev im source integriert. -> udev ist ein teil der systemd distribution. Unter gentoo kann das udev paket und das systemd paket nicht gleichzeitig installiert sein, da systemd selbst udev mitbringt. Und wie ich schon sagte, das udev ebuild das systemd source archiv herrunterläd und daraus nur udev baut...
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 882
Location: Eppingen, Germany

PostPosted: Sun Jul 14, 2013 9:24 pm    Post subject: Reply with quote

ok, jetzt zum bug 453594, den Josef.95 erwähnt hat. Wenn ich die Posts richtig verstnaden habe, gibt es einen Overlay systemd-love. Den bekomme ich aber nicht rein mit layman.

Habe ich wieder etwas missverstanden?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2306
Location: Germany

PostPosted: Sun Jul 14, 2013 9:55 pm    Post subject: Reply with quote

Hm, sofern dein layman mit "git"USE-Flag gebaut wurde sollte es eigentlich verfügbar sein.
Code:
layman -L | grep systemd-love
 * systemd-love              [Git       ] (git://github.com/Sabayon/systemd-...)

Ansonsten kannst du dir das Paket aber auch aus https://github.com/Sabayon/systemd-love/tree/master/sys-fs/lvm2
pflücken, und in ein lokales Overlay packen, und dann testen.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 882
Location: Eppingen, Germany

PostPosted: Tue Jul 16, 2013 4:57 am    Post subject: Reply with quote

Mit layman hats jetzt geklappt. Wenn ich lvm2 ansehe, habe ich dort USE=udev gesetzt. Das muss raus, oder?

Code:
emerge -avt lvm2

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R    ] sys-fs/lvm2-2.02.97-r1  USE="lvm1 readline thin udev (-clvm) (-cman) (-selinux) -static -static-libs" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2306
Location: Germany

PostPosted: Tue Jul 16, 2013 12:04 pm    Post subject: Reply with quote

uhai wrote:
Mit layman hats jetzt geklappt. Wenn ich lvm2 ansehe, habe ich dort USE=udev gesetzt. Das muss raus, oder?

Code:
emerge -avt lvm2

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R    ] sys-fs/lvm2-2.02.97-r1  USE="lvm1 readline thin udev (-clvm) (-cman) (-selinux) -static -static-libs" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


uhai

Hehe neiin, auf den udev Support wirst du idR nicht wirklich verzichten wollen :)
Bei Unsicherheit nutze am besten die meist guten Defaults.
Vermutlich ist dir noch nicht wirklich ganz klar, das mit dem USE=udev nicht zwingend das Paket sys-fs/udev installiert wird (das sich mit systemd beißt, da beide ein udev bereitstellen).
Schaue am besten mal ins Ebuild:
Beispiel:
/usr/portage/sys-fs/lvm2/lvm2-2.02.98.ebuild wrote:
Code:
IUSE="readline static static-libs clvm cman +lvm1 selinux +udev +thin"
Das "+udev" ist ein default Use-Flag, das heißt in etwa: sofern es nicht explizit von dir in der make. conf oder package use deaktiviert wird, baue das Paket bitte mit udev Supoort.
Weiter unten im Ebuild:
Code:
 udev? ( virtual/udev[static-libs?] )"
Hier wird dann geprüft: soll mit USE=udev gebaut, dann installiere das Paket virtual/udev
damit ist die Abhängigkeit auf udev soweit erst mal erfüllt.
Nun schaue ins virtual/udev Ebuild
/usr/portage/virtual/udev/udev-197-r3.ebuild wrote:
Code:
DEPEND=""
RDEPEND="|| ( >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?]
        >=sys-apps/systemd-198-r5[gudev?,introspection?,keymap(+)?,kmod?,selinux?,static-libs(-)?]
        kmod? ( >=sys-fs/eudev-1_beta2-r2[modutils,gudev?,hwdb?,introspection?,keymap?,selinux?,static-libs?] )
        !kmod? ( >=sys-fs/eudev-1_beta2-r2[gudev?,hwdb?,introspection?,keymap?,selinux?,static-libs?] )
        )"
Sprich mit einem dieser drei Pakete, sys-fs/udev sys-apps/systemd oder sys-fs/eudev
wird dann letztendlich eine der drei möglichen udev Varianten gefordert - und das kann eben auch systemd sein (je nachdem was ser Admin halt bevorzugt).
Fazit: Wenn du systemd installiert hast, nutzen Pakete die mit USE=udev gebaut werden letztendlich das in systemd enthaltene udev.
Es gibt also keinen Grund auf udev Support zu verzichten nur weil man systemd installiert hat :)

Und noch kurz zu dem lvm2 Paket: Achte bitte darauf das passende Ebuild zu installieren (das mit dem Patch).

Viel Erfolg
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 882
Location: Eppingen, Germany

PostPosted: Tue Jul 16, 2013 6:57 pm    Post subject: Reply with quote

@Josef.95:
Woran erkenne ich das richtige? Ich würde jetzt das hier nehmen:

Code:
eix lvm2
[I] sys-fs/lvm2
     Available versions:  ~2.02.95-r4 ~2.02.97 2.02.97-r1 ~2.02.98 ~2.02.98-r3[1] {{clvm cman +lvm1 readline selinux static static-libs +thin +udev}}
     Installed versions:  2.02.97-r1(22:03:07 29.01.2013)(lvm1 readline thin udev -clvm -cman -selinux -static -static-libs)
     Homepage:            http://sources.redhat.com/lvm2/
     Description:         User-land utilities for LVM2 (device-mapper) software.

[1] "systemd-love" /var/lib/layman/systemd-love
(chroot) livecd / # emerge -avt lvm2

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R    ] sys-fs/lvm2-2.02.97-r1  USE="lvm1 readline thin udev (-clvm) (-cman) (-selinux) -static -static-libs" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] n



Das kommt doch aus dem Overlay systemd-love, oder? Also mit patch...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4124

PostPosted: Tue Jul 16, 2013 7:22 pm    Post subject: Reply with quote

uhai wrote:
@Josef.95:
Woran erkenne ich das richtige? Ich würde jetzt das hier nehmen:

Code:
eix lvm2
[I] sys-fs/lvm2
     Available versions:  ~2.02.95-r4 ~2.02.97 2.02.97-r1 ~2.02.98 ~2.02.98-r3[1] {{clvm cman +lvm1 readline selinux static static-libs +thin +udev}}
     Installed versions:  2.02.97-r1(22:03:07 29.01.2013)(lvm1 readline thin udev -clvm -cman -selinux -static -static-libs)
     Homepage:            http://sources.redhat.com/lvm2/
     Description:         User-land utilities for LVM2 (device-mapper) software.

[1] "systemd-love" /var/lib/layman/systemd-love
(chroot) livecd / # emerge -avt lvm2

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R    ] sys-fs/lvm2-2.02.97-r1  USE="lvm1 readline thin udev (-clvm) (-cman) (-selinux) -static -static-libs" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] n



Das kommt doch aus dem Overlay systemd-love, oder? Also mit patch...

uhai

Nein kommt es nicht, die version aus dem overlay ist 2.02.98-r3 wie auch in der Ausgabe von eix zu sehen (beachte das [<zahl>]) hinter der version und eine entsprechende Zeile am schluss der Ausgabe von eix)
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 882
Location: Eppingen, Germany

PostPosted: Tue Jul 16, 2013 9:31 pm    Post subject: Reply with quote

~2.02.98-r3[1] -> die Tilde weist auf eine Maskierung hin, oder?

Mit den Details der Ausgaben sollte ich mich auch einmal auseinandersetzen....

Die [1] unten habe ich gesehen, aber nicht realisiert, dass oben eine [I] steht....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum