Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] nVidia Drivers, Kernel 3.10.0 Compat. [LAST POST]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
splurben
Apprentice
Apprentice


Joined: 03 Feb 2004
Posts: 176
Location: Augusta, Southwest Western Australia

PostPosted: Thu Jul 04, 2013 1:44 am    Post subject: [SOLVED] nVidia Drivers, Kernel 3.10.0 Compat. [LAST POST] Reply with quote

splurben wrote:
As of NVIDIA-DRIVERS-325.15, Kernels 3.10.* are supported and functioning on two systems on my bench.

New restriction of NVIDIA-DRIVERS is <3.11

Cheers


I have masked 3.10.0 and above because nVidia drivers 319.32 wouldn't install on the new kernel.

Today I got nVidia driver 325.08, I was wondering if it was 3.10 compatible, I've looked around three times now and I can't find a page that shows nVidia drivers versions in relation to kernels.

Does anyone have nVidia drivers on 3.10.* or know if there's a page somewhere that shows the compatibility matrix?

Cheers,

Kirk
_________________
--=>Like... Goodness had nothing to do with it.<=--


Last edited by splurben on Fri Aug 09, 2013 12:26 am; edited 2 times in total
Back to top
View user's profile Send private message
croutch
n00b
n00b


Joined: 04 Aug 2012
Posts: 31
Location: göteborg

PostPosted: Thu Jul 04, 2013 3:29 am    Post subject: Reply with quote

I mask nvidia 325.08 for now. You can install 319.32 if you check that thread ->> http://forums.gentoo.org/viewtopic-t-963230.html
Back to top
View user's profile Send private message
splurben
Apprentice
Apprentice


Joined: 03 Feb 2004
Posts: 176
Location: Augusta, Southwest Western Australia

PostPosted: Thu Jul 04, 2013 6:56 am    Post subject: not quite sure what that's about Reply with quote

croutch wrote:
I mask nvidia 325.08 for now. You can install 319.32 if you check that thread ->> http://forums.gentoo.org/viewtopic-t-963230.html


I'm already successfully using 325.08 just fine. I just want to know if I can use it with kernel 3.10.0. I'm currently using it with 3.9.8 with no issues.

When I tried the previous nVidia drivers in 3.10.0, the ebuild said it needed <3.10.0, I'm just wondering if 325.08 is okay for 3.10.0.

Kirk
_________________
--=>Like... Goodness had nothing to do with it.<=--
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1155

PostPosted: Thu Jul 04, 2013 10:47 am    Post subject: Reply with quote

I think it is not.
And thank you for the info running the new beta driver without issues ...
_________________
fun2gen2
Back to top
View user's profile Send private message
splurben
Apprentice
Apprentice


Joined: 03 Feb 2004
Posts: 176
Location: Augusta, Southwest Western Australia

PostPosted: Sat Jul 06, 2013 10:54 am    Post subject: You're welcome, also… Reply with quote

ulenrich wrote:
I think it is not.
And thank you for the info running the new beta driver without issues ...


…I took a stab in the dark in order to determine if the new driver was 'supposed' to work with Kernel 3.10 and…
Code:
bench6 nvidia-drivers # grep -i kernel nvidia-drivers-325.08.ebuild
returns
Code:

IUSE="acpi multilib kernel_FreeBSD kernel_linux pax_kernel +tools +X"
   kernel_linux? ( >=sys-libs/glibc-2.6.1 )
   kernel_linux? ( virtual/linux-sources )
   if use kernel_linux && kernel_is ge 3 10 ; then
      ewarn "Gentoo supports kernels which are supported by NVIDIA"
      ewarn "which are limited to the following kernels:"
      ewarn "<sys-kernel/gentoo-sources-3.10"
      ewarn "<sys-kernel/vanilla-sources-3.10"

…and as you surmised, it's not.

Cheers
_________________
--=>Like... Goodness had nothing to do with it.<=--
Back to top
View user's profile Send private message
st3f4n2006
n00b
n00b


Joined: 07 Jul 2013
Posts: 8

PostPosted: Sun Jul 07, 2013 6:05 pm    Post subject: Working Reply with quote

Hello,
The 325.08 is working with 3.10 kernel. If you follow the post here: http://forums.gentoo.org/viewtopic-t-963230.html (instructions from n00berry) and follow the instruction from user Robert_SoCal https://devtalk.nvidia.com/default/topic/549208/patch-for-325-08-on-linux-3-10/ :

....

copy patch "nvidia-drivers-linux-3.10.patch.txt" https://devtalk.nvidia.com/cmd/default/download-comment-attachment/58795/ instead of the one provided in the first link

Quote:

3) Open the patch program and change the following lines:

diff -ur -X - NVIDIA-Linux-x86_64-319.17-no-compat32.orig/kernel/nv-i2c.c NVIDIA-Linux-x86_64-319.17-no-compat32/kernel/nv-i2c.c
--- NVIDIA-Linux-x86_64-319.17-no-compat32.orig/kernel/nv-i2c.c 2013-04-26 00:22:30.000000000 -0400
+++ NVIDIA-Linux-x86_64-319.17-no-compat32/kernel/nv-i2c.c 2013-05-13 05:20:55.571981365 -0400

into:

diff -ur -X - NVIDIA-Linux-x86_64-325.08.orig/kernel/nv-i2c.c NVIDIA-Linux-x86_64-325.08/kernel/nv-i2c.c
--- NVIDIA-Linux-x86_64-325.08.orig/kernel/nv-i2c.c 2013-04-26 00:22:30.000000000 -0400
+++ NVIDIA-Linux-x86_64-325.08/kernel/nv-i2c.c 2013-05-13 05:20:55.571981365 -0400

4) Then perform the same action on these lines:

diff -ur -X - NVIDIA-Linux-x86_64-319.17-no-compat32.orig/kernel/nv-procfs.c NVIDIA-Linux-x86_64-319.17-no-compat32/kernel/nv-procfs.c
--- NVIDIA-Linux-x86_64-319.17-no-compat32.orig/kernel/nv-procfs.c 2013-04-26 00:22:30.000000000 -0400
+++ NVIDIA-Linux-x86_64-319.17-no-compat32/kernel/nv-procfs.c 2013-05-22 04:52:45.229495748 -0400

Change to:

diff -ur -X - NVIDIA-Linux-x86_64-325.08.orig/kernel/nv-procfs.c NVIDIA-Linux-x86_64-325.08/kernel/nv-procfs.c
--- NVIDIA-Linux-x86_64-325.08.orig/kernel/nv-procfs.c 2013-04-26 00:22:30.000000000 -0400
+++ NVIDIA-Linux-x86_64-325.08/kernel/nv-procfs.c 2013-05-22 04:52:45.229495748 -0400


5) replace linux-3.10.patch from the first link with this "nvidia-drivers-linux-3.10.patch.txt" (i think you must preserve the name "linux-3.10.patch")

6) install drivers :)


Last edited by st3f4n2006 on Sun Jul 07, 2013 6:11 pm; edited 2 times in total
Back to top
View user's profile Send private message
st3f4n2006
n00b
n00b


Joined: 07 Jul 2013
Posts: 8

PostPosted: Sun Jul 07, 2013 6:08 pm    Post subject: Reply with quote

Quote:
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 555M/PCIe/SSE2
OpenGL core profile version string: 4.3.0 NVIDIA 325.08
OpenGL core profile shading language version string: 4.30 NVIDIA via Cg compiler


glxinfo in optirun :D

Linux version 3.10.0-gentoo (...) (gcc version 4.7.3 (Gentoo 4.7.3 p1.0, pie-0.5.5) ) #1 SMP PREEMPT
Back to top
View user's profile Send private message
ExecutorElassus
l33t
l33t


Joined: 11 Mar 2004
Posts: 759
Location: Stuttgart, Germany

PostPosted: Wed Jul 10, 2013 1:02 pm    Post subject: Reply with quote

seems to work for me as well. Thanks for the instructions!

Cheers,

EE
Back to top
View user's profile Send private message
Cephas
n00b
n00b


Joined: 25 Mar 2011
Posts: 6

PostPosted: Fri Jul 12, 2013 10:04 am    Post subject: Reply with quote

Thanks for the instructions.
Works fine.
Back to top
View user's profile Send private message
Jerrino
n00b
n00b


Joined: 25 Dec 2012
Posts: 20

PostPosted: Sun Jul 14, 2013 8:38 am    Post subject: Reply with quote

Sorry guys, but i can't download the patch from devtalk. "access denied"!!!!

Someone could post the whole .txt file please? Thanks
_________________
Free your PC.. Free your Mind!!
ASUS Crosshair V formula - AMD FX-8150
16GB DDR3 - Nvidia GTX 550 Ti
Back to top
View user's profile Send private message
st3f4n2006
n00b
n00b


Joined: 07 Jul 2013
Posts: 8

PostPosted: Thu Jul 18, 2013 12:01 pm    Post subject: Reply with quote

http://pastebin.com/SPj4AAHE


The code here it's already modified so it should work as it is.
Back to top
View user's profile Send private message
splurben
Apprentice
Apprentice


Joined: 03 Feb 2004
Posts: 176
Location: Augusta, Southwest Western Australia

PostPosted: Fri Aug 09, 2013 12:23 am    Post subject: [SOLVED] 325.15 NVIDIA-DRIVERS Supports Kernel 3.10.* Reply with quote

As of NVIDIA-DRIVERS-325.15, Kernels 3.10.* are supported and functioning on two systems on my bench.

New restriction of NVIDIA-DRIVERS is <3.11

Cheers
_________________
--=>Like... Goodness had nothing to do with it.<=--
Back to top
View user's profile Send private message
AchilleTalon
Apprentice
Apprentice


Joined: 11 Apr 2004
Posts: 286
Location: Montreal, Quebec, Canada

PostPosted: Wed Aug 28, 2013 4:15 pm    Post subject: Reply with quote

So, why the update process doesn't install the newest nvidia-drivers right from the emerge command if it is supported?

The latest nvidia-drivers an emerge update install is nvidia-drivers-319.32 and it fails if you have updated to kernel 3.10.x.

That's a shame when updates are not properly released.
_________________
Achille Talon Hop!
Back to top
View user's profile Send private message
GregToo
n00b
n00b


Joined: 18 Aug 2013
Posts: 25
Location: Chile

PostPosted: Thu Aug 29, 2013 9:10 pm    Post subject: Reply with quote

AchilleTalon wrote:
So, why the update process doesn't install the newest nvidia-drivers right from the emerge command if it is supported?

The latest nvidia-drivers an emerge update install is nvidia-drivers-319.32 and it fails if you have updated to kernel 3.10.x.

That's a shame when updates are not properly released.



LOL i have this problem...
nvidia-drivers need a update BUMP
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum