Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libmpeg2 error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
renokite
n00b
n00b


Joined: 07 Jul 2013
Posts: 1

PostPosted: Sun Jul 07, 2013 4:18 pm    Post subject: libmpeg2 error Reply with quote

Hi I am having a problem in installing opera. I am on 32bit machine. This is the error i get ,

config.status: creating Makefile
config.status: creating include/Makefile
config.status: creating test/Makefile
config.status: creating doc/Makefile
config.status: creating src/Makefile
config.status: creating libmpeg2/Makefile
config.status: creating libmpeg2/convert/Makefile
config.status: creating libvo/Makefile
config.status: creating vc++/Makefile
config.status: creating libmpeg2/libmpeg2.pc
config.status: creating libmpeg2/convert/libmpeg2convert.pc
config.status: creating include/config.h
config.status: executing depfiles commands
>>> Source configured.
>>> Compiling source in /var/tmp/portage/media-libs/libmpeg2-0.5.1-r1/work/libmpeg2-0.5.1 ...
make -j2 'OPT_CFLAGS=-O2 -march=i686 -pipe' 'MPEG2DEC_CFLAGS=-O2 -march=i686 -pipe' LIBMPEG2_CFLAGS=
Making all in libmpeg2
make[1]: Entering directory `/var/tmp/portage/media-libs/libmpeg2-0.5.1-r1/work/libmpeg2-0.5.1/libmpeg2'
Making all in convert
make[2]: Entering directory `/var/tmp/portage/media-libs/libmpeg2-0.5.1-r1/work/libmpeg2-0.5.1/libmpeg2/convert'
/bin/sh ../../libtool --tag=CC --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../../include -I../../include -I../../include -O2 -march=i686 -pipe -O2 -march=i686 -pipe -c -o rgb.lo rgb.c
/bin/sh ../../libtool --tag=CC --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../../include -I../../include -I../../include -O2 -march=i686 -pipe -O2 -march=i686 -pipe -c -o uyvy.lo uyvy.c
mkdir .libs
mkdir .libs
mkdir: cannot create directory '.libs': File exists
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../../include -I../../include -I../../include -O2 -march=i686 -pipe -O2 -march=i686 -pipe -c rgb.c -fPIC -DPIC -o .libs/rgb.o
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../../include -I../../include -I../../include -O2 -march=i686 -pipe -O2 -march=i686 -pipe -c uyvy.c -fPIC -DPIC -o .libs/uyvy.o
env: env: UTF-8: No such file or directory
make[2]: *** [rgb.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
UTF-8: No such file or directory
make[2]: *** [uyvy.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-libs/libmpeg2-0.5.1-r1/work/libmpeg2-0.5.1/libmpeg2/convert'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-libs/libmpeg2-0.5.1-r1/work/libmpeg2-0.5.1/libmpeg2'
make: *** [all-recursive] Error 1
* ERROR: media-libs/libmpeg2-0.5.1-r1 failed (compile phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=media-libs/libmpeg2-0.5.1-r1'`,
* the complete build log and the output of `emerge -pqv '=media-libs/libmpeg2-0.5.1-r1'`.
* The complete build log is located at '/var/log/portage/media-libs:libmpeg2-0.5.1-r1:20130707-072726.log'.
* For convenience, a symlink to the build log is located at '/var/tmp/portage/media-libs/libmpeg2-0.5.1-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/media-libs/libmpeg2-0.5.1-r1/temp/environment'.
* Working directory: '/var/tmp/portage/media-libs/libmpeg2-0.5.1-r1/work/libmpeg2-0.5.1'
* S: '/var/tmp/portage/media-libs/libmpeg2-0.5.1-r1/work/libmpeg2-0.5.1'

>>> Failed to emerge media-libs/libmpeg2-0.5.1-r1, Log file:

>>> '/var/log/portage/media-libs:libmpeg2-0.5.1-r1:20130707-072726.log'


this is my 02locales file

LANG="en_US.ISO-8859-1"
LANGUAGE="en_US.UTF-8 UTF-8"
LC_COLLATE="C"
LC_CTYPE="en_US.ISO-8859-1"

this is my locale.gen file


# /etc/locale.gen: list all of the locales you want to have on your system
#
# The format of each line:
# <locale> <charmap>
#
# Where <locale> is a locale located in /usr/share/i18n/locales/ and
# where <charmap> is a charmap located in /usr/share/i18n/charmaps/.
#
# All blank lines and lines starting with # are ignored.
#
# For the default list of supported combinations, see the file:
# /usr/share/i18n/SUPPORTED
#
# Whenever glibc is emerged, the locales listed here will be automatically
# rebuilt for you. After updating this file, you can simply run `locale-gen`
# yourself instead of re-emerging glibc.

en_US ISO-8859-1
en_US.UTF-8 UTF-8


Please could anyone assist me ?

thanks
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5525

PostPosted: Mon Jul 08, 2013 3:02 pm    Post subject: Reply with quote

I'm not sure what are the proper values for LANGUAGE variable, but I doubt what you're setting it to is among them.
Also, mixing UTF-8 with ISO-8859-1 can only lead to trouble.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum