Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PBM: nvidia-settings takes 2 minutes to show up!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4688
Location: Theux (Belgium)

PostPosted: Wed Jul 03, 2013 3:29 pm    Post subject: PBM: nvidia-settings takes 2 minutes to show up! Reply with quote

Hi all.

My new laptop (Dell Latitude E6530) comes with an nvidia card and I've just switched to the proprietary driver. I'm used to NVidia hardware since that's what I always chose for my home machine. This said I still might have missed something.

If I run nvidia-settings for the first time (i.e. there's no .nvidia-settings-rc) it shows up as fast as usual. But if I close it and run it again (I've timed how long it takes) it appears after 2(!) minutes. If I remove .nvidia-settings-rc and run the program again, it appears as fast as usual.

Add to that I see an error message "Instruction not permitted" (it's in French) each time I close the program.

Does anybody have an idea what could be wrong?
  • driver x11-drivers/nvidia-drivers-319.23
  • video 01:00.0 VGA compatible controller: NVIDIA Corporation GF108GLM [NVS 5200M] (rev a1)
  • kernel 3.8.13-gentoo
Thanks in advance for any help/hint.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1194

PostPosted: Wed Jul 03, 2013 4:52 pm    Post subject: Reply with quote

Quiet a lot is said about bug fixes regarding nvidia-settings
in "Release Highlights" of the new beta release:
http://www.nvidia.com/object/linux-display-amd64-325.08-driver.html
_________________
fun2gen2
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4688
Location: Theux (Belgium)

PostPosted: Thu Jul 04, 2013 4:21 pm    Post subject: Reply with quote

ulenrich wrote:
Quiet a lot is said about bug fixes regarding nvidia-settings
in "Release Highlights" of the new beta release:
http://www.nvidia.com/object/linux-display-amd64-325.08-driver.html

http://www.nvidia.com/object/linux-display-amd64-325.08-driver.html wrote:
Fixed a bug that caused nvidia-settings to write hostname-based color correction settings to the .nvidia-settings-rc configuration file, even when the "Include X Display Names in the Config File" option was unset. This could lead to a long delay when starting nvidia-settings, if a hostname saved to the configuration file failed to resolve.

That furiously looks familiar to me :D .

Thanks a lot for your lights, man. (Proves once more that they're listening to bug reports and they fix 'em.)

Erm... ah, wait a minute, I don't have that item ("Include X Display Names in the Config File") checked now... Well, will try anyway and report.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum