Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
bundle not found as users but as sudo is.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Fri Jun 28, 2013 3:19 am    Post subject: bundle not found as users but as sudo is. Reply with quote

git@mksrv ~ $ bundle
bash: bundle: command not found

mksrv # bundle
bash: bundle: command not found

mksrv # sudo -u git -H bundle
Bundler::GemfileNotFound

im trying to avoid sudo for a wiki page, what is going on with this strange behavior? im specifically updating the gitlab wiki from 4.1 to 5.3, and have 5.3 on my system but i required sudo and they didnt like it last time i put sudo into a wiki.
Back to top
View user's profile Send private message
Naib
Advocate
Advocate


Joined: 21 May 2004
Posts: 4337
Location: Removed by Neddy

PostPosted: Sun Jun 30, 2013 3:02 pm    Post subject: Reply with quote

that probably means it has been installed in /usr/sbin (could be /sbin but I doubt it).

/usr/sbin isn't in the general user PATH variable since binaries in that directory are usually for superuser usage.

if part of the command can be run as a normal user try: /usr/sbin/bundle
_________________
the table is made from wood. forget what you learnt, the table is made from carbon. forget what you learnt, the table is made from protons. forget what you learnt, the table is made from quarks. forget what you learnt, the table is good for shagging on
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum