Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel panic
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Gothral
n00b
n00b


Joined: 09 Aug 2011
Posts: 11

PostPosted: Sun Jun 23, 2013 10:11 pm    Post subject: Kernel panic Reply with quote

Ho da poco terminato l'installazione di Gentoo sul mio Asus A55VD e non appena lo avvio mi compare questo messaggio di errore:

"EXT4-fs (sda10): coudn't mount as ext3 due to feature incompatibilities
EXT4-fs (sda10): coudn't mount as ext2 due to feature incompatibilities
EXT4-fs (sda10): mounted filesystem with ordered data mode Opts: (null)
VFS: mounted root (ext4 filesystem) readonly on device 8:10

[...]

traps: init[1] general prtection ip:f75b9e7d sp:ffd0d4e8 error:0 in ld-2.163so[f75a3000+21000]
initi (1) used greatest stack depth: 3056 bytes left
Kernel panic - not syncing: Attempted to kill init! exitcode=0x000000b
Pid: 1, comm: init Not tainted 3.8.13-gentoo #5

[...]

"Warning: at arch/x86/kernel/smp.c:123 native_smp_send-reschedule+0x53/0x60()
Hardware name: K55VD
Modules linked in:
Pid: 1, comm: init not tanited 3.8.13-gentoo #2"

Durante l'installazione non ho riscontrato nessun genere di errore. Quale potrebbe essere il problema?
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 435

PostPosted: Mon Jun 24, 2013 10:37 pm    Post subject: Reply with quote

Sembrerebbe che il tuo kernel abbia problemi con ext4. L'hai messo come builtin o come modulo?
Inoltre, il kernel l'hai creato a mano o con genkernel?
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
Gothral
n00b
n00b


Joined: 09 Aug 2011
Posts: 11

PostPosted: Tue Jun 25, 2013 7:50 am    Post subject: Reply with quote

Non ho usato genkernel, ho configurato il kernel manualemente mettendo il supporto per ext4 come built-in.
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 435

PostPosted: Tue Jun 25, 2013 8:55 am    Post subject: Reply with quote

Prova ad aggiungere "rootfstype=ext4" ai parametri del kernel.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
Gothral
n00b
n00b


Joined: 09 Aug 2011
Posts: 11

PostPosted: Tue Jun 25, 2013 10:55 am    Post subject: Reply with quote

Scusa l'ignoranza, ma come dovrei fare per aggiunger
Quel parametro?
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 435

PostPosted: Tue Jun 25, 2013 11:00 am    Post subject: Reply with quote

Gothral wrote:
Scusa l'ignoranza, ma come dovrei fare per aggiunger
Quel parametro?


Dipende dal boot loader. Stai usando grub1, grub2 o lilo?
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
Gothral
n00b
n00b


Joined: 09 Aug 2011
Posts: 11

PostPosted: Tue Jun 25, 2013 11:11 am    Post subject: Reply with quote

Sto usando il grub 2 di ubuntu. Ho installato prima ubuntu e poi gentoo e quindi ho impostato il boot attraverso il grub del primo.
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 435

PostPosted: Tue Jun 25, 2013 11:38 am    Post subject: Reply with quote

Segui questo link:
http://askubuntu.com/questions/19486/how-do-i-add-a-kernel-boot-parameter
Ricordati che se è il grub di ubuntu, le modifiche devi farle da ubuntu.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4724
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Tue Jun 25, 2013 3:58 pm    Post subject: Reply with quote

direi che la via che comporta meno "sbattimenti" sotto ogni profilo rimane
/etc/genkernel.conf wrote:
INSTALL="yes"
OLDCONFIG="yes"
MENUCONFIG="no"
CLEAN="yes"
MRPROPER="yes"
MOUNTBOOT="yes"
SAVE_CONFIG="yes"
CLEAR_CACHE_DIR="yes"
POSTCLEAR="1"
MAKEOPTS="-j5"
LVM="no"
LUKS="no"
GPG="no"
DMRAID="no"
BUSYBOX="yes"
MDADM="yes"
MDADM_CONFIG="/etc/mdadm.conf"
MULTIPATH="no"
ISCSI="no"
E2FSPROGS="yes"
DISKLABEL="yes"
#BOOTLOADER="grub" tienilo commentato o impostalo a "none"
KEYMAP="it"
BOOTDIR="/boot"
INTEGRATED_INITRAMFS="1"
COMPRESS_INITRD="yes"
COMPRESS_INITRD_TYPE="xz"
REAL_ROOT="/dev/sdxx"
in rosso quello che devi adattare
Code:
genkernel --menuconfig all
badando che nella conf del kernel
/usr/src/linux/.config wrote:
# CONFIG_KERNEL_GZIP is not set
# CONFIG_KERNEL_BZIP2 is not set
# CONFIG_KERNEL_LZMA is not set
CONFIG_KERNEL_XZ=y
# CONFIG_KERNEL_LZO is not set
CONFIG_BLK_DEV_INITRD=y
# CONFIG_INITRAMFS_SOURCE is not set
CONFIG_INITRAMFS_ROOT_UID=0
CONFIG_INITRAMFS_ROOT_GID=0
# CONFIG_RD_GZIP is not set
# CONFIG_RD_BZIP2 is not set
# CONFIG_RD_LZMA is not set
CONFIG_RD_XZ=y
# CONFIG_RD_LZO is not set
CONFIG_INITRAMFS_COMPRESSION_NONE=y
# CONFIG_INITRAMFS_COMPRESSION_XZ is not set
CONFIG_CMDLINE_BOOL=y
CONFIG_CMDLINE="domdadm fbcon=scrollback:1024k radeon.audio=0 video=HDMI-A-1:d video=DVI-I-1:d drm_kms_helper.edid_firmware=VGA-1:edid/Samsung_S19B150N.bin video=VGA-1:e rfkill.master_switch_mode=2 rootfstype=ext4"
# CONFIG_CMDLINE_OVERRIDE is not set
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y
# CONFIG_STANDALONE is not set
CONFIG_PREVENT_FIRMWARE_BUILD=y
CONFIG_FW_LOADER=y
CONFIG_FIRMWARE_IN_KERNEL=y
CONFIG_EXTRA_FIRMWARE="edid/Samsung_S19B150N.bin radeon/R600_rlc.bin radeon/R700_rlc.bin rtl_nic/rtl8168e-2.fw"
CONFIG_EXTRA_FIRMWARE_DIR="/lib64/firmware"
e configurando builtin il dovuto, firmware compreso nel caso usi ati come me.

inutile dire che io il kernel me lo configuro a mano e lancio un genkernel all (con --noclean e --nomrproper impliciti), solo per compilare in pratica, ma uso linux da più di quindici anni e gentoo da almeno otto, ma se, invece, è il primo kernel che compili per gentoo ti "consiglio" di non fare l'eroe¹ e partire dalla configurazione che ti propone genkernel e non da quella base.
Se poi non sei realmente avvezzo (scafato, scafatissimo, ai limiti dello scocciato, quindi sai bene quello che fai e venendo da distribuzioni meno "da utonti" sai che non basta oldconfig ma è sempre utile newconfig etc) alla configurazione manuale del kernel ti consiglio per un bel pò di continuare a seguire questa via.

salaam aleikum²

¹ eroe = imbecille che si fa ammazzare per nulla o per uno sciocco puntiglio/causa persa/fanatismo
² da intendere più che come saluto come espediente per far perder tempo agli "oni" in ascolto nel nome dell'idiozia contagiosa nota come "intelligence" ed un sarcastico confidare nell'aiuto di imprecisata divinità (augurando semmai l'opposto)

:twisted: :twisted: :twisted:

_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Gothral
n00b
n00b


Joined: 09 Aug 2011
Posts: 11

PostPosted: Thu Jun 27, 2013 3:02 pm    Post subject: Reply with quote

Grazie ad entrambi per i vostri consigli. Ho provato entrambe le strade da voi consigliatemi ma nulla. Paradossalmente l'installazione che avevo condotto poco tempo fa su un altro pc era andata liscia come l'olio. Alla fine ho optato per reinstallare gentoo utilizzando genkernel e finalmente funziona tutto.

Grazie ancora per i consigli!
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4724
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Fri Jun 28, 2013 11:39 am    Post subject: Reply with quote

8O :?:
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum