Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No sound using skype -- (almost) RESOLVED
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Fred Krogh
l33t
l33t


Joined: 07 Feb 2005
Posts: 783
Location: Tujunga, CA

PostPosted: Thu Jun 27, 2013 11:42 pm    Post subject: No sound using skype -- (almost) RESOLVED Reply with quote

It used to work, but not now. Sound seems to be just fine in every other program. I'm using skype-4.2.0.11 and pulseaudio-4.0. Nothing I've seen posted, seems to help with the problem. Any ideas? Thanks,
Fred


Last edited by Fred Krogh on Tue Jul 09, 2013 6:25 pm; edited 2 times in total
Back to top
View user's profile Send private message
shad0w_GR
n00b
n00b


Joined: 06 Apr 2011
Posts: 16

PostPosted: Fri Jun 28, 2013 2:33 pm    Post subject: Reply with quote

Try to remove tsched=0 from default.pa. <- Probably you dont have this in default.pa if you dont have any sound with skype, but crackling sound is triggered after tsched=0 is added,so remove it
And run
Code:
$ PULSE_LATENCY_MSEC=30 skype


Bug is here

I found this problem today(crackling sound in audacity, and after i removed tsched=0, audacity was fine but skype was without sound).

Also is mentioned in archlinux forum.
Back to top
View user's profile Send private message
Fred Krogh
l33t
l33t


Joined: 07 Feb 2005
Posts: 783
Location: Tujunga, CA

PostPosted: Fri Jun 28, 2013 3:52 pm    Post subject: Reply with quote

I've tried all combinations with tsched=0 or not, and starting with and without PULSE_LATENCY_MSEC=30 skype None of these combinations seems to work. I guess for the time being, I'll use google hang out. Thanks for the suggestion, I thought it was going to work.
Back to top
View user's profile Send private message
Fred Krogh
l33t
l33t


Joined: 07 Feb 2005
Posts: 783
Location: Tujunga, CA

PostPosted: Tue Jul 09, 2013 12:18 am    Post subject: Reply with quote

I'm not sure what I did or didn't do last time but skype now works if I start it with "PULSE_LATENCY_MSEC=30 /opt/bin/skype". And it works with either "load-module module-udev-detect", or "load-module module-udev-detect tsched=0" in /etc/pulse/default.pa.

Should add that before I did not have pulseaudio volume control, so perhaps the volume was so low as to be inaudible and that I increased the volume with the recently installed pavucontrol.
Back to top
View user's profile Send private message
Fred Krogh
l33t
l33t


Joined: 07 Feb 2005
Posts: 783
Location: Tujunga, CA

PostPosted: Tue Jul 09, 2013 6:25 pm    Post subject: Reply with quote

I thought this was fixed, but not so. If I play music with audacious, I need to set the volume down to the point where skype is inaudible. Then if a call comes in, even if I close audacious, I can't hear anything on skype without adjusting the volume. I had the impression that the pulse audio volume center was setting volume levels for different applications, but no such luck. Is there some way to get some kind of balance here? Thanks,
Fred
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum