Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[init] "respawning too fast" : boot bloqué
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Sun Jun 02, 2013 6:30 pm    Post subject: [init] "respawning too fast" : boot bloqué Reply with quote

Salut à tous,

J'ai de gros problèmes avec un de mes postes sous Gentoo. Il m'est devenu impossible de le booter. J'ignore d'où cela vient, je n'ai juste que quelques supositions. Je n'ai pas non plus de support log puisque cela arrive dès le début.

Mon kernel boote bien, pas de kernel panic. Je suis un peu à l'aveugle, car tout se passe apparemment avant d'écrire quelque chose dans les logs, au début de l'init. En fait, j'ai le droit à des messages en masse du style "respawning too fast" ou des "cannot execute binary file", l'écran étant figé dessus, et le fameux Ctrl+Alt+Del ne fonctionne pas, obligé de faire un hard reset. Le problème ainsi, c'est que cela pourrissait mon filesystem, donc obligé de rebooter sous un live CD et de réparer ma partition ext4 (au passage, je trouve dommage que fsck est incapable de détecter où sont sauvegardés les superblock). A force de chercher le problème, de reboot et de cassage de partition, je me suis décidé à formater et à réinstaller Gentoo. Auparavant, les outils SMART ne détectent aucun problème sur le disque dur, il marche donc comme au premier jour. Après formatage, réinstallation à zéro (ou presque, j'ai gardé le .config et le make.conf) de Gentoo, rien à faire, toujours ces erreurs. Las, j'ai décidé à faire une installation complète de Linux Mint, bien que correct, et qui s'est bien déroulée, avant de me dire que rien ne vaut la légèreté d'une Gentoo, particulièrement sur un poste assez âgé...

Alors, heureusement j'ai quelques pistes. Etant donné que mon posté est assez âgé, j'ai réussi à dénicher pour lui donner un léger souffle nouveau un nouveau processeur d'occase, un Opteron double coeur (socket 939). Je n'écarte pas un éventuel problème de ce côté, mais il faut savoir qu'avant de ne plus pouvoir démarrer, j'avais déjà installé le processeur. Et après documentation, l'Opteron est équivalent au Athlon64 X2, donc pas de problème de CFLAGS, sachant que j'étais déjà en native.
En fait, je penche plus du côté de la mise à jour du kernel vers la version 3.8.13, où j'ai activé des nouvelles options au moment du "make oldconfig", mais j'ignore lesquelles, ça m'apprendra à me documenter trop rapidement...

Alors voilà, si quelqu'un peut m'aider... Je poste les infos que je pense utile, si besoin d'autres je les posterai dès que possible.

Mon make.conf :
Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /etc/make.conf.example for a more detailed example.
CFLAGS="-march=native -msse3 -m3dnow -O2 -pipe"
CFLAGS="$CFLAGS -I$SOURCES/arch/x86/include/uapi"
CXXFLAGS="${CFLAGS}"

# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"

# These are the USE flags that were used in addition to what is provided by the
# profile used for building.

MAKEOPTS="-j2"

LINGUAS="fr"

VIDEO_CARDS="r600 radeon"
ALSA_CARDS=""
INPUT_DEVICE="evdev"

#DVB_CARDS="cx23885"
LIRC_DEVICES="hauppauge hauppauge_dvb"
VDR_SC_PARALLEL="PARALLEL_128_SSE"

ACCEPT_LICENSE="AdobeFlash-10.3 dlj-1.1 ralink-firmware AdobeFlash-11.x"

CAMERA="kodak"
SANE_BACKENDS="hp4200"

XFCE_PLUGINS="clock menu logout trash"

USE="xfce gtk -gtk3 -gnome -kde -qt -qt3 -qt4 \
-acessibility -qt3support -qt-static \
dbus consolekit glade gvfs -gdu -hal pam policykit udev xcomposite startup-notification samba -ldap usb zvbi \
acpi lm_sensors \
3dnow 3dnowext g3dvl gallium mmx mmxext sse sse2 ssse3 smp threads \
X dga opengl xv v4l v4l2 xvmc \
a52 alsa dts jack sdl openal midi mtp -timidity ladspa -esd -arts \
cd cdda cdinstall cdparanoia cdr cddb css dvb dvd dvdr -bluetooth \
cups gnutls pdf nsplugin \
nls xft \
truetype \
gif gphoto2 jpeg jpeg2k png openexr raw svg tiff wmf \
aac flac mad mp3 mms musepack ogg videos vorbis wavpack wma \
amr faac faad ffmpeg dirac dri mpeg quicktime postproc pvr theora vdr win32codecs x264 xvid"

#PORTDIR="/usr/portage"
#PORTDIR_OVERLAY="/usr/local/portage/"

GENTOO_MIRRORS="http://mirrors.linuxant.fr/distfiles.gentoo.org/ "
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
#source /var/lib/layman/make.conf


Mon inittab :
Code:
#
# /etc/inittab:  This file describes how the INIT process should set up
#                the system in a certain run-level.
#
# Author:  Miquel van Smoorenburg, <miquels@cistron.nl>
# Modified by:  Patrick J. Volkerding, <volkerdi@ftp.cdrom.com>
# Modified by:  Daniel Robbins, <drobbins@gentoo.org>
# Modified by:  Martin Schlemmer, <azarah@gentoo.org>
# Modified by:  Mike Frysinger, <vapier@gentoo.org>
# Modified by:  Robin H. Johnson, <robbat2@gentoo.org>
#
# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/files/inittab-2.87,v 1.2 2013/04/20 03:51:26 vapier Exp $

# Default runlevel.
id:3:initdefault:

# System initialization, mount local filesystems, etc.
si::sysinit:/sbin/rc sysinit

# Further system initialization, brings up the boot runlevel.
rc::bootwait:/sbin/rc boot

l0:0:wait:/sbin/rc shutdown
l0s:0:wait:/sbin/halt -dhp
l1:1:wait:/sbin/rc single
l2:2:wait:/sbin/rc nonetwork
l3:3:wait:/sbin/rc default
l4:4:wait:/sbin/rc default
l5:5:wait:/sbin/rc default
l6:6:wait:/sbin/rc reboot
l6r:6:wait:/sbin/reboot -dk
#z6:6:respawn:/sbin/sulogin

# new-style single-user
su0:S:wait:/sbin/rc single
su1:S:wait:/sbin/sulogin

# TERMINALS
c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:2345:respawn:/sbin/agetty 38400 tty2 linux
c3:2345:respawn:/sbin/agetty 38400 tty3 linux
c4:2345:respawn:/sbin/agetty 38400 tty4 linux
c5:2345:respawn:/sbin/agetty 38400 tty5 linux
c6:2345:respawn:/sbin/agetty 38400 tty6 linux

# SERIAL CONSOLES
#s0:12345:respawn:/sbin/agetty -L 115200 ttyS0 vt100
#s1:12345:respawn:/sbin/agetty -L 115200 ttyS1 vt100

# What to do at the "Three Finger Salute".
ca:12345:ctrlaltdel:/sbin/shutdown -r now

# Used by /etc/init.d/xdm to control DM startup.
# Read the comments in /etc/init.d/xdm for more
# info. Do NOT remove, as this will start nothing
# extra at boot if /etc/init.d/xdm is not added
# to the "default" runlevel.
x:a:once:/etc/X11/startDM.sh


Mon .config ici : http://pastebin.com/fKuGnRZB


Last edited by Fenril on Sat Jun 15, 2013 12:31 pm; edited 2 times in total
Back to top
View user's profile Send private message
k-root
Guru
Guru


Joined: 08 Jan 2005
Posts: 358
Location: Paris

PostPosted: Mon Jun 03, 2013 5:57 pm    Post subject: Reply with quote

Code:
"respawning too fast" ou des "cannot execute binary file"



http://www.gentoo.org/doc/fr/gentoo-amd64-faq.xml#kernel


?

http://gcc.gnu.org/onlinedocs/gcc/i386-and-x86_002d64-Options.html#i386-and-x86_002d64-Options

Quote:

‘opteron’
‘athlon64’
‘athlon-fx’
Processors based on the AMD K8 core with x86-64 instruction set support, including the AMD Opteron, Athlon 64, and Athlon 64 FX processors. (This supersets MMX, SSE, SSE2, 3DNow!, enhanced 3DNow! and 64-bit instruction set extensions.)

_________________
boozo wrote:
Gentoo, ça mange des ours et baffe des buffles par 37°C avec un bob et des tongs
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3319
Location: Paris - France

PostPosted: Mon Jun 03, 2013 7:40 pm    Post subject: Reply with quote

ce genre de messages d'erreur sent effectivement le problème de init qui plante. Vu la nature du programme init, il est peu probable qu'il y ait un souci d'optimisation (il s'agit d'un programme très simple, les optimisations spécifiques à un processeur on très peu de chance d'intervenir ici, malgré tous les efforts de GCC...)

La piste du noyau compilé pour la mauvaise architecture est effectivement une très bonne idée. Si tu lance un noyau 32 bits que le systeme est compilé en 64, kboom. Et inversement.
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3136

PostPosted: Mon Jun 03, 2013 8:04 pm    Post subject: Reply with quote

Ou un couplage des 2... l'un peut aussi masquer l'autre des fois

D'ailleurs a ce propos, je ne comprends pas bien ce que fait un hack uapi pour les nvidia-drivers dans tes cflags alors que tu as du radeon en $video_card ? Un vestige d'une autre carte ?
Je pense que tu as dû prendre un patch depuis b.g.o non ?
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
k-root
Guru
Guru


Joined: 08 Jan 2005
Posts: 358
Location: Paris

PostPosted: Mon Jun 03, 2013 8:06 pm    Post subject: Reply with quote

une autre piste

Code:
# CONFIG_MODVERSIONS is not set

_________________
boozo wrote:
Gentoo, ça mange des ours et baffe des buffles par 37°C avec un bob et des tongs
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Mon Jun 03, 2013 9:04 pm    Post subject: Reply with quote

guilc wrote:
ce genre de messages d'erreur sent effectivement le problème de init qui plante. Vu la nature du programme init, il est peu probable qu'il y ait un souci d'optimisation (il s'agit d'un programme très simple, les optimisations spécifiques à un processeur on très peu de chance d'intervenir ici, malgré tous les efforts de GCC...)

La piste du noyau compilé pour la mauvaise architecture est effectivement une très bonne idée. Si tu lance un noyau 32 bits que le systeme est compilé en 64, kboom. Et inversement.

Bin je ne me suis pas trompé, si ? Je n'ai rien touché et ait toujours tourné en 64 bits depuis que je l'ai. l'IA32 emulation est bien activé dans mon kernel config : http://pastebin.com/fKuGnRZB Le passage A64 X2 > Opteron ne signifie aucun changement d'architecture d'après la doc gcc, non ?

Si je fais un readelf :

Code:
# readelf -h /mnt/gentoo/sbin/agetty
ELF Header:
  Magic:   7f 45 4c 46 02 01 01 00 00 00 00 00 00 00 00 00
  Class:                             ELF64
  Data:                              2's complement, little endian
  Version:                           1 (current)
  OS/ABI:                            UNIX - System V
  ABI Version:                       0
  Type:                              EXEC (Executable file)
  Machine:                           Advanced Micro Devices X86-64
  Version:                           0x1
  Entry point address:               0x40420c
  Start of program headers:          64 (bytes into file)
  Start of section headers:          29640 (bytes into file)
  Flags:                             0x0
  Size of this header:               64 (bytes)
  Size of program headers:           56 (bytes)
  Number of program headers:         10
  Size of section headers:           64 (bytes)
  Number of section headers:         27
  Section header string table index: 26


J'ai donc bien des exécutables en AMD64.

Quote:

D'ailleurs a ce propos, je ne comprends pas bien ce que fait un hack uapi pour les nvidia-drivers dans tes cflags alors que tu as du radeon en $video_card ? Un vestige d'une autre carte ?
Je pense que tu as dû prendre un patch depuis b.g.o non ?


Pardon tu as raison, cette ligne était pour une ancienne nvidia, et la laisser empêchait certains paquets de compiler, mais maintenant elle n'y est plus, sinon tout le reste est ainsi.
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Tue Jun 04, 2013 8:15 pm    Post subject: Reply with quote

Oulà... J'ai d'étranges erreurs en chroot...

Code:
# rc-status --all
mkdir `/run/openrc/starting': No such file or directory
mkdir `/run/openrc/started': No such file or directory
mkdir `/run/openrc/stopping': No such file or directory
mkdir `/run/openrc/inactive': No such file or directory
mkdir `/run/openrc/wasinactive': No such file or directory
mkdir `/run/openrc/failed': No such file or directory
mkdir `/run/openrc/hotplugged': No such file or directory
mkdir `/run/openrc/daemons': No such file or directory
mkdir `/run/openrc/options': No such file or directory
mkdir `/run/openrc/exclusive': No such file or directory
mkdir `/run/openrc/scheduled': No such file or directory
mkdir `/run/openrc/tmp': No such file or directory
 * Caching service dependencies ...
fopen `/run/openrc/deptree': No such file or directory
fopen `/run/openrc/depconfig': No such file or directory
 * Failed to update the dependency tree                                    [ !! ]
Runlevel: default
mkdir `/run/openrc/starting': No such file or directory
mkdir `/run/openrc/started': No such file or directory
mkdir `/run/openrc/stopping': No such file or directory
mkdir `/run/openrc/inactive': No such file or directory
mkdir `/run/openrc/wasinactive': No such file or directory
mkdir `/run/openrc/failed': No such file or directory
mkdir `/run/openrc/hotplugged': No such file or directory
mkdir `/run/openrc/daemons': No such file or directory
mkdir `/run/openrc/options': No such file or directory
mkdir `/run/openrc/exclusive': No such file or directory
mkdir `/run/openrc/scheduled': No such file or directory
mkdir `/run/openrc/tmp': No such file or directory
 * Caching service dependencies ...
fopen `/run/openrc/deptree': No such file or directory
fopen `/run/openrc/depconfig': No such file or directory
 * Failed to update the dependency tree                                    [ !! ]
 metalog                                                            [  stopped  ]
 netmount                                                           [  stopped  ]
 local                                                              [  stopped  ]
Runlevel: sysinit
mkdir `/run/openrc/starting': No such file or directory
mkdir `/run/openrc/started': No such file or directory
mkdir `/run/openrc/stopping': No such file or directory
mkdir `/run/openrc/inactive': No such file or directory
mkdir `/run/openrc/wasinactive': No such file or directory
mkdir `/run/openrc/failed': No such file or directory
mkdir `/run/openrc/hotplugged': No such file or directory
mkdir `/run/openrc/daemons': No such file or directory
mkdir `/run/openrc/options': No such file or directory
mkdir `/run/openrc/exclusive': No such file or directory
mkdir `/run/openrc/scheduled': No such file or directory
mkdir `/run/openrc/tmp': No such file or directory
 * Caching service dependencies ...
fopen `/run/openrc/deptree': No such file or directory
fopen `/run/openrc/depconfig': No such file or directory
 * Failed to update the dependency tree                                    [ !! ]
 udev-mount                                                         [  stopped  ]
 udev                                                               [  stopped  ]
 devfs                                                              [  stopped  ]
 sysfs                                                              [  stopped  ]
 dmesg                                                              [  stopped  ]
Runlevel: boot
mkdir `/run/openrc/starting': No such file or directory
mkdir `/run/openrc/started': No such file or directory
mkdir `/run/openrc/stopping': No such file or directory
mkdir `/run/openrc/inactive': No such file or directory
mkdir `/run/openrc/wasinactive': No such file or directory
mkdir `/run/openrc/failed': No such file or directory
mkdir `/run/openrc/hotplugged': No such file or directory
mkdir `/run/openrc/daemons': No such file or directory
mkdir `/run/openrc/options': No such file or directory
mkdir `/run/openrc/exclusive': No such file or directory
mkdir `/run/openrc/scheduled': No such file or directory
mkdir `/run/openrc/tmp': No such file or directory
 * Caching service dependencies ...
fopen `/run/openrc/deptree': No such file or directory
fopen `/run/openrc/depconfig': No such file or directory
 * Failed to update the dependency tree                                    [ !! ]
 swapfiles                                                          [  stopped  ]
 localmount                                                         [  stopped  ]
 sysctl                                                             [  stopped  ]
 fsck                                                               [  stopped  ]
 termencoding                                                       [  stopped  ]
 tmpfiles.setup                                                     [  stopped  ]
 net.lo                                                             [  stopped  ]
 mtab                                                               [  stopped  ]
 bootmisc                                                           [  stopped  ]
 hostname                                                           [  stopped  ]
 swap                                                               [  stopped  ]
 procfs                                                             [  stopped  ]
 keymaps                                                            [  stopped  ]
 hwclock                                                            [  stopped  ]
 urandom                                                            [  stopped  ]
 modules                                                            [  stopped  ]
 root                                                               [  stopped  ]
Runlevel: shutdown
mkdir `/run/openrc/starting': No such file or directory
mkdir `/run/openrc/started': No such file or directory
mkdir `/run/openrc/stopping': No such file or directory
mkdir `/run/openrc/inactive': No such file or directory
mkdir `/run/openrc/wasinactive': No such file or directory
mkdir `/run/openrc/failed': No such file or directory
mkdir `/run/openrc/hotplugged': No such file or directory
mkdir `/run/openrc/daemons': No such file or directory
mkdir `/run/openrc/options': No such file or directory
mkdir `/run/openrc/exclusive': No such file or directory
mkdir `/run/openrc/scheduled': No such file or directory
mkdir `/run/openrc/tmp': No such file or directory
 * Caching service dependencies ...
fopen `/run/openrc/deptree': No such file or directory
fopen `/run/openrc/depconfig': No such file or directory
 * Failed to update the dependency tree                                    [ !! ]
 killprocs                                                          [  stopped  ]
 savecache                                                          [  stopped  ]
 mount-ro                                                           [  stopped  ]
Dynamic Runlevel: hotplugged
mkdir `/run/openrc/starting': No such file or directory
mkdir `/run/openrc/started': No such file or directory
mkdir `/run/openrc/stopping': No such file or directory
mkdir `/run/openrc/inactive': No such file or directory
mkdir `/run/openrc/wasinactive': No such file or directory
mkdir `/run/openrc/failed': No such file or directory
mkdir `/run/openrc/hotplugged': No such file or directory
mkdir `/run/openrc/daemons': No such file or directory
mkdir `/run/openrc/options': No such file or directory
mkdir `/run/openrc/exclusive': No such file or directory
mkdir `/run/openrc/scheduled': No such file or directory
mkdir `/run/openrc/tmp': No such file or directory
 * Caching service dependencies ...
fopen `/run/openrc/deptree': No such file or directory
fopen `/run/openrc/depconfig': No such file or directory
 * Failed to update the dependency tree                                    [ !! ]
Dynamic Runlevel: needed
mkdir `/run/openrc/starting': No such file or directory
mkdir `/run/openrc/started': No such file or directory
mkdir `/run/openrc/stopping': No such file or directory
mkdir `/run/openrc/inactive': No such file or directory
mkdir `/run/openrc/wasinactive': No such file or directory
mkdir `/run/openrc/failed': No such file or directory
mkdir `/run/openrc/hotplugged': No such file or directory
mkdir `/run/openrc/daemons': No such file or directory
mkdir `/run/openrc/options': No such file or directory
mkdir `/run/openrc/exclusive': No such file or directory
mkdir `/run/openrc/scheduled': No such file or directory
mkdir `/run/openrc/tmp': No such file or directory
 * Caching service dependencies ...
fopen `/run/openrc/deptree': No such file or directory
fopen `/run/openrc/depconfig': No such file or directory
 * Failed to update the dependency tree                                    [ !! ]
Dynamic Runlevel: manual
mkdir `/run/openrc/starting': No such file or directory
mkdir `/run/openrc/started': No such file or directory
mkdir `/run/openrc/stopping': No such file or directory
mkdir `/run/openrc/inactive': No such file or directory
mkdir `/run/openrc/wasinactive': No such file or directory
mkdir `/run/openrc/failed': No such file or directory
mkdir `/run/openrc/hotplugged': No such file or directory
mkdir `/run/openrc/daemons': No such file or directory
mkdir `/run/openrc/options': No such file or directory
mkdir `/run/openrc/exclusive': No such file or directory
mkdir `/run/openrc/scheduled': No such file or directory
mkdir `/run/openrc/tmp': No such file or directory
 * Caching service dependencies ...
fopen `/run/openrc/deptree': No such file or directory
fopen `/run/openrc/depconfig': No such file or directory
 * Failed to update the dependency tree
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Fri Jun 14, 2013 6:00 pm    Post subject: Reply with quote

Je le mets en non résolu. Si jamais quelqu'un a les même problèmes que moi, je m'y replongerai. En attendant, j'ai réinstallé Mint (j'ai quand même besoin du PC...), bon sang, toutes ces années sous Gentoo, impossible de m'y faire au systèème Debian/Ubuntu, on a l'impression de ne rien contrôler... Bon l'essentiel c'est que ça marche, mais j'ai perdu la fulgurance au boot de ma machine...
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2862
Location: Paris

PostPosted: Fri Jun 14, 2013 10:06 pm    Post subject: Reply with quote

Retire le "non résolu" de ton titre, STP, conformément à nos usages.
_________________
-PC: 2500K/P8Z68V, 8Go DDR3 1600 1.35V, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC + NF9D-2700, 4Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RDNU2000
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum