Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
openoffice will alle "ß" durch "ss" ersetzen
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3873
Location: Irgendwo im Nirgendwo

PostPosted: Sat Mar 13, 2010 2:01 pm    Post subject: openoffice will alle "ß" durch "ss" erse Reply with quote

Ich hab leider ein bescheuertes Problem mit der Rechtschreibkorrektur von OpenOffice.
Die will einfach alle vorkommenden "ß" durch "ss" ersetzen, egal ob das jetzt Sinn macht oder nicht.
Ich weiß -> weiss
Straße ->Strasse
usw.

Eingestellt ist "Deutsch (Deutschland)"

Code:
$ paludis -q openoffice
* app-office/openoffice
    gentoo:                  3.1.1 (3.2.0)K {:0}
    installed:               3.1.1* {:0}
    Description:             OpenOffice.org, a full office productivity suite.
    Homepage:                http://go-oo.org
    License:                 LGPL-2
    Installed time:          Sun Jan 17 12:49:30 CET 2010
    Use flags:               (-aqua) (-bash-completion) (-binfilter) (cups) (dbus) (-debug) (-eds) (-gnome) (gstreamer) (-gtk) (-java) (kde) (-kdeenablefinal) (ldap) (-mono) (-nsplugin) (-odk) (opengl) (pam) (-templates) linguas: (-af) (-ar) (-as_IN) (-be_BY) (-bg) (-bn) (-br) (-brx) (-bs) (-ca) (-cs) (-cy) (-da) (de) (-dgo) (-dz) (-el) (-en) (-en_GB) (-en_US) (-en_ZA) (-eo) (-es) (-et) (-eu) (-fa) (-fi) (-fr) (-ga) (-gl) (-gu) (-he) (-hi_IN) (-hr) (-hu) (-id) (-it) (-ja) (-ka) (-kk) (-km) (-kn_IN) (-ko) (-kok) (-ks) (-ku) (-lt) (-mai) (-mk) (-ml_IN) (-mn) (-mni) (-mr_IN) (-nb) (-ne) (-nl) (-nn) (-nr) (-ns) (-oc) (-or_IN) (-pa_IN) (-pl) (-pt) (-pt_BR) (-ru) (-rw) (-sa_IN) (-sat) (-sd) (-sh) (-sk) (-sl) (-sr) (-ss) (-st) (-sv) (-sw_TZ) (-ta) (-ta_IN) (-te_IN) (-tg) (-th) (-ti_ER) (-tn) (-tr) (-ts) (-uk) (-ur_IN) (-uz) (-ve) (-vi) (-xh) (-zh_CN) (-zh_TW) (-zu) Build Options: -trace

Welche Infos könnt ihr noch brauchen?

Danke
Franz
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Sat Mar 13, 2010 5:10 pm    Post subject: Reply with quote

Das Problem hatte ich auch schonmal auf Arbeit beim verteilen der Suite. Kannst du mal deinen ~/.ooo3 Ordner bereitstellen, eventuell finde ich das Problem wieder.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3873
Location: Irgendwo im Nirgendwo

PostPosted: Sat Mar 13, 2010 6:12 pm    Post subject: Reply with quote

escor wrote:
Kannst du mal deinen ~/.ooo3 Ordner bereitstellen, eventuell finde ich das Problem wieder.

Ich hab das leider auch bei einem komplett frisch erstellten User :/
Ich werd das mal packen und hochladen (heute wohl eher nicht mehr). Ich denke nicht dass das mit einem verkorksten Userverzeichnis zu tun hat sondern evtl. an einer globalen verkonfigurierung/verinstallierung.
Die Schweizer haben kein ß, kann es sein dass da irgend was verdreht ist?
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3873
Location: Irgendwo im Nirgendwo

PostPosted: Sat Mar 13, 2010 6:22 pm    Post subject: Reply with quote

Ok, die Bayern haben Pause und der Reis ist noch nicht fertig...
here you are
Und allerbesten Dank!
Google war da so lieb und hat mich auf der Suche meist auf Rechtschreibbesserwisserdiskussionen geleitet :D
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1798
Location: Germany

PostPosted: Sun Mar 14, 2010 1:44 am    Post subject: Reply with quote

Also ich vermute das liegt...

a. an der Autokorrektur-Funkton
b. an der neuen Rechtschreibung

Ich werde morgen mal einen Blick drauf werfen.
Back to top
View user's profile Send private message
schachti
Advocate
Advocate


Joined: 28 Jul 2003
Posts: 3765
Location: Gifhorn, Germany

PostPosted: Sun Mar 14, 2010 11:42 am    Post subject: Reply with quote

Seltsam, ich habe das gleiche Problem mit der aktuellen Version 3.2.
_________________
Never argue with an idiot. He brings you down to his level, then beats you with experience.

How-To: Daten verschlüsselt auf DVD speichern.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3873
Location: Irgendwo im Nirgendwo

PostPosted: Sun Mar 14, 2010 1:37 pm    Post subject: Reply with quote

ChrisJumper wrote:
a. an der Autokorrektur-Funkton
b. an der neuen Rechtschreibung

a) Es wird ja nicht automatisch ersetzt, die Rechtschreibprüfung meckert nur an dass man "Straße" nicht mit "ß" schreibt, sondern eben mit "ss"...
b) Die neue Rechtschreibregelung? Hat die das "ß" komplett gestrichen?
Wäre mir nix gekannt...

@schachti
Mist, und ich hab gehofft, dass die 3.2er Besserung bringen könnte...
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Pro_metheus
n00b
n00b


Joined: 14 Mar 2008
Posts: 8
Location: Jenseits der Zeit

PostPosted: Sun Mar 14, 2010 3:03 pm    Post subject: Reply with quote

Hallo an alle :)

Ich hatte das Problem bis gestern auch.
Nach einigem herum experimentieren hab ich es wohl hin bekommen.
Ich bin folgendermaßen vorgegangen:

1. bisher installierte deutsche Wörterbücher in /home/<user>/.ooo3/user/wordbook/ gelöscht (weiß aber nicht, ob das unbedingt erforderlich war)
2. Textdatei mit oowriter geöffnet
3. unter Extras - Extension Manager - DE-frami und DE-Igerman98 Wörterbücher heruntergeladen und hinzugefügt
4. beide Wörterbücher im Extension Manager noch mal deaktiviert und danach wieder aktiviert (hatte sonst das Problem, dass die Wörterbücher nicht erkannt wurden)
5. unter /home/<user>/.ooo3/user/wordbook/ nachgeschaut, da gibt es mir jetzt nur noch die Datei standart.dic

Jetzt wird z.B "Straße" oder "weiß" als richtig und "Strasse" bzw. "weiss" als falsch gewertet.

Vielleicht hilfts auch bei euch ?

Viele Grüße
Pro_metheus
Back to top
View user's profile Send private message
schachti
Advocate
Advocate


Joined: 28 Jul 2003
Posts: 3765
Location: Gifhorn, Germany

PostPosted: Sun Mar 14, 2010 3:20 pm    Post subject: Reply with quote

Danke, nach Installation von de-DE igerman98 über den Extension Manager klappt es auch bei mir.
_________________
Never argue with an idiot. He brings you down to his level, then beats you with experience.

How-To: Daten verschlüsselt auf DVD speichern.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3873
Location: Irgendwo im Nirgendwo

PostPosted: Sun Mar 14, 2010 3:46 pm    Post subject: Reply with quote

Hat hier auch wunderbar geklappt :)
Wunder misch nur dass das Standard-dictionary so umfanglos ist.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Mon Mar 15, 2010 1:02 pm    Post subject: Reply with quote

Dann hat es sich wohl für mich erledigt :( schade :D
Back to top
View user's profile Send private message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1798
Location: Germany

PostPosted: Mon Mar 15, 2010 7:09 pm    Post subject: Reply with quote

Hatte mal nachgeschaut weil ich zuerst die Auto-Korrektur im Verdacht hatte. Ein ähnliches Phänomen hatte ich mal mit MS-Office.

Die Schweizer schreiben wohl Strasse und weiss.. verwirrt hat mich das jetzt aber trotzdem, woher kam der Fehler denn nun?

Verwendet ihr nicht auch:

Code:
$ eselect oodict list
Installed dictionary sources that can be set:
  [1]   myspell
    Installed language codes:
      de
Code:

$ $ eix myspell-de
[I] app-dicts/myspell-de
     Available versions:  20060316 20080915-r1
     Installed versions:  20080915-r1(13:20:16 07.07.2009)
     Homepage:            http://lingucomponent.openoffice.org/
     Description:         German dictionaries for myspell/hunspell

* app-dicts/myspell-de-alt
     Available versions:  20060124
     Homepage:            http://www.j3e.de/myspell/
     Description:         German dictionaries (traditional orthography) for myspell/hunspell

2 Treffer.


Unter /home/<user>/.ooo3/user/wordbook/ findet sich bei mir nur das standart.dic, welches selbst hinzugefügte Wörter enthält.
Back to top
View user's profile Send private message
schachti
Advocate
Advocate


Joined: 28 Jul 2003
Posts: 3765
Location: Gifhorn, Germany

PostPosted: Mon Mar 15, 2010 7:12 pm    Post subject: Reply with quote

Code:

segfault ~ # eselect oodict list
!!! Error: Can't load module oodict
exiting

_________________
Never argue with an idiot. He brings you down to his level, then beats you with experience.

How-To: Daten verschlüsselt auf DVD speichern.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3873
Location: Irgendwo im Nirgendwo

PostPosted: Mon Mar 15, 2010 7:31 pm    Post subject: Reply with quote

Code:
emerge eselect-oodict

brachte aber nix.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
bug_report
n00b
n00b


Joined: 17 Sep 2010
Posts: 65
Location: Frankfurt, Germany

PostPosted: Sat Jun 08, 2013 7:19 pm    Post subject: Reply with quote

Nachtrag, falls noch jemand diesen Thread liest: Das Problem sollte nun mit =myspell-de-2012.06.17-r1 behoben sein - siehe dazu auch Bug 447976

Also, man kann jetzt die selbst installierten Wörterbücher im Home-Verzeichnis wieder löschen und stattdessen myspell-de-2012.06.17-r1 installieren.
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1068
Location: Buchholz/GER

PostPosted: Mon Jun 10, 2013 4:35 am    Post subject: Reply with quote

bug_report wrote:
Nachtrag, falls noch jemand diesen Thread liest ...

Eigentlich nicht, jetzt aber schon. :)

Und da sage ich jetzt einfach mal danke, dass Du die abschließende Lösung nachträglich noch eingepflegt hast. Ich ärgere mich nämlich regelmäßig darüber, dass ich ins Suchmaschinen zwar mein Problem finde, aber nicht mehr die abschließende Lösung.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum