Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE Netbook Expose Black
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
anyNiXwilldo
Apprentice
Apprentice


Joined: 20 Feb 2004
Posts: 176
Location: US

PostPosted: Sat May 18, 2013 4:17 pm    Post subject: KDE Netbook Expose Black Reply with quote

I managed to setup a Gentoo binary install on my netbook optimized for the atom processor. Everything works perfectly except for one catch. When there are multiple windows opened in expose, the screen is black . Individual windows will appear normal if I roll the cursor over them, then go black once the cursor is moved off the windows for each app. Any clues what might cause this?
_________________
Of course you can have my root password. I'm on Hardened!
Back to top
View user's profile Send private message
papapenguin
l33t
l33t


Joined: 20 Sep 2005
Posts: 694
Location: Bellevue

PostPosted: Mon May 20, 2013 3:23 am    Post subject: Reply with quote

hello, I had a similar issue related to nvidia drivers...please take a look here...I'm not sure why it began working again, but it did...it may have had something to do with my video memory, but I don't really know...
http://forums.gentoo.org/viewtopic-t-895602-start-0-postdays-0-postorder-asc-highlight-papapenguin+black.html
_________________
--------------
Compaq Presario V6120US
AMD Turion 64X2
------------------------
Back to top
View user's profile Send private message
anyNiXwilldo
Apprentice
Apprentice


Joined: 20 Feb 2004
Posts: 176
Location: US

PostPosted: Mon May 20, 2013 2:43 pm    Post subject: Reply with quote

You may be onto something here and I appreciate the hint.

I read the post you linked here. It could well be a video memory issue. This netbook has the Intel video chip. Checking the BIOS shows only 8MB of memory used for video, out of a total of 2048MB. Unfortunately, the amount of memory used for video can not be changed in the BIOS. I have tried other distros on this netbook and did not have this issue. This makes me wonder if perhaps there is a setting in the kernel which could be adjusted for video memory.
_________________
Of course you can have my root password. I'm on Hardened!
Back to top
View user's profile Send private message
papapenguin
l33t
l33t


Joined: 20 Sep 2005
Posts: 694
Location: Bellevue

PostPosted: Mon May 20, 2013 2:58 pm    Post subject: Reply with quote

it does...look here
http://www.gentoo.org/doc/en/kernel-config.xml
_________________
--------------
Compaq Presario V6120US
AMD Turion 64X2
------------------------
Back to top
View user's profile Send private message
anyNiXwilldo
Apprentice
Apprentice


Joined: 20 Feb 2004
Posts: 176
Location: US

PostPosted: Mon May 20, 2013 7:03 pm    Post subject: Reply with quote

I have all of those set in the kernel config, at least as far as memory. Since this is the first Intel I ever bought in my life, I followed the Gentoo Wiki as far as the kernel config for the intel video chip, but started fresh with Pappy's kernel seed.

I am wondering if this may be related to the binaries, which were all compiiled on an AMD quad-core, although set to build -march=atom -Os. I have compiled xorg-server on the netbook itself, to see if that might make a difference. Additionally, portage isn't handling the kernel. I download the libre kernel, apply the ck-patches, then build and install. I don't think this would cause an issue since the Intel video drivers are liberated anyway & Parabola, Trisquel and Wheezy all include a liberated kernel by default and none had this issue. This is just such a bizarre issue to track down and I have no idea what could be causing it.
_________________
Of course you can have my root password. I'm on Hardened!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum