Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gimp 2.8 only runs in root? [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 823
Location: Tri-Cities, WA USA

PostPosted: Thu May 16, 2013 11:32 am    Post subject: gimp 2.8 only runs in root? [solved] Reply with quote

I installed gimp 2.8 emerge =media-gfx/gimp-2.8.4 on my amd machine.
azzerare ~ # uname -a
Linux azzerare 3.7.10-gentoo-r1 #1 SMP Wed Apr 17 13:06:21 PDT 2013 x86_64 AMD Athlon(tm) 64 Processor 3400+ AuthenticAMD GNU/Linux

Gimp 2.8 ran for a while now no luck.
There is no error message it just will not open.
From gnome or tty.

Any ideas?
_________________
Without diversity there can be no evolution:)


Last edited by cwc on Fri May 17, 2013 12:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1234

PostPosted: Thu May 16, 2013 3:06 pm    Post subject: Reply with quote

If it still runs as root what do you get from
Code:
ls -la /usr/bin/gimp
?
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 823
Location: Tri-Cities, WA USA

PostPosted: Thu May 16, 2013 11:17 pm    Post subject: Reply with quote

turtles wrote:
If it still runs as root what do you get from
Code:
ls -la /usr/bin/gimp
?


azzerare bin # ls -la /usr/bin/gimp
lrwxrwxrwx 1 root root 8 May 15 22:38 /usr/bin/gimp -> gimp-2.8
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 823
Location: Tri-Cities, WA USA

PostPosted: Thu May 16, 2013 11:21 pm    Post subject: Reply with quote

turtles wrote:
If it still runs as root what do you get from
Code:
ls -la /usr/bin/gimp
?


azzerare bin # ls -la /usr/bin/gimp
lrwxrwxrwx 1 root root 8 May 15 22:38 /usr/bin/gimp -> gimp-2.8

?
I also cleared the .gimp2.8 directory in my user directory along with the .gimp2.6 directory


Thanks for the line.
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1234

PostPosted: Thu May 16, 2013 11:53 pm    Post subject: Reply with quote

Whats the terminal output from running
Code:
/usr/bin/gimp
?
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 823
Location: Tri-Cities, WA USA

PostPosted: Fri May 17, 2013 11:26 am    Post subject: Reply with quote

turtles wrote:
Whats the terminal output from running
Code:
/usr/bin/gimp
?



I finally got gimp 2.8 working.

- Deleted gimp 2.8 and media-libs/gegl media-libs/babl
- Installed gimp 2.8 again
- But what I think really worked was rebooting. dbus was restarted properly with a reboot and a new dbus was installed this week
/etc/init.d/dbus restart hangs

Do you thing dbus had anything to do with it?

Thanks!
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1234

PostPosted: Sun May 19, 2013 3:08 am    Post subject: Reply with quote

(Posting in correct thread this time)
Strange.. Looks like gimp has a dep on dev-libs/dbus-glib.
I have had problems with gimp bringing in weird dependencies.
like webkit.

Does dbus still hang when it starts?
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 823
Location: Tri-Cities, WA USA

PostPosted: Thu May 30, 2013 12:16 pm    Post subject: Reply with quote

turtles wrote:
(Posting in correct thread this time)
Strange.. Looks like gimp has a dep on dev-libs/dbus-glib.
I have had problems with gimp bringing in weird dependencies.
like webkit.

Does dbus still hang when it starts?


Yes. Thanks for the line!
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum